.Net Support in PortableApps.com Apps

The PortableApps.com Platform and App Store support apps that utilize the .Net Framework. Apps include details about which .Net version they require and the PortableApps.com Platform will automatically check for support before launching the app. It will even offer to assist the user with downloads, which link to this page. If you are unsure what version of Windows you are running and whether is 32-bit or 64-bit, you can select Help and then About in the PortableApps.com Platform and look in the lower left of the About window.

.Net 5, 6, and 7 Bundles

These portable apps bundle the appropriate and work out of the box on modern Windows

  • Windows 8.1, 10, 11 - Apps will work out of the box
  • Windows 8.0 - Install a free upgrade to Windows 8.1 as Windows 8.0 is no longer supported
  • Windows 7 - Install the Platform Update for Windows 7 if it has not already been installed. Select the appropriate x64 64-bit or x86 32-bit download.
  • Windows XP, Vista - Not compatible with .Net Core or .Net 5+

.Net Framework 4 or 3.5, 4 or 3, 4 or 2

These apps will work with two versions of the .Net Framework and work out of the box on modern Windows

.Net Framework 4.x

  • Windows 8.1, 10, 11 with updates - Apps will work out of the box. Apply all updates in Windows Update. If needed, you can download the .Net Framework 4.8 web installer.
  • Windows 8 - Apps requiring .Net Framework 4 and 4.5 will work out of the box. Your PC should automatically update to 4.6, but if it does not, you can Download .Net Framework 4.6, the last version to support your OS. To run apps requiring .Net Framework 4.7 or 4.8, you can install a free upgrade to Windows 8.1.
  • Windows 7 - While a version of .Net Framework may be installed, it may not be updated to the current release. It's recommended you use the .Net Framework 4.8 web installer to install the latest version.
  • Windows Vista - Download .Net Framework 4.6, which is is the latest to support your operating system. Apps that require .Net Framework 4.7 or 4.8 are not compatible with Windows Vista.
  • Windows XP - Download .Net Framework 4.0 to run .Net Framework 4, 4or3.5, and 4or2 portable apps. Apps that require .Net Framework 4.5 and later are not compatible with Windows XP.

.Net Framework 3.5

.Net Framework 3.0

.Net Framework 2.0

.Net Framework 1.1

  • Windows 8, 8.1, 10, 11 - Not supported
  • Windows 2000, XP, 7 - Download and install .Net Framework 1.1. You will likely need to uninstall any later versions of .Net Framework before installing (except .Net 2/3/3.5 pre-bundled in Windows 7).

.Net Framework 1.0

  • Windows 8, 8.1, 10, 11 - Not supported
  • Windows 2000, XP, 7 - Download and install .Net Framework 1.0. You will likely need to uninstall any later versions of .Net Framework before installing (except .Net 2/3/3.5 pre-bundled in Windows 7).

.Net Core 1.0 to 3.1 or .Net 5 -7

.Net Core and .Net 5+ require installation on the local PC when not bundled with the app or bundled with Windows. They support Windows 7, 8.1, 10, and 11. .Net 1.x may support Windows 8.0 but it is recommended to upgrade to Windows 8.1.