You are here

PortableApps Suite 1.5 Installer Problem

12 posts / 0 new
Last post
ingai
Offline
Last seen: 13 years 2 months ago
Joined: 2008-10-15 10:35
PortableApps Suite 1.5 Installer Problem

After I installed PortableApps Suite v1.5 over the previous version, I began to install the latest version of some applications. Although I could finish installing the apps, the application installer would freeze at the end. I had to use Ctrl-Alt-Delete to select the task and end it. Does anyone know why? Is there a fix?

I tried 2 USB sticks on 2 PCs, the results were the same.

Thanks

John T. Haller
John T. Haller's picture
Online
Last seen: 7 min 47 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Other Menus

Hi ingai. The only time we've seen this so far is if you have a copy of a portableapps menu mod or similar running at the same time. Is that the case? If not, is it installed to the standard location (X:\PortableApps\PortableApps.com), nothing else unusual? Are the About and Rename windows closed when this happens? Also, what operating system, etc?

Sometimes, the impossible can become possible, if you're awesome!

ingai
Offline
Last seen: 13 years 2 months ago
Joined: 2008-10-15 10:35
Hi John, I've never modified

Hi John,

I've never modified PortableApps.

I've upgraded two USB flash drives (different brands) and a USB 2.5 inches hard drive to the latest PortableApps Suite v1.5 (without uninstalling the previous version). At any one time, there was only one copy of PortableApps running either from a USB flash drive or 2.5 inches hard drive.

v1.5 was installed in the default location on my USB devices.

About and Rename windows were not opened when the installer crashed.

Operation system was XP Pro (English version).

I've even tried installing an application on a flash drive with a desktop and notebook PCs. The installer crashed at both times.

John T. Haller
John T. Haller's picture
Online
Last seen: 7 min 47 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Hmm

Really odd. I can't recreate this one at all.

Is it XP Pro SP3?
Is PortableApps.com Platform 1.5 installed to X:\PortableApps\PortableApps.com and then started up?
Was Backup/Restore window open?
What app are you trying to install? Where are you running it from?
What antivirus, firewall and antimalware software are you running? Can you try again with it disabled?

Sometimes, the impossible can become possible, if you're awesome!

ingai
Offline
Last seen: 13 years 2 months ago
Joined: 2008-10-15 10:35
Yes, my PCs have XP Pro

Yes, my PCs have XP Pro SP3.

PortableApps.com Suite v1.5 was by default installed in X:\. I tried installing in X:\PortableApps\PortableApps.com, however, at both times the Installer froze at "Refreshing PortableApps.com Menu". I had to use Ctrl-Alt-Delete to end the task.

Backup/Restore windows were never opened.

Apps I tried to install were those released on Mar 7. I ran all the upgrades from my desktop PC.

I'm using ESET Smart Security v3.0.650.0. I've tried disabling ESET; reinstalled Suite v1.5; reinstalled Cornice Portable v0.6.1.2. However, the installer still crashed!

Furthermore, after I reinstalled with PortableApps.com Suite Setup 1.1 (default X:\); with ESET enabled; the installer no longer crashed.

Asiangotchi
Offline
Last seen: 12 years 2 months ago
Joined: 2008-12-01 23:17
Same here. It freezes when it

Same here. It freezes when it attempts to refresh the portableapps menu. I'd have to end the process, exit the menu and install it again for it to work.

John T. Haller
John T. Haller's picture
Online
Last seen: 7 min 47 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Details

Again, looking for the same details I posted above. I can not reproduce the issue even with two menus open or an old and new menu open. Without details, I can't determine the issue.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Online
Last seen: 7 min 47 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fix Posted: 1.5.1 Test Release

I have posted a fix which should address the issue here:
https://portableapps.com/node/18475

Please test current app installers (which won't auto-refresh the menu) as well as the included Cornice sample app which will refresh both the 1.5 and the 1.5.1 release without hanging. Report all results in the linked post. Thanks!

Sometimes, the impossible can become possible, if you're awesome!

ingai
Offline
Last seen: 13 years 2 months ago
Joined: 2008-10-15 10:35
PortableApps.com Suite 1.5

PortableApps.com Suite 1.5 works fine with Cornice_Portable_0.6.1.2 INSTALLERTEST.paf.exe.

PortableApps.com_Platform_Setup_1.5.1_RC1.exe works fine with Cornice_Portable_0.6.1.2.paf.exe.

Thanks for your speedy response, John.

John T. Haller
John T. Haller's picture
Online
Last seen: 7 min 47 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Thanks

Thanks, can you confirm if 1.5 and the official Cornice release still hangs for you? It's a rare issue and the two testers I had working with me their PCs suddenly stopped hanging on everything.

Sometimes, the impossible can become possible, if you're awesome!

ingai
Offline
Last seen: 13 years 2 months ago
Joined: 2008-10-15 10:35
I tried 1.5 again. As I said

I tried 1.5 again. As I said before, 1.5 still hangs with official Cornice release during installation per se; however, it doesn't hang my PC. 1.5.1 RC1 solves this minor inconvenience.

John T. Haller
John T. Haller's picture
Online
Last seen: 7 min 47 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Thanks

Great, thanks. Looks like we've got it.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments