You are here

TypeError: str is undefined

11 posts / 0 new
Last post
Esgrimidor
Offline
Last seen: 9 years 2 months ago
Joined: 2008-09-16 17:36
TypeError: str is undefined

I have observed this windows happen while downloading from a msn.com account.

[JavaScript Application]
TypeError : str is undefined

the downloading is very slow.

In general :
gmail and hotmail accounts don't go well. Seem dowload only a few emails .
By example : today 08.09.2010 download four emails from the date 08.02.2010 .
And I see all emails are not download.

I have multiple filters defined for these accounts.

I suppose I need to reconstruct my profile or try to repair step by step.

What can i do ?

Best Regards.

Esgrimidor
Offline
Last seen: 9 years 2 months ago
Joined: 2008-09-16 17:36
TypeError: str is undefined

It's a bug.

Nobody knows nothing and I obtain the same error in a clean installation.

Do you know how much time take to make good the new Thunderbird version ?

Best Regards

P.D. Windows xp + sp3
Avast or AVG free antivirus
all the same I have time ago.

Windows xp pro sp3
Last version Thunderbird portable

Esgrimidor
Offline
Last seen: 9 years 2 months ago
Joined: 2008-09-16 17:36
This version 3.1.2 is a

This version 3.1.2 is a complete disaster for me.

Do you know an addon to locate duplicate emails ?

Best Regards

Windows xp pro sp3
Last version Thunderbird portable

J Neutron
Offline
Last seen: 2 months 2 weeks ago
Joined: 2008-06-10 19:26
Talking to yourself

Sorry it seems like you are talking to yourself. I believe that others have not experienced the issues that you have.

You should re-fresh ThunderbirdPortable by downloading it again and running the package. It will write over the program stuff and leave all of the your data and profile alone.

Next, you should follow the directions on the support page:
https://portableapps.com/support/thunderbird_portable#performance

Hopefully that will solve the issue you are having. There are many of us running this version successfully.

neutron1132 (at) usa (dot) com

Esgrimidor
Offline
Last seen: 9 years 2 months ago
Joined: 2008-09-16 17:36
I have made clean

I have made clean installation and obtain the same message.
I use windows xp pro + sp3 , spanish version.
I have made a clean installation in other pc and obtain the same message, but all downloading goes well.

May be a bug only for me ?

Windows xp pro sp3
Last version Thunderbird portable

J Neutron
Offline
Last seen: 2 months 2 weeks ago
Joined: 2008-06-10 19:26
How clean?

Are you running the installation with no extensions or add-ons?

How about if you run in English temporarily? It could be a problem with the language.

neutron1132 (at) usa (dot) com

Esgrimidor
Offline
Last seen: 9 years 2 months ago
Joined: 2008-09-16 17:36
Best Regards J Neutron. May

Best Regards J Neutron.
May be may be.
I am the spanish version of TB3 with a spanish version of windows.
I am not a programmer.
I hope the programmers solve their BUG.

Thank a lot for your companion and confidence.
Best Regards.

Windows xp pro sp3
Last version Thunderbird portable

Esgrimidor
Offline
Last seen: 9 years 2 months ago
Joined: 2008-09-16 17:36
It's a bug definitely

I made another installation in the same pc.
Redefined from zero all accounts and filters.
No errors now.
So the problem is inside the folder Data in the old installation.

So I make a security copy and put the parallel data folder in its place.
No errors now.
So the problem definitely is inside the the old data folder.

How can I depure the old data folder to identificate the bug ?

Best Regards

Windows xp pro sp3
Last version Thunderbird portable

J Neutron
Offline
Last seen: 2 months 2 weeks ago
Joined: 2008-06-10 19:26
Mozilla knowledgebase

If you look at Mozilla knowledgebase article:

http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Thunderbird

You will see the bits and pieces that make up the profile.

Make a copy of your good profile as a backup. Then, I would copy one thing at a time (say, the addressbook) from your broken profile into your new profile and see what happens. If your new installation still works correctly, then bring over another piece of your old profile. Once it breaks, STOP, and restore the clean files back from the backup profile. Then you can bring over the rest of the old profile, again, one step at a time.

neutron1132 (at) usa (dot) com

Esgrimidor
Offline
Last seen: 9 years 2 months ago
Joined: 2008-09-16 17:36
Thank J. Neutron At the

Thank J. Neutron

At the present moment I made a complete new portable installation.
Define from zero all accounts
Define from zero all filters
And now I will install again the addons.
But I use the addon import/export to import to the new installation some folders from the old installation.
All goes well.
So , as you say, my old profile is corrupted.

I will take a good look to the link

Best regards

Windows xp pro sp3
Last version Thunderbird portable

J Neutron
Offline
Last seen: 2 months 2 weeks ago
Joined: 2008-06-10 19:26
Good

I'm glad that you have solved the problem.

Good luck to you!

neutron1132 (at) usa (dot) com

Log in or register to post comments