You are here

[Released] Spybot - Search & Destroy Portable 1.6.2 Development Test 5

43 posts / 0 new
Last post
scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
[Released] Spybot - Search & Destroy Portable 1.6.2 Development Test 5

Application: Spybot - Search & Destroy
Category: Security
Description:

Spybot - Search & Destroy detects and removes spyware, a relatively new kind of threat not yet covered by common anti-virus applications. Spyware silently tracks your surfing behaviour to create a marketing profile for you that is transmitted without your knowledge to the compilers and sold to advertising companies. If you see new toolbars in your Internet Explorer that you haven't intentionally installed, if your browser crashes inexplicably, or if your home page has been "hijacked" (or changed without your knowledge), your computer is most probably infected with spyware. Even if you don't see the symptoms, your computer may be infected, because more and more spyware is emerging. Spybot-S&D is free, so there's no harm giving it a try to see if something has invaded your computer.

Spybot-S&D can also clean usage tracks, an interesting function if you share your computer with other users and don't want them to see what you have been working on. And for professional users, Spybot-S&D allows you to fix some registry inconsistencies and extended reports.

Download Spybot - Search & Destroy Portable 1.6.2 Development Test 5 [19.4MB download / 52.7MB installed]
(MD5: 2f87c5893ece271c129bd8c368134d87)

Release Notes:
1.6.2 Development Test 5 (2010-12-13)

  • Fixed folders being left behind in %ProgramFiles%

1.6.2 Development Test 4 (2010-12-13)

  • Fixed not saving settings in Windows 2000/Windows XP
  • Fixed double ampersand issue in the installer

1.6.2 Development Test 3 (2010-10-25)

  • Launcher now cleans up left behind registry keys

1.6.2 Development Test 2 (2010-10-25)

  • User must now agree to the EULA before installing Spybot - Search & Destroy Portable

1.6.2 Development Test 1 (2010-10-24): Initial release

Known Issues:

  • Language switching does not work with Windows Vista or greater
  • Spybot - Search & Destroy Portable leaves behind Eventlog entries

Notes:

  • Administrator rights are required for all features to work properly
  • For personal use only
  • Bundled with permission
I was told that a while back PortableApps.com had been granted permission to bundle Spybot as a portable application. I wanted to verify this was true myself (since nobody else has packaged it yet, I figured why not possibly do it myself), and ask if this applied to any of your other utilities (RegAlyzer, FileAlyzer, etc.). I'm quite busy with classes at the moment so Spybot Portable might take a bit, however your other utilities seem to be much easier to package for the time being. If I was told wrong and we have not been given permission to do so, then I apologize for not further checking first.

Hello Kenny,

There should not be a problem with this, as long as you make clear that this is only for the private use. Smile

Best regards
Sandra
Team Spybot

  • Thanks to Chris Morgan for hosting
horusofoz
horusofoz's picture
Offline
Last seen: 1 year 7 months ago
Joined: 2008-04-03 22:45
Thanks Scriptdaemon

Thanks for this. It's been on my most wanted list for some time. Will test for a while and see how it goes.

An initial thought regarding TeaTimer, is it wanted?

I, and I believe most SpyBot users, use SpyBot as a secondary scanner therefore resident scanning is not required. As a PortableApp I would think this would be even more the case.

From memory TeaTimer closely monitors (and possibly hooks into) the registry acting almost like a firewall. This would be quite a handful to manage portably.

Anyway thanks again Smile

PortableApps.com Advocate

Darkbee
Darkbee's picture
Offline
Last seen: 2 years 6 months ago
Joined: 2008-04-14 09:41
Time for Tea

I have to admit that I have been using TeaTimer, not really for myself but for other family members who are less cautious with their surfing habits (click click click format C: yes/no? click click).

I can certainly test at home how well SpybotPortable plays with the real TeaTimer. For the most part AFAIK they are two separate and distinct entities but we shall see.

As you said, TeaTimerPortable would be nice but I could quite easily see it being a nightmare with all the system hooks and what-not.

Oh yes, and I almost forgot.. Thanks ScriptDaemon, this is probably one of the most requested apps of all time, ever. Smile

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 5 months ago
Joined: 2007-04-15 21:08
PAF good, portability needs work

PAF pass with no issues except the icon being horrible (as you said) and help.html not encoding the & character as & (not an issue except that it's not valid HTML).

Tested on XP SP3, administrator. Language switching worked.

Some keys have been left behind:

HKLM\SOFTWARE\Classes\.disabled
HKLM\SOFTWARE\Classes\.sbe
HKLM\SOFTWARE\Classes\.sbi
HKLM\SOFTWARE\Classes\.sbs
HKLM\SOFTWARE\Classes\.tnfo
HKLM\SOFTWARE\Classes\.uti
HKLM\SOFTWARE\Classes\.uts
HKLM\SOFTWARE\Classes\SpybotSD.DisabledFile
HKLM\SOFTWARE\Classes\SpybotSD.SBEFile
HKLM\SOFTWARE\Classes\SpybotSD.SBIFile
HKLM\SOFTWARE\Classes\SpybotSD.SBSFile
HKLM\SOFTWARE\Classes\SpybotSD.TInfoFile
HKLM\SOFTWARE\Classes\SpybotSD.UTIFile
HKLM\SOFTWARE\Classes\SpybotSD.UTSFile
HKLM\SOFTWARE\Safer Networking Limited
HKLM\SYSTEM\CurrentControlSet\Services\Eventlog\Application\SNL HiveManager
HKLM\SYSTEM\CurrentControlSet\Services\Eventlog\Application\Spybot - Search & Destroy 2

The use of the event log is not quite desirable. There's an extra value which is not altered due to it as well:

Before: HKLM\SYSTEM\CurrentControlSet\Services\Eventlog\Application\Sources: 'WSH WMIAdapter WmdmPmSN WinMgmt Winlogon Windows Product Activation Windows 3.1 Migration WgaSetup WebClient VSS VBRuntime Userinit Userenv Tlntsvr SysmonLog Starter SpoolerCtrs Software Restriction Policies Software Installation SecurityCenter SclgNtfy SceSrv SceCli safrslv SAFrdms RPC Remote Assistance PerfProc PerfOS PerfNet Perfmon Perflib PerfDisk Perfctrs Offline Files Oakley ntbackup MSSQLSERVER/MSDE MSSHA MsiInstaller MSDTC Client MSDTC mnmsrvc Microsoft H.323 Telephony Service Provider LoadPerf HelpSvc Folder Redirection File Deployment EventSystem ESENT DrWatson Dot3Svc DiskQuota crypt32 COM+ COM Ci Chkdsk AutoEnrollment Autochk Application Management Application Hang Application Error Application'
After:  HKLM\SYSTEM\CurrentControlSet\Services\Eventlog\Application\Sources: 'Spybot - Search & Destroy 2 SNL HiveManager WSH WMIAdapter WmdmPmSN WinMgmt Winlogon Windows Product Activation Windows 3.1 Migration WgaSetup WebClient VSS VBRuntime Userinit Userenv Tlntsvr SysmonLog Starter SpoolerCtrs Software Restriction Policies Software Installation SecurityCenter SclgNtfy SceSrv SceCli safrslv SAFrdms RPC Remote Assistance PerfProc PerfOS PerfNet Perfmon Perflib PerfDisk Perfctrs Offline Files Oakley ntbackup MSSQLSERVER/MSDE MSSHA MsiInstaller MSDTC Client MSDTC mnmsrvc Microsoft H.323 Telephony Service Provider LoadPerf HelpSvc Folder Redirection File Deployment EventSystem ESENT DrWatson Dot3Svc DiskQuota crypt32 COM+ COM Ci Chkdsk AutoEnrollment Autochk Application Management Application Hang Application Error Application'

Also the directory C:\Documents and Settings\All Users\Application Data\Spybot - Search & Destroy was left behind with various data. There's a [DirectoriesMove] entry which should deal with it, so I'm not sure what happened there. I'll need to try it again another day.

I did go to the immunisation tab but didn't do anything with it.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
...What?

Tested on XP SP3, administrator. Language switching worked.

Language switching worked with admin rights? If so, then it seems that issue has somehow been fixed because this is still using RunAsAdmin=try (or should be; I'm pretty sure I changed it back).

As far as all those keys go, should I just remove them? I don't think any of that needs to be backed up (except maybe HKLM\SOFTWARE\Safer Networking Limited).

And lastly, is there anything I can do about the event log in this case?

I'll put a new DT tonight after work.

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 5 months ago
Joined: 2007-04-15 21:08
XP as admin

I'm not surprised language switching is working; bear in mind that I was running on XP with admin already, so there's no elevation done and no UAC prompt. A more interesting issue is whether it works on Vista/7, and I don't have VMs set up for them yet.

There will be some DLL call for the event log (don't know what it would be). I suspect it might not be safe to just backup and delete them. You could try it though.

[RegistryKeys]
-=HKLM\SYSTEM\CurrentControlSet\Services\Eventlog\Application\SNL HiveManager
-=HKLM\SYSTEM\CurrentControlSet\Services\Eventlog\Application\Spybot - Search & Destroy 2

[RegistryValueBackupDelete]
1=HKLM\SYSTEM\CurrentControlSet\Services\Eventlog\Application\Sources

I think those registry keys should be fine to just backup and delete (file name of -), and HKLM\Software\Safer Networking Limited may as well be kept.

Edit: probably something like this for the event log stuff.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
Updated. I still haven't

Updated.

I still haven't worked out how to do the Eventlog stuff though.

z25blink
Offline
Last seen: 7 years 11 months ago
Joined: 2009-11-18 20:30
nice

Spybot - Search & Destroy Portable

Moonbase
Offline
Last seen: 8 years 10 months ago
Joined: 2010-09-09 06:16
A valuable addition

A valuable addition to the PA portfolio, I think. If it can be made really "clean".

Personally, Spybot S&D is usually my 2nd choice after the (installed) virus scanner. I almost never use TeaTimer, and if so, only on installed Spybot versions. I feel it wouldn’t be required for a portable app. After all, with tools like Spybot S&D it’s usually "come over, help someone, and leave".

Just my 2 cents while timing the tea … Wink

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
I thank the users who have

I thank the users who have provided feedback on whether or not to include TeaTimer. I think I might leave it out then, if this is the general consensus.

brum74
Offline
Last seen: 9 years 9 months ago
Joined: 2009-04-11 11:29
Small issue with the name

Small issue with the name being displayed in the menu. The name shows as "Spybot - Search _Destroy Portable" but should be "Spybot - Search & Destroy Portable". If you add a 2nd & to the appinfo.ini then the menu displays it correctly, however this causes 2 &'s to be displayed in the tooltip. This might be more of a menu issue but figured i'd mention it here.

Once you go portable...

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
I know.

I've already reported it here.

Thank you, though.

brum74
Offline
Last seen: 9 years 9 months ago
Joined: 2009-04-11 11:29
Ok, didn't see that. Maybe

Ok, didn't see that. Maybe for now you can use && and have the tooltip display incorrectly until the menu is fixed?

Once you go portable...

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 5 months ago
Joined: 2007-04-15 21:08
More than that

It's more that that - the installer also shows Search _Destroy some times and Search & Destroy other times, so it would affect that too.

The only really feasible solution without considerable work in the Platform and Installer for just one app is what I suggested to scriptdaemon: just keep it Spybot Portable.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
I'm going to do that, just

I'm going to do that, just didn't have time to upload it yet. I'll be off work in about ~45 minutes, so I'll do it then.

John T. Haller
John T. Haller's picture
Online
Last seen: 17 min 10 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
We'll Fix It

Keep it as Spybot - Search & Destroy as that is their registered trademark name. I'll fix it in the installer and platform in the next releases.

Sometimes, the impossible can become possible, if you're awesome!

brum74
Offline
Last seen: 9 years 9 months ago
Joined: 2009-04-11 11:29
The delphi fix should be very

The delphi fix should be very simple just set ShowAccelChar = False. I just ran a test using a TLabel, which I believe the menu is using, and the ampersands are displayed. As for the installer I see what you mean, had to run it again as I missed it the 1st time.

Once you go portable...

John T. Haller
John T. Haller's picture
Online
Last seen: 17 min 10 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
More Complicated

It's more complicated than that for the installer as the AppName is woven into NSIS itself in multiple locations, so we'll need to override a few things. It may get messy.

Sometimes, the impossible can become possible, if you're awesome!

brum74
Offline
Last seen: 9 years 9 months ago
Joined: 2009-04-11 11:29
I know it might be more

I know it might be more involved but I did some research for NSIS and found something interesting. I think it might be how Name is being set in the script. It takes a second optional parameter which is explicitly for when a name has ampersands.

Name "${PORTABLEAPPNAME}"

would need to be something like:

Name "${PORTABLEAPPNAME}" "${PORTABLEAPPNAME_DOUBLED_AMPERSANDS}"

I did a couple basic tests and it seems to work. How you would generate the double ampersands part I'm not sure as my NSIS knowledge is limited.

Hope this helps.

Once you go portable...

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 5 months ago
Joined: 2007-04-15 21:08
Hmm...

I'd never noticed that before.

OK, I take back what I said about its being difficult; it's really very easy to fix.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

John T. Haller
John T. Haller's picture
Online
Last seen: 17 min 10 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fixed

It wasn't super easy, but it was a few lines of code to generate and then adding it into the proper places without doing it in places where it showed up twice. I think I have it sorted and it's in 2.0.6.

Sometimes, the impossible can become possible, if you're awesome!

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
:)

Thanks.

kiriko
kiriko's picture
Offline
Last seen: 7 months 3 weeks ago
Developer
Joined: 2009-03-08 22:50
Thanks

Thanks this works like a charm! Smile

Mark Sikkema
Offline
Last seen: 11 years 2 months ago
Developer
Joined: 2009-07-20 14:55
Issues

I had a rough go on SpybotPortable and ran into several new issues, all tested on XP sp3 admin and/or non-admin.

  1. After using the 'Search for updates' feature, I ended-up with 4 packages being installed to %PROGRAMFILES% (sorry, this is probably a portability killer Sad )

    C:\Program Files\File Scanner Library (Spybot - Search & Destroy)\advcheck.dll
    C:\Program Files\Misc. Support Library (Spybot - Search & Destroy)\Tools.dll
    C:\Program Files\SDHelper (Spybot - Search & Destroy)\KIBPDCRSTALOL.scr
    C:\Program Files\SDHelper (Spybot - Search & Destroy)\SDHelper.dll
    C:\Program Files\TeaTimer (Spybot - Search & Destroy)\GYSCUGE.scr
    C:\Program Files\TeaTimer (Spybot - Search & Destroy)\TeaTimer.exe
    
  2. Allthought language swithing from PAM works no matter it's admin or not (actually I've got no idea how admin or not, could ever make a difference as all PAL has to do is modify a HKCU value), it gets broken whenever SpybotP is ran directly.
    Why are you writing the language value as an INI, but reading the value with ConfigRead ?
    The ConfigRead is probably not doing the intended job somehow !
  3. On my OS the directory to be moved is:
    '%ALLUSERSPROFILE%\Application Data\Spybot - Search & Destroy'
    instead of
    '%ALLUSERSPROFILE%\Spybot - Search & Destroy'

Formerly Gringoloco
Windows XP Pro sp3 x32

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
1. I never noticed even the

1. I never noticed even the installed app on my comp ever doing that. I'll have to investigate. I can talk to Safer Networking and see if they can fix it if it's still a problem.

2. ChrisMorgan suggested doing it that way. I'll take a look at it again to see if it still makes sense (or he could investigate it in the launcher if he sees this).

3. I'll double check this as well.

I should have some time over the weekend to look over this.

htismaqe
Offline
Last seen: 6 years 5 months ago
Joined: 2010-10-01 10:54
I see the same behaviors...

It creates 4 folders in %PROGRAMFILES%.

C:\Program Files\File Scanner Library (Spybot - Search & Destroy)\advcheck.dll
C:\Program Files\Misc. Support Library (Spybot - Search & Destroy)\Tools.dll
C:\Program Files\SDHelper (Spybot - Search & Destroy)\KIBPDCRSTALOL.scr
C:\Program Files\SDHelper (Spybot - Search & Destroy)\SDHelper.dll
C:\Program Files\TeaTimer (Spybot - Search & Destroy)\GYSCUGE.scr
C:\Program Files\TeaTimer (Spybot - Search & Destroy)\TeaTimer.exe

Like Mark, I'm on XP SP3 and it creates the necessary data in %ALLUSERSPROFILE%\Application Data\Spybot - Search & Destroy instead of %ALLUSERSPROFILE%\Spybot - Search & Destroy. So when you close the app, it doesn't move any of the files. Not only are they left stranded on the local machine but that folder contains the settings INI files so Spybot doesn't automatically keep track of its settings.

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
The settings should be saved.

The settings should be saved. It always retains its settings when I run it. Odd.

htismaqe
Offline
Last seen: 6 years 5 months ago
Joined: 2010-10-01 10:54
stranded folder, no saved settings = same issue

The cause of my issue is the same as Mark - it appears the main Spybot EXE is creating its data directory in %ALLUSERSPROFILE%\Application Data\Spybot - Search & Destroy. The settings are stored in that directory, in the configuration.ini file.

The issue is that the SpybotPortable.ini tries to execute [DirectoriesMove] against %ALLUSERSPROFILE%\Spybot - Search & Destroy, which doesn't exist on my PC. The launcher leaves behind %ALLUSERSPROFILE%\Application Data\Spybot - Search & Destroy instead of copying everything back to flash.

The next time I run it, the main Spybot EXE creates %ALLUSERSPROFILE%\Application Data\Spybot - Search & Destroy again, overwriting everything in the directory including the settings file.

htismaqe
Offline
Last seen: 6 years 5 months ago
Joined: 2010-10-01 10:54
Sorry, submitted post before I was finished...

I also looked on my flash drive and found that \PortableApps\SpybotPortable\Data\Spybot was empty after closing the application.

I changed:

[DirectoriesMove]
Spybot=%ALLUSERSPROFILE%\Spybot - Search & Destroy

to

[DirectoriesMove]
Spybot=%ALLUSERSPROFILE%\Application Data\Spybot - Search & Destroy

and confirmed that it works. I changed all of my settings, updated, and closed the program. %ALLUSERSPROFILE%\Application Data\Spybot - Search & Destroy is gone, its contents moved by the launcher to \PortableApps\SpybotPortable\Data\Spybot. Re-opening the program shows that my settings have been saved.

I also found that although the application created those 4 folders in %PROGRAMFILES% they don't come back after being deleted.

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
I'll fix that settings issue

I'll fix that settings issue when I get the chance (probably tomorrow).

jkemp
Offline
Last seen: 11 years 4 months ago
Joined: 2007-11-26 16:50
I have the exact same problem

I deleted all the directories which were empty. start and stop, updated and they never appeared again. i think it does it on first update.

James

jkemp
Offline
Last seen: 11 years 4 months ago
Joined: 2007-11-26 16:50
Imunizing FirefoxPortable

I could not get Spybot to recognize FirefoxPortable.

I successfully immunized my local installed Firefox-3.6.8 on my workstation. By sorting the local profile directory my date/time, the only thing changed was a file named permissions.sqlite. Spybot added over 44,487 entries making it grow from 200k to 1.5MBs.

I copied this file to my PortableApps\FirefoxPortable\Data\Profile directory and it seems to be working.

Can someone verify this is all needed to immunize FirefoxPortable?

Thanks

htismaqe
Offline
Last seen: 6 years 5 months ago
Joined: 2010-10-01 10:54
I too had issues with updating...

First of all, it didn't work. It timed out and said there was an error retrieving the info file.

A cursory check of the filesystem (XP SP3, admin rights) shows 17 files and 4 folders were added under \Documents and Settings\All Users\Application Data\Spybot - Search & Destroy\.

htismaqe
Offline
Last seen: 6 years 5 months ago
Joined: 2010-10-01 10:54
Nevermind

I can't get to the Spybot forums either. Massive packet loss between dallas.opentransit.net and paris.opentransit.net.

I will have to try it later.

htismaqe
Offline
Last seen: 6 years 5 months ago
Joined: 2010-10-01 10:54
Cool, thanks...

The issue only applies to XP. It's because they changed the way "all users" works. In Vista/Win7, "all users" consists of global folders, like C:\ProgramData, where all local users can share access to apps or data.

The path listed in the default config (%ALLUSERSPROFILE%\Spybot - Search & Destroy) works fine for Windows 7 because %ALLUSERSPROFILE% is set to C:\ProgramData by default in Windows 7.

In XP Pro SP3, "all users" is actually a user with a user directory in C:\Documents and Settings\All Users, so the default value of %ALLUSERSPROFILE% points to there instead of to %ALLUSERSPROFILE%\Application Data\Spybot - Search & Destroy.

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
Ah, yes. I might have to talk

Ah, yes. I might have to talk to Chris about how to handle this with PAL.

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 5 months ago
Joined: 2007-04-15 21:08
ALLUSERSAPPDATA

(2.1)

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
Tip or beta 2?

Tip or beta 2?

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 5 months ago
Joined: 2007-04-15 21:08
Either

It's been in for a while.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
Updated.

Fixed the settings issue in 2000/XP and the double ampersand issue in the installer.

scriptdaemon
Offline
Last seen: 3 years 3 days ago
Developer
Joined: 2008-10-10 17:40
And again.

And again.

htismaqe
Offline
Last seen: 6 years 5 months ago
Joined: 2010-10-01 10:54
installed Development Test 5 last night...

Installed on both XP SP3 and Windows 7 Enterprise.

No modifications necessary. Works like a charm!

old farmer
Offline
Last seen: 7 years 2 months ago
Joined: 2015-09-13 19:19
Spybot portable app doesnt shut down

Ive installed Spybot ver 2.4.40.0
Now I want to remove my portable apps usb stick And I can't get spybot to exit, I've closed spybot, but when I click to remove port app, the error is ' spybot is still running. close all programs
So, how do I do that??
BTW, portable apps 12.1

Log in or register to post comments