You are here

[Discontinued] wxDev-C++ Portable

31 posts / 0 new
Last post
scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
[Discontinued] wxDev-C++ Portable

Application: wxDev-C++
Category: Development
Description:

wxDev-C++ is an extension of Dev-C++ by Colin Laplace et. al. This program helps you to create dialogs and frames for wxWidgets visually using a form designer. With all the wonderful features of Dev-C++, wxDev-C++ is still being actively developed. The main aim of this project is to provide the wxWidgets community with a free, open-source, commercial-grade IDE/RAD tool for development with wxWidgets.

[Link removed. Reason: discontinued; replaced with Orwell Dev-C++ Portable.]

Release Notes:
7.4.2 Development Test 6 (2012-10-10)

  • Fixed crash on exit

7.4.2 Development Test 5 (2012-05-13)

  • Re-added UPX compression

7.4.2 Development Test 4 (2012-05-13)

  • Fixed linker errors due to UPX compression
  • Fixed first run not being disabled

7.4.2 Development Test 3 (2012-05-12)

  • Show PA.c splash as loading screen instead of separately

7.4.2 Development Test 2 (2012-05-11)

  • Fixed language switching for Galician

7.4.2 Development Test 1 (2012-05-11)

  • Updated to wxDev-C++ 7.4.2

7.4.1 Development Test 2 (2012-02-19)

  • Minor updates to language switching

7.4.1 Development Test 1 (2012-02-12): Initial release

Notes:

  • Taken over from a previous package by aamiel here
scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
.

I've added language switching as well as the ability to run wxDev-C++ Portable on a path that contains spaces, among other minor clean-up.

One note is that on first run it asks the user to select a language. I'm wondering if there's a good way to suppress that but leave all other first-run options alone, or if it's fine as it is (it'll utilize language switching every time after first-run).

EDIT: Oh, and this uses the PAL 2.2 beta due to the need for TrimLeft.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Updated.

If language switching works for you, or you don't use language switching, you probably don't need to update.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Potentially waiting.

I asked on the wxWidgets forums if there was a way to override the initial language prompt on first run. One of the developers said there wasn't, but he would look into adding the ability. I am currently waiting to see how quickly he does this before doing an update.

http://forums.wxwidgets.org/viewtopic.php?f=28&t=35002&p=143301

aamiel
aamiel's picture
Offline
Last seen: 1 year 10 months ago
Joined: 2008-11-03 04:53
Usually a long time

In the past, I reported 2 problems and they got fixed, usually quite quickly through an unofficial patch given to me.
The proper updated release though usually takes a long time. In the past I was waiting for the proper release.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Updated.

Updated to the latest version. I disabled first run in this version so language switching will work even on first run. Plus. it disables the cache feature which breaks portability anyway as it caches the file paths, but the cache file isn't a text file so I can't edit it with the launcher.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Bug fix.

Updated to DT 2. This fixes language switching for Galician, so if you've already installed DT 1 you don't need to update unless you need that language.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Custom slash.

wxDev-C++ allows for a custom splash by using the 'Splash' key in devcpp.ini. It supports for our purposes only .bmp. I'm not a graphics artist, so if John or someone else wants to look into making a custom splash for this, go ahead. Sometime tomorrow (well, technically today) I'll going to reupload this using the dev test splash as the custom splash.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
.

And updated.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Difficulties

Both an upgrade from 7.4.0.77 and a fresh install will not compile existing or new projects. I keep getting errors along the following lines:

P:\PortableApps\wxDev-CppPortable\App\wxDev-Cpp\mingw32\lib\crt2.o In function `_mingw_CRTStartup'::
[Linker Error] undefined reference to `__dyn_tls_init_callback'
[Linker Error] undefined reference to `std::basic_string, std::allocator >::append(wchar_t const*, unsigned int)'
[Linker Error] undefined reference to `std::basic_string, std::allocator >::_S_construct(unsigned int, wchar_t, std::allocator const&)'

and that is only the first three of over 120.

Googling the problem seems to indicate a few potential causes:
1) wxDev is pointing to two different version of MinGW (which is not the case here as only one version, the included one, is referenced in Compiler Options->Directories).
2) More than one version of MinGW appear in PATH env var (possible, but I don't see anywhere that you are adding to PATH).
3) You need to install the latest version of MinGW, remove references to the included version and instead point it to the newer version (which I couldn't get to work using MinGW Portable).

Note that a fresh install of aamiel's package of 7.4.1.13 (not released here, but it is on his SkyDrive) does not have this issue, and I also assume an install of 7.4.0.77 wouldn't have this issue either.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Hmm.

Confirmed. I'll do some testing, but I don't remember changing anything that would cause this.

I also noticed I broke the DefaultData when I edited the launcher .ini to use Dev-Cpp instead of settings and didn't update DefaultData.

EDIT: Ah, looks like UPX compression has broken something. I'll need to investigate to find which file(s) is/are having problems with UPX. I vaguely remember discussing this before, but I can't find anything about the issue now. Anyway, in the meantime I can put up a new DT without compression, but I want to make sure it fully works first.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Cool

Happy to wait til it is right.

Based on the error messages, MinGW\lib may be a good place to start.

UPX would also explain another issue I had which was fixable purely by changing my code. I was getting errors when using the wxT() macro, so wherever that macro is held was also messed up by compression I assume.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Updated.

Give this one a try. Thanks.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Step backwards I think

New and existing projects now bring up the error "Project is not compiled".

The compile log shows the following:

Compiler: Default GCC compiler
Building Makefile: "P:\Portable Share\Projects\C++\Iconize\Makefile.win"
Executing  make...
mingw32-make.exe -f "Makefile.win" all 
Execution terminated
Compilation successful
Compilation took 0 seconds to complete
scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
.

Hmm. I tested it (and the one I just uploaded) and it works for new and existing projects for me.

I re-added UPX compression. Seems to me the only file that was problematic (at least in my testing) was devcpp.exe.

Try this one, and if you still have problems would you be able to send me your project files for me to test with? Thanks.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Still issues but

I think I've figured out why.

A fresh install of DT5 (and I'm guessing DT4 as well) has nothing in Tools->Compiler Options->Directories->Binaries.

There should be an entry here pointing to %PAL:PortableAppsDir%\wxDev-CppPortable\App\Dev-Cpp\MinGW32\bin

After adding this entry a blank project compiles just fine.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
I see.

The reason it was working for me was the fact it was pointing to my non-PA.c installation.

I'm trying to manually set the paths for MinGW, but wxDev-C++ keeps crashing. Looks like I'll have to speak with the wxDev-C++ devs about this.

EDIT: Hmm. Apparently the crash has nothing to do with the paths. DT 4 and 5 (didn't test any earlier ones yet) both crash as well. On first run, it's fine, but if you try to run it again, it'll crash on close. I'm not sure what's causing this. I'll post on the wxWidgets forums tomorrow.

@winterblood, could you test this to see if it crashes for you as well?

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Works fine for me on both XP

Works fine for me on both XP sp3 and Win7.

I could get it to throw a warning sometimes on exiting from which it couldn't continue or restart, but nothing bad when setting the compiler path.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Think I have figured out your crashing issue

I had noticed that the custom splash wasn't working for me and started looking into it.

It looks like the splash screen path hasn't been updated, and is still pointing to where you have the app installed in your User directory.

Anyways, I set my custom splash (in the ini file) to a relative path, but it still didn't work. I then set it from within the app, and the app now crashes every time I try to start it. If I change the icon path to something invalid again, the app starts fine.

Also while poking around, I found some non-portable paths that shouldn't be there. Have a look at lines 269, 307 and 338 of the devcpp.ini.

Edit: Ignore the non-portable paths, they are defaults set by the app itself.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
.

Yeah, I noticed I didn't update the path to the splash the other day so I changed it to X:\\ and included a last drive and a last directory variable so the launcher would automatically handle it.

I noticed the non-portable paths too, which is why I tried manually setting the directories ([Directories]) in the .ini. If I do that, they don't default to the non-portable paths.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Still crashes.

I tried launching the app without the Splash= key in the devcpp.ini and it still crashes for me.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Another thing

You might have to provide a little more default data for devcpp.ini.

For one, it is defaulting to no values for syntax highlighting, which is causing the editor to have black text on black background for things such as gutters, mouse hightlighting and breakpoints. To remedy this you will need to set (most or all of) the following:

[Editor]
ActiveSyntax="Classic"
[Editor.Syntax]
Assembler=clBlue, clNone, 0, 0, 0
Character=clBlack, clNone, 0, 0, 0
Comment=clHighlight, clNone, 0, 1, 0
Float=clPurple, clNone, 0, 0, 0
Hexadecimal=clPurple, clNone, 0, 0, 0
Identifier=clBlack, clNone, 0, 0, 0
Illegal Char=clBlack, clNone, 0, 0, 0
Number=clPurple, clNone, 0, 0, 0
Octal=clPurple, clNone, 0, 0, 0
Preprocessor=clGreen, clNone, 0, 0, 0
Reserved Word=clBlack, clNone, 1, 0, 0
Space=clBlack, clWhite, 0, 0, 0
String=clRed, clNone, 0, 0, 0
Symbol=clBlack, clNone, 0, 0, 0
Selected text=16777215, 8388608
Gutter=0, -2147483633
Break points=16777215, 255
Error Line=16777215, 128
Active Breakpoints=16777215, 16711680

Then for the MinGW path I tried hacking devcpp.ini apart and only supplying necessary information for that compiler, but the other default compilers populate as blank in the ini, and are not displayed in the program if you do (but is this really such a bad thing, since [CompilerSet_9] defaults to the non-portable paths on C: that I mentioned above?)

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
.

Hmm, I suppose I'll have to look further over the devcpp.ini file then, thanks.

Yeah, as I've been tweaking with the MinGW paths in the devcpp.ini file I noticed I can have it only show the one compiler, which I think is a good idea to do since I don't want to give the user the option of picking up anything on the host computer due to potential portability issues. Regarding the non-portable paths, they update to the portable paths if I include portable paths in the [Directories] category.

pinipon
Offline
Last seen: 10 years 5 months ago
Joined: 2007-02-16 11:20
Which version of wxWidget?

2.8.12 or 2.9.3 ??

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
.

2.9.3

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Update.

This should now be ready to release.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Sweet

Will play with it somewhat tomorrow when I should be working. Have been thinking lately that a new version of a couple of my apps are due, so this will give me the motivation to get started on at least one.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Splash issues again

A fresh install crashes on startup before the splash appears.

After deleting the custom splash line in \Data\Dev-Cpp\devcpp.ini it starts fine.

Upgrade from dev test 5 works without issue as the custom splash line was there but the value was empty from last time I was having problems with it.

Running on WinXP SP3.

EDIT: Also your language switching isn't working. You have %PAL:LanguageName% (which doesn't exist) where you should have %PortableApps.comLocaleName%.

EDIT 2: Also you have no LanguageString mapping for SpanishCastellano from their lang files. Someone with more knowledge of the Spanish language variants may be needed to determine which one maps to Spanish and which maps to SpanishInternational.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
;_;

I think the wxDev-C++ developers need to just abandon it and work with Orwell to include wxWidgets and the designer in his fork. I've had way too many crash issues with wxDev-C++ but not once (at least yet) with Orwell Dev-C++.

1. I didn't have any issues with crashes in my recent testing (otherwise I wouldn't have said the crashes have been fixed, obviously. =P), but I will try again and on my other computer when I can find some time.

2. I'll look at that again, too. Not sure what went wrong there when I implemented language switching (I remember testing it before, but I may have changed things by accident).

3. I've never been able to figure out what maps to SpanishInternational. If I remember correctly, I didn't want to make assumptions so I just left Castellano alone. I can do some more research about this another time as well.

Ken Herbert
Ken Herbert's picture
Online
Last seen: 8 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Yeah

I would like to see them partner up as well.

I must admit I have had a lot of problems with wxDev, but I'm not far from a novice at C++ (generic C-like language structure I am cool with, but C++ specifics I am not really up to speed on), so using wxWidgets helps me get a lot more done in a much shorter timeframe.

I had a bash at running wxWidgets in Orwell, but couldn't get it otherwise I would have already switched.

Regarding language mapping, from a quick look it seems that Castellano = traditional Spanish, which leads me to think that the Spanish lang file must be SpanishInternational - but I'm not an expert on the many flavours of Spanish in any way.

scriptdaemon
Offline
Last seen: 3 years 1 week ago
Developer
Joined: 2008-10-10 17:40
Discontinued.

I've decided that I will no longer be maintaining this in favor of just updating Orwell Dev-C++. Orwell Dev-C++ is still updated often, while wxDev-C++ hasn't been updated in over a year.

My goal is to package wxWidgets (and perhaps Boost) with Orwell Dev-C++ Portable at some point (I might even talk to the dev and see if he'd be interested in packaging them with the base app), so this app should not be missed.

Log in or register to post comments