You are here

A question (suggestion?) about the intelligence of the Installer

5 posts / 0 new
Last post
Ken Herbert
Ken Herbert's picture
Online
Last seen: 44 min 6 sec ago
DeveloperModerator
Joined: 2010-05-25 18:19
A question (suggestion?) about the intelligence of the Installer

After seeing this comment in regards to the release of FF13, I was wondering if the Installer is smart enough to recognize if the launcher.ini specifies a MinOS or MaxOS that the current system does not meet?

While blocking execution at the launcher stage is vital (to prevent installing FF13 on an OS > Win2k and then running it on Win2k), I think that (if it can't already) there needs to be a warning when installing to an OS that does not meet the MinOS or MaxOS of the app.

Otherwise those users who run apps from a local hard drive or who work regularly on older OSes will be unable to run their apps after updating. I could see this causing some very irate user complaints.

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 25 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Nope

Launcher.ini is for the PA.c Launcher, which Firefox Portable doesn't even use, so there is no launcher.ini.

It's a bit of a non-issue as the user would either being using Firefox 12.0 which is now insecure and unsupported (and should NOT be used) or upgraded to 13.0 which won't work on Windows 2000. So, either way, you're gonna have a bad time. As almost no one uses Windows 2000 anymore and users of it have accepted that many apps already dropped it and additional ones do all the time, it's not really an issue.

All a Win2K user could do would be to rename FirefoxPortable to FirefoxPortableESR and stay on that line (downgrading to 10.0.x). But that will only buy them until November at which point no Firefox will support Win2K at all anymore.

While we will continue to support Windows 2000 where we can, but we likely won't go to great lengths for it. A large chunk of apps have dropped it. And Microsoft dropped it about 2 years ago meaning it's insecure and unsupported.

Sometimes, the impossible can become possible, if you're awesome!

Ken Herbert
Ken Herbert's picture
Online
Last seen: 44 min 6 sec ago
DeveloperModerator
Joined: 2010-05-25 18:19
Had forgotten that FF uses a

Had forgotten that FF uses a custom launcher and thus doesn't have a launcher.ini, but I was thinking in a more broad sense, not just regarding Firefox or Win2k (they are just where the idea came from), but for any apps and any versions of Windows going into the future.

I guess with XP though, it is probably harder for app developers to really create functionality that refuses to work for XP but will for Vista/7 (although 8 may prove different enough in that regard). At least in my experience developing for Windows (which isn't that extensive, I admit) I haven't come across a situation where something won't work on XP that will work for newer OSes.

mgagnonlv
Offline
Last seen: 11 months 2 weeks ago
Joined: 2008-04-04 21:51
I'm not sure it would even be a good idea

... after all, the beauty of PortableApps is that they are used on more than one system. What if I install an application on a system that uses Windows 7 (no problem), then bring by external disk onto another system that uses Windows XP or even Windows 2000?

It's probably feasible to add a general warning, like "Do you want to update to version X, even though it won't work on Windows 2000?". Apart from the additional coding required for that, it would make the upgrading process more cumbersome, with yet more dialog boxes to reply to. I think of the puzzled face my 80-year-old mom makes with many questions asked when upgrading commercial software (like "do you like to add this_?") and I appreciate the fact this platform doesn't ask hard-to-answer questions.

Michel Gagnon
Montréal (Québec, Canada)

Ken Herbert
Ken Herbert's picture
Online
Last seen: 44 min 6 sec ago
DeveloperModerator
Joined: 2010-05-25 18:19
The launcher already takes

The launcher already takes care of that, with the MinOS and MaxOS detection, and will notify you if you are running on an incompatible system.

Not everyone uses their PortableApps portably, and unfortunately for some who do use them portably the different systems they run on are quite often older OSes.

Apart from my home computer and my wife's laptop (which are both Win7) and my work computer (which is XP) I regularly service older PCs including 2000 and rarely ME or 98, mostly because a lot of older people are either unwilling to change from what they already know (or cannot afford to upgrade their PC to one that meets spec for a modern OS).

Log in or register to post comments