You are here

[Fixed] Ooops!-as-you-type

7 posts / 0 new
Last post
zoc
Offline
Last seen: 7 years 7 months ago
Joined: 2012-06-15 05:02
[Fixed] Ooops!-as-you-type

After the update to 10.1.1, pressing keys does not launch the search box as it used to. Instead, now pressed keys seem to act as "shortcuts" for generic the menu entries on the left. Ex. "d" launches the explorer on the Documents folder, "m" on the Music folder etc.

The "/" search launch shortcut does not work either. Now, to launch the search box, it takes two keys, "sa".

This does not seem to be a planed (and documented) change, so I will assume it's a bug.

If so, I sure hope it can be fixed soon. (And if I can do anything to help speed up the fix, I'll gladly contribute.)

And if - contrary to my assumption - this has been a planed "feature" after all, then I would like to request to make it optional.

Thanks.

zoc
Offline
Last seen: 7 years 7 months ago
Joined: 2012-06-15 05:02
Update: More "Ooops!"

Sometimes after popping up the PortableApps menu, keyboard input doesn't have any visible effect at all (nothing happens on the surface). However, keys are collected in the search box nonetheless, just that the search box remains hidden. When this happens, the search box can only be shown via the mouse, and then it has all the entered characters in it.

Now I'm between a rock and a hard stone:

I would roll back to the prior version of the menu this second, but then I wouldn't be able to run app update checks from the menu.

Alas, given the rather infrequent platform updates, the option to wait for the next update and hope for a fix does not feel like a "happy ending" either (especially because one never knows if the update doesn't introduce bugs of own).

I love my portable apps, but frankly, this situation is quite a mess... Sad

Any advice?

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 36 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
See Here

See here: https://portableapps.com/news/2012-06-14--portableapps.com-platform-10.1...

It's already fixed in code, built and uploaded. But SourceForge's download mirroring has been broken for over 3 hours, so we can't give it to users yet: https://sourceforge.net/apps/trac/sourceforge/ticket/26147

Sometimes, the impossible can become possible, if you're awesome!

zoc
Offline
Last seen: 7 years 7 months ago
Joined: 2012-06-15 05:02
Wow! Cool!

That's really *great* news! Can't wait for the update. Thanks! Smile

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 36 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fixed in 10.1.2

SF mirrors are working again so 10.1.2 is out. It reliably works with / to start it on non-English keyboards. I also added in triggering it with F3 so you can start it with a single key rather than needing to use a SHIFT combination to type a / first.

Sometimes, the impossible can become possible, if you're awesome!

zoc
Offline
Last seen: 7 years 7 months ago
Joined: 2012-06-15 05:02
Fantastic!

I already got the update, and it works perfectly now! 1000 thanks!

A question: What is the right place to report bugs and submit suggestions around here? I placed mine here in the forum, but then you pointed me to another node, a comment thread. Which one is preferred?

Thanks again for the update!

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 36 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Support

The support forum for the platform (or an app) is fine. We also have a special meta thread for all platform bugs and feature requests pinned at the top of the Portable Apps Platform forum.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments