You are here

Thunderbird 13.0 upgrade broke under Linux/WIne

19 posts / 0 new
Last post
darkstar
Offline
Last seen: 11 years 1 month ago
Joined: 2008-04-03 03:14
Thunderbird 13.0 upgrade broke under Linux/WIne

Hi - I noticed that PortableApps upgraded my portable version of Thunderbird to version 13.0 recently, and it is now broke when running under SuSE12.1/wine1.5.5. It runs fine under Windows7. I tried to run it manually with wine and got the feedback shown below. Anyone want to decipher this for me and help me get my poor Thunderbird back up and flying? Thanks in advance, Marc... -

marc@marcslaptop:/media/My Passport/PortableApps/ThunderbirdPortable> wine ThunderbirdPortable.exe
fixme:system:SetProcessDPIAware stub!
fixme:process:SetProcessDEPPolicy (1): stub
fixme:iphlpapi:NotifyAddrChange (Handle 0x2bfe9c0, overlapped 0x2bfe9a4): stub
fixme:winsock:WSCGetProviderPath ({e70f1aa0-ab8b-11cf-8ca3-00805f48a192} 0x2ffe7bc 0x2ffe788 0x2ffe7a4) Stub!
fixme:winsock:WSCGetProviderPath ({e70f1aa0-ab8b-11cf-8ca3-00805f48a192} 0x2ffe7bc 0x2ffe788 0x2ffe7a4) Stub!
fixme:winsock:WSCGetProviderPath ({11058240-be47-11cf-95c8-00805f48a192} 0x2ffe7bc 0x2ffe788 0x2ffe7a4) Stub!
fixme:winsock:WSCGetProviderPath ({11058241-be47-11cf-95c8-00805f48a192} 0x2ffe7bc 0x2ffe788 0x2ffe7a4) Stub!
fixme:winsock:WSCGetProviderPath ({11058241-be47-11cf-95c8-00805f48a192} 0x2ffe7bc 0x2ffe788 0x2ffe7a4) Stub!
fixme:advapi:RegisterTraceGuidsW (0x131da12, 0x2aa9880, {509962e0-406b-46f4-99ba-5a009f8d2225}, 2, 0x2aaa3d0, (null), (null), 0x2aa98b0,): stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:advapi:FileEncryptionStatusW (L"Z:\\media\\My Passport\\PortableApps\\ThunderbirdPortable\\Data\\profile\\prefs-2.js" 0x33d774): stub
fixme:alsa:AudioSessionControl_SetGroupingParam (0x114850)->({5eef2318-5c91-4a31-a809-06bf13c075e0}, (null)) - stub
fixme:alsa:AudioSessionControl_SetGroupingParam (0x114850)->({00000000-0000-0000-0000-000000000000}, (null)) - stub
fixme:alsa:AudioSessionControl_UnregisterAudioSessionNotification (0x114850)->(0x42476c0) - stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33c744,0x00000000), stub!
fixme:resource:GetGuiResources (0xffffffff,0): stub
wine: Call from 0x7bc4dc10 to unimplemented function SHELL32.dll.SHSetUnreadMailCountW, aborting
fixme:dbghelp:elf_search_auxv can't find symbol in module
wine: Call from 0x7b83b772 to unimplemented function msvcp80.dll.??0?$basic_ifstream@DU?$char_traits@D@std@@@std@@QAE@XZ, aborting
wine: Unimplemented function msvcp80.dll.??0?$basic_ifstream@DU?$char_traits@D@std@@@std@@QAE@XZ called at address 0x7b83b772 (thread 0039), starting debugger...

Ken Herbert
Ken Herbert's picture
Offline
Last seen: 1 hour 11 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
I was going to suggest trying

I was going to suggest trying to update Wine, but I see you are running the dev channel. In that case I would suggest trying the stable release of Wine.

Otherwise, you could try reinstalling TBird Portable.

darkstar
Offline
Last seen: 11 years 1 month ago
Joined: 2008-04-03 03:14
Tried using earlier versions of Wine and reinstalled TBird Porta

Thanks Winterblood, for your suggestions. It took me awhile to get back to report my progress as I have tried a lot of different things in order to get the new version of TBird working. I dropped back to earlier versions of Wine, both the factory/development versions and the stable release of Wine, No Joy!

I tried to reinstall TBird 13.0 from scratch and again No Joy!

I installed the legacy version of TBird 3.1.20 (that is quite a jump in version numbers! Wonder why...) and that worked! So, I dunno, but it sure looks like something broke in TBird 13.0 to me...

Marc

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 45 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Works Here

Nothing is broken in 13.0 as it works just fine on Ubuntu with stable Wine. 13.0 does use a much more advanced set of display options than 3.x though, so if you're using buggy Wine (dev channel is buggy) or your Wine builds for your favorite distro aren't up to the level of the Ubuntu ones, you may just be out of luck. The SuSE builds just may not get as much love (or attention) as the Ubuntu builds do.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 45 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Works Here

Both Firefox and Thunderbird 13.0 work just fine in currently updated Ubuntu with latest stable Wine.

Sometimes, the impossible can become possible, if you're awesome!

darkstar
Offline
Last seen: 11 years 1 month ago
Joined: 2008-04-03 03:14
Ubuntu

Thanks John for your thoughts, but telling me that TBird works fine for you under Ubantu does not help me to understand why it suddenly broke for me under both openSuSE 11.4 and 12.0 on two different computers. So I am still at a loss for getting TBird 13.0 back up and flying..

thomasb12
Offline
Last seen: 11 years 6 months ago
Joined: 2012-06-26 08:50
Latest Portable TBird 13.0 does not work in Oneiric or Pangolin

I also have trouble on my desktop, Kubuntu Oneiric 11.10, and my laptop, Kubuntu Precise Pangolin, with the latest update to Thunberbird. This is not an aberration. The WINE version is 1.4.
I had no problem until the latest update of T'Bird.
Apparently the debug information was sent to Mozilla automatically.
Now I cannot run my email program from my computer, but must logon to my ISP to read it.
When will this be fixed????
Thank you!

"When plunder becomes a way of life for a group of men living in society, they create for themselves, in the course of time, a legal system that authorizes it and a moral code that glorifies it."
-- Frederic Bastiat(1801-1850, French writer and economist

ottosykora
Offline
Last seen: 1 week 1 day ago
Joined: 2007-10-11 17:48
confirm

I can confirm that the current version does not work under ubnutu 12.04 in the standard version of wine 1.4 provided there.

It is rather some component of wine what does crash however not the TB in fact.

Otto Sykora
Basel, Switzerland

thomasb12
Offline
Last seen: 11 years 6 months ago
Joined: 2012-06-26 08:50
Response

I upgraded to the latest T'bird and then WINE crashed attempting to run it. Therefore, something changed in the T'Bird upgrade that caused the crash. Whether it is related to WINE implementation or T'Bird implementation, it has to be because of a change made in the T'Bird upgrade. When that is identified then a fix can be found, whether in T'Bird or WINE.
Thank you!

"When plunder becomes a way of life for a group of men living in society, they create for themselves, in the course of time, a legal system that authorizes it and a moral code that glorifies it."
-- Frederic Bastiat(1801-1850, French writer and economist

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 45 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Feature, Specific Wine Bug

Likely, it's a specific Windows feature that Thunderbird is now using that Wine doesn't properly implement (there are a LOT of these). Usually, Wine just ignores stuff it doesn't implement, like proper handling of transparent forums. It looks like there is something newer Thunderbird uses in some SPECIFIC way that some Wine builds may have issues with.

But, as Thunderbird Portable works just fine on Wine stable on Ubuntu stable (and I just reconfirmed on TBP 13.0.1 on current Wine and current Ubuntu), the issue is likely not in Thunderbird. It may not even be in Wine. It could be on the Wine builds for some specific OSes or even in those specific OSes.

Sometimes, the impossible can become possible, if you're awesome!

ottosykora
Offline
Last seen: 1 week 1 day ago
Joined: 2007-10-11 17:48
on standard on my side

On my side, I have just the standard installation of ubuntu 12.04 and the wine comming with it, no extras, no dev of wine or so, simple the stable version delivered with ubuntu 12.04.
My language version of ubnutu is german.

The wine does crash on my side when an attempt is made to start TB portable 13.01

Otto Sykora
Basel, Switzerland

rtalbert
Offline
Last seen: 10 years 2 months ago
Joined: 2014-04-29 15:17
Thunderbird 12 Last version working in Wine

Stop making excuses and fix it!! I have generic Wine on Mint 13. No excuse that no version of Thunderbird after 12 works under Wine.
Developers please fix and do not blame the version of Wine as the latest version should ALWAYS be supported.
Thank you.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 45 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Wrong People

You're yelling at the wrong people. We have no control over which versions of Wine Thunderbird runs under. We only make our utilities work under Wine (the ThunderbirdPortable.exe launcher, etc). Then, before claiming a given base app is compatible, we test it under the latest Wine under the latest Ubuntu to be sure.

Thunderbird 24.4 works fine on a properly configured Wine instance. Here's a screenshot of it running on Wine 1.6.2 under Ubuntu 14.04 LTS that I just took a few minutes ago.

If it isn't working on your copy of Mint, then it's either an issue with your Mint configuration or the supplied version of Wine is out of date or improperly configured/compiled.

Note that, in most instances, the latest versions of regularly released apps like Thunderbird/Firefox/etc will ONLY work in the latest version of Wine. Anything less than Wine 1.6.2, and you're using an outdated version of Wine and apps like Firefox and Thunderbird simply won't work.

If you're running on the latest version of Mint and the latest version of Wine and it isn't working, then you'll need to hit up the Mint and/or Wine community to troubleshoot your configuration. It isn't something that we can assist you with.

Sometimes, the impossible can become possible, if you're awesome!

rtalbert
Offline
Last seen: 10 years 2 months ago
Joined: 2014-04-29 15:17
I am running the latest generic Mint and generic Wine.

I am running the latest generic Mint and generic Wine.
Also Thunderbird versions 13 and later will not run under Redhat.
If testing is under Ubuntu only, than that helps to explain the problem but not the fix.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 45 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Outdated Mint

You'd said you were running Mint 13, which is 2 years old. Yes, it is an LTS release, but Wine may not be able to run the latest apps on it. Also, are you sure you're running on Wine 1.6.2?

As for a fix, again, you'd need to check with the Mint and/or Wine folks. Thunderbird runs under Wine without issue on Ubuntu. So there is either an issue with Mint's packaging of it or configuration.

We couldn't possibly test under all Linux variants. Especially when distros like Mint have 8 different packages of a release (14 if you count 32-bit and 64-bit separately).

I'm firing up a VM of Mint 16 to see how it fares under the current version.

UPDATE: I can confirm that Linux Mint 16 is serving up an outdated version of Wine. It serves up 1.4.1 when you install it from the Software Manager. This outdated version of Wine is incapable of running current Firefox and Thunderbird releases.

Sometimes, the impossible can become possible, if you're awesome!

rtalbert
Offline
Last seen: 10 years 2 months ago
Joined: 2014-04-29 15:17
Thank you for the replies.

First, I do appreciate the hard work so few have done for so many.
My frustration realy does start with Microsoft for making changes that, may have in this case, forced Mozilla group to create work-arounds. Work arounds that had broken Thunderbird under PortableApps/Mint/Wine.
I know that for decades, Opensource groups have had to battle against these tactics which takes resources away from more productive work.
This will not stop me from supporting and using Thunderbird even if I must use an older version.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 45 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Current Wine

All you need to do is use a current Wine instead of the outdated one Mint is pushing in their repositories. It shouldn't be more complicated than that. It's a bit silly of them to be serving up an outdated version.

Sometimes, the impossible can become possible, if you're awesome!

rtalbert
Offline
Last seen: 10 years 2 months ago
Joined: 2014-04-29 15:17
Thank you John for the fix

Who knew that even Mint 16 used an old Wine version.
The following allows me to run the latest Thunderbird.
sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.6

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 45 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Good To Hear

Glad to hear it!

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments