You are here

[Closed] Mail Merge Wizard doesn't work properly

8 posts / 0 new
Last post
tapsklaps
Offline
Last seen: 4 years 1 month ago
Developer
Joined: 2010-10-17 08:11
[Closed] Mail Merge Wizard doesn't work properly

I've tried to create a serial letter with the "Mail Merge Wizard" (Tools -> Mail Merge Wizard ...) but without any success. Firstly I assumed, that this is a bug in the app itself. But this assumption wasn't true, because I can create a serial letter with the portable version X-LibreOffice.

The failure occurs after step 6 "Edit document" within the "Mail Merge Wizard". Now the inserted address block (see step 3 of the "Mail Merge Wizard") disappears.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 43 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Local

I can't even get it working on my local install of LibreOffice. It won't let me continue past step 3. Could you walk me through the steps you're using?

Sometimes, the impossible can become possible, if you're awesome!

tapsklaps
Offline
Last seen: 4 years 1 month ago
Developer
Joined: 2010-10-17 08:11
comprehensive procedure
  1. Step 1: Creation of a data source using LibreOffce Portable Calc
  2. In a first step it's necessary to create a data source. For this creation you can use LibreOffce Portable Calc. In the following screenshot you can see a typical example of such a data source. I'll call the appropriate file "customers.ods". Please also note the bolded field names in the first row of this table (Salutation, FirstName, LastName, City, Postcode). The usage of these field names is very important in step 4 "Insert address block" of the "Mail Merge Wizard".

    screenshot: customers

  3. Step 2: Select starting document
  4. After the start of the "Mail Merge Wizard" please let the selection "Use the current document" unchanged and click on the buttton "Next".

  5. Step 3: Select document type
  6. In this dialog window once again you let the selection "Letter" unchanged and click on the button "Next".

  7. Step 4: Insert address block
  8. In this dialog window you click on the button "Select Address List..." at the top on the right. Afterwards you click on the button "Add..." and chose the table named "customers.ods". Finally you click on the button "Ok".

    Now you set a checkmark next to "This document shall contain an address block". Then select the second rimmed address block righthand.

    Now you click on the button "Match Fields...". Then click on the downward-pointing arrow next to "Title" and choose the entry "Salutation".Then click on the downward-pointing arrow next to "First Name" and choose the entry "FirstName". Then click on the downward-pointing arrow next to "Last Name" and choose the entry "LastName". Then click on the downward-pointing arrow next to "Address Line 1" and choose the entry "Address". Then click on the downward-pointing arrow next to "City" and choose the entry "City". and finally click on the downward-pointing arrow next to "Zip" and choose the entry "Postcode".

    Finally you can now click on the button "Next" at the bottom.

  9. Step 5: Create salutation
  10. In this dialog window please set checkmarks next to "This document should contain a salutation" and "Insert personalized salutation".

    Then click on the downward-pointing arrow next to "Field Name" and choose the entry "Salutation". In the empty field next to "Field value" you write "Mrs.".

    Finally you can now click on the button "Next" at the bottom.

  11. Step 6: Adjust layout
  12. This dialog window you can leave unchanged.

    Finally you can now click on the button "Next" at the bottom.

  13. Step 7: Edit document
  14. This dialog window you can leave unchanged.

    Finally you can now click on the button "Next" at the bottom.

  15. Step 8: Personalize document
  16. In this dialog window should now appear all the concrete address blocks. But unfortunately all the address blocks are disappeared. That's the bug!!

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 43 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Work Path

I believe the problem is due to an invalid work path.

What's the full location you have LibreOffice Portable installed to? And, if you could open up the file registrymodifications.xcu within LibreOfficePortable\Data\settings\user and find the entry for /org.openoffice.Office.Paths/Paths/org.openoffice.Office.Paths:NamedPath['Work']. The value follows within value tags.

I was unable to get past step 3 until I blanked that value out by removing the text between the value tags. After that it went all the way through and the saved document looked correct. My finished document from my local copy of LO and portable LO both have blank sections where the inserts should be in the still-open document, though.

Sometimes, the impossible can become possible, if you're awesome!

tapsklaps
Offline
Last seen: 4 years 1 month ago
Developer
Joined: 2010-10-17 08:11
Problem is not solved

The full location of my installed LibreOffice Portable is:
C:\Portable Programme\PortableApps\LibreOfficePortable

Despite the removal of the value in the registrymodifications.xcu file the error I described above occurs again.

Here the content of this value: file:///C:/Portable Programme/Documents

tapsklaps
Offline
Last seen: 4 years 1 month ago
Developer
Joined: 2010-10-17 08:11
correct results with X-LibreOffice

As I have mentioned it in my original post, I got correct results with X-LibreOffice. For more transparency and simplification I can show it you with the help of TeamViewer.

tapsklaps
Offline
Last seen: 4 years 1 month ago
Developer
Joined: 2010-10-17 08:11
Bug in the app itself

I have forgot to mention, that I have used an older version of X-LibreOffice namely v4.0.4.2. Accordingly I have now downloaded the newest version of X-LibreOffice (v4.2.0.4) as a standalone version. And indeed I get now the same issues, which I described in my original post.
In summary, it can be clearly concluded, that in the program itself is a bug.

For this reason I have closed this reported bug.

tapsklaps
Offline
Last seen: 4 years 1 month ago
Developer
Joined: 2010-10-17 08:11
Bug removed

The bug in the app LibreOffice Writer, which I've mentioned here, was now removed with the update to the version 4.2.1.

Log in or register to post comments