You are here

Strange icons appearing in Firefox 29 url bar

8 posts / 0 new
Last post
orschiro
Offline
Last seen: 8 years 5 months ago
Joined: 2012-01-07 14:42
Strange icons appearing in Firefox 29 url bar

After the upgrade to FF29 I get very strange icons in the menu bar.

See this screenshot: http://i.imgur.com/JqDg0lW.png

Can anyone else reproduce this issue?

MichaelDW
Offline
Last seen: 6 years 6 months ago
Joined: 2011-01-05 11:50
It is not a bug

For some reason in Firefox 29,
they have 'merged' the add-on bar and the url bar.
The result is that most icons that would have been in the add-on bar
now has a default location of the url bar.

https://support.mozilla.org/en-US/kb/what-happened-to-the-add-on-bar

orschiro
Offline
Last seen: 8 years 5 months ago
Joined: 2012-01-07 14:42
Hi Michael, Thanks for your

Hi Michael,

Thanks for your reply. Have you looked at the screenshot?

To me this looks terribly wrong. I cannot believe that this should be a feature.

GlennAllen
Offline
Last seen: 9 years 1 month ago
Joined: 2011-03-08 14:46
Compatibility?

I'd tend to attribute that to some addon or to CSS from a userstyle or userscript that isn't compatible with Fx29's new UI.

John T. Haller
John T. Haller's picture
Online
Last seen: 59 min 10 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Restore Defaults

Right-click on the Home icon and select Customize. Then click Restore Defaults. This is likely cruft related to multiple add-ons having been installed previously or currently. Everything that was on your (likely hidden) add-on bar is now pushed into the main toolbar.

You could also have some incompatible extensions or have applies some custom CSS that is no longer compatible with Firefox.

As this is not a bug with Firefox Portable, I have removed the Bug tag. That tag is only for bugs in our own code that we need to track.

Sometimes, the impossible can become possible, if you're awesome!

orschiro
Offline
Last seen: 8 years 5 months ago
Joined: 2012-01-07 14:42
Indeed an Add-on issue.

Indeed an Add-on issue. Thanks for the hint!

I started in Safe Mode and the issue is gone.

Now I have to figure out which extension causes the issue.

LauRoman
Offline
Last seen: 9 years 11 months ago
Joined: 2014-05-01 16:45
the rss icon (by kitsunemg) is the culprit

The culprit is an RSS Icon addon, that you might have installed to restore some functionality of older firefox version. It used to work up until FF28 and it hasn't been updated for the latest version. You could remove it and install another one that is compatible with the latest version. I recommend "RSS icon in url bar" or "RSS icon in awsomebar".

orschiro
Offline
Last seen: 8 years 5 months ago
Joined: 2012-01-07 14:42
This extension was exactly

This extension was exactly the issue. Thanks for investigating and your recommendation for alternatives!

Log in or register to post comments