You are here

[PA.c Installer 3.0.15 ] A bug in online installer?

3 posts / 0 new
Last post
5keeve
Offline
Last seen: 7 years 7 months ago
Joined: 2012-07-12 15:13
[PA.c Installer 3.0.15 ] A bug in online installer?

I've created an online installer containing this download section shown at the bottom.

Unfortunately I'm behind a firewall and so have to use a proxy. PortableApps is configured properly and can successfully download new applications.

But my Installer, created with PortablApps.com Installer 3.0.15 is not able to download.

As the details didn't tell me much (SendRequest Error), I've used wireshark to sniff the network traffic. It seems there is something going wrong. Please see a snapshot at http://img5.fotos-hochladen.net/uploads/wwwdbviscomppiewh972ql.png

As you can see, the full request URI, as seen by wireshark is "http://www.dbvis.comhttp://www.dbvis.com/...." which is for sure wrong.

Download section:

[DownloadFiles]
DownloadURL=http://www.dbvis.com/product_download/dbvis-9.1.11/media/dbvis_windows_9_1_11.zip
DownloadName=DbVisualizer 9.1.11 
DownloadFilename=dbvis_windows_9_1_11.zip
DownloadMD5=e0a40b41da7217b5f53e6aae1d53faf0
AdditionalInstallSize=65500
AdvancedExtract1To=App\
AdvancedExtract1Filter=*

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 4 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Works Fine, Proxy is Platform Only

The PA.c Installer's download component works just fine and you can see the proper URI listed in the Wireshark details. At no point in the code is the DownloadURL variable even manipulated.

Note that a proxy will only work if Windows is properly configured to use it. The PA.c Installer does not use the PA.c Platform's proxy configuration. The only case where it will work is for an officially released app as the Updater will use the PA.c Platform's proxy configuration to download both the installer and the live component that the installer specifies in the DownloadURL line, bypassing the PA.c Installer's downloading feature.

Sometimes, the impossible can become possible, if you're awesome!

5keeve
Offline
Last seen: 7 years 7 months ago
Joined: 2012-07-12 15:13
As I'm by no means an windows

As I'm by no means an windows expert, could you please tell me how I can find out whether or not windows is properly configured to use a proxy? I do not have admin rights for the PC and I guess it's configured properly as IE can connect to the internet just fine. Same for PA as I have configured its Connection to "Automatic".

Btw: Now I'm at home, where no proxy is required, and the installer worked just fine.

Update: Your hint was useful! I've experimented a bit with the proxy settings and it appears to me that the PA.c Installer can't handle automatic proxy configuration. Here is what I did:

  1. Connected to my company's VPN
  2. I checked in
    Control Panel\Network and Internet\Network and Sharing Center
    Internet Properties > Connections > LAN settings
  3. I changed from "Use automatic configuration script" to that
    "Use a proxy server". There I configured the proxy server the
    script usually gives me
  4. Verified that I can still connect using a browser
  5. Ran my installer and it worked

Update: I fired up miniweb, giving it the very same proxy.pac the company's server would provide, configured this proxy.pac and the installer works.

So it's not that there is a proxy.pac used, nor is it its content.

Then I tested again with the "normal" configuration and now it works.

I think: Case closed. Must have been an intermittent local issue.

Thanks for your hints.

Log in or register to post comments