You are here

ATOM.io (another, but better looking code editor)

17 posts / 0 new
Last post
Wickster
Offline
Last seen: 4 years 7 months ago
Joined: 2013-02-14 19:22
ATOM.io (another, but better looking code editor)

I know, we have a whole lot of code editors now, but you can never have too much right? Smile

This one is called Atom. I believe it's open source. It's new and looks very modern, much like Brackets but not from Adobe.

You can find the app here:
https://atom.io/

And the source can be found here:
https://github.com/atom/atom

Thanks all.

war59312
Offline
Last seen: 4 weeks 17 hours ago
Joined: 2007-08-18 17:10
Would love to see this as

Would love to see this as well.

Now that it has reached 1.0.

God Bless America

John T. Haller
John T. Haller's picture
Online
Last seen: 4 min 30 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
.NET 4.5

For future reference, this requires .NET 4.5 which is only bundled with Windows 8 and higher. Windows 7 and lower (the vast majority of Windows machines) requires .NET 4.5 to be installed with administrative rights.

Sometimes, the impossible can become possible, if you're awesome!

Brisingr Aerowing
Offline
Last seen: 5 months 3 days ago
Joined: 2013-08-18 14:55
Are you sure?

The build process doesn't require .NET, and it seems the Atom is built using Node.JS and Chromium using Electron. No .NET needed.

farat_as
Offline
Last seen: 5 years 9 months ago
Joined: 2012-02-14 09:02
If Im not wrong, Atom does

If Im not wrong, Atom does not requires .Net.

Please make it portable. Here a discuss for it: https://github.com/atom/atom/issues/2939

Atom is based on nodeJs and chromium. It is fully featured cross platform text editor.

Mavis Beacon
Offline
Last seen: 7 years 2 months ago
Joined: 2015-05-17 04:46
John is partly correct

It seems the Windows installer requires .NET 4.5, but Atom itself does not. The following thread from the Atom website explains that the Atom installer may be bypassed by simply downloading and extracting a .zip file.

https://discuss.atom.io/t/windows-install-requires-net-4-5/19085

farat_as
Offline
Last seen: 5 years 9 months ago
Joined: 2012-02-14 09:02
I tried that link, it is

I tried that link, it is portable. but profile files are saving at Home folder of user :/

sagie gur-ari
Offline
Last seen: 4 years 5 months ago
Joined: 2014-03-01 08:07
no .net

from what i know it doesn't require .net
I made a portable version of their zip dist a long time ago, but didn't publish it because atom is just not as good as brackets so why bother.
I saw it was working good so if you really need it and you prefer it over brackets.io than tell me and i'll publish it.
if you want to tryout brackets.io first, go to: https://github.com/sagiegurari/brackets-portable/releases/tag/1.4.0.3

vf2nsr
vf2nsr's picture
Offline
Last seen: 6 years 1 month ago
Developer
Joined: 2010-02-13 17:10
As stated the installer is .Net

REad further up they state installer is .Net

“Be who you are and say what you feel because those who mind don't matter and those who matter don't mind.” Dr. Seuss

sagie gur-ari
Offline
Last seen: 4 years 5 months ago
Joined: 2014-03-01 08:07
I did

I read it but when using paf, installers are usually not needed and for atom.io definitely as they provide a zip package without an installer.
I wanted to confirm that everyone understands that .net is not needed for the app.

TaoTao
Offline
Last seen: 6 years 11 months ago
Joined: 2015-11-12 10:59
New here: https://github.com
sagie gur-ari
Offline
Last seen: 4 years 5 months ago
Joined: 2014-03-01 08:07
working good

ya thats pretty great they implemented it.
works good too.

Heros15582
Offline
Last seen: 7 years 1 week ago
Joined: 2015-11-04 21:06
Would Love to see portable

i am always looking for new portable text editor this would be awesome

trust
Offline
Last seen: 2 years 7 months ago
Joined: 2009-09-29 19:54
Have you figured out if this

Have you figured out if this requires .NET 4.5 or not? https://portableapps.com/node/53604

All I know is that I install recommended updates on Windows 7, I wasn't really able to found out my .NET version for 100% sure, according to Microsoft's guide here: https://msdn.microsoft.com/en-us/library/hh925568(v=vs.110).aspx

nickfo
Offline
Last seen: 5 days 4 hours ago
Joined: 2012-06-28 04:34
dotnetinspector-portable?

not sure how up to date it is, but you could try https://portableapps.com/apps/utilities/dotnetinspector-portable.

blaablaaguy
Offline
Last seen: 5 years 9 months ago
Joined: 2016-07-26 09:32
Every time i used portablapps

Every time i used portablapps i found myself wishing this was portable Smile

This is not a signature

mwayne
Offline
Last seen: 17 hours 30 min ago
Developer
Joined: 2012-01-03 09:23
Available

Atom.io is available as a Development Test here.

Log in or register to post comments