You are here

PortableApps Platform Update to 14.2 Installer Crash

6 posts / 0 new
Last post
NotMine
Offline
Last seen: 1 year 9 months ago
Joined: 2013-11-18 15:58
PortableApps Platform Update to 14.2 Installer Crash

I checked for Portable Apps updates today. The updater reported that there was an update for PortableApps Platform 14.2 and it's 4MB in size.

Fine. Update it. I have never had problems with this Portable App in the past.

The updater downloads and then automatically starts the installation process.

It is just a matter of seconds and then I get this error:

Window Title: NSIS Error
Window Text: (X) Error launching installer

If it matters, I do not run my Windows 7 x64 laptop using a login with "administrator" level access. The standard login I use is that of a "user", as defined by Windows 7.

The error can currently be repeated "at will" just by running the updater and trying again and again.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 7 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Corruption or TEMP issue

This is an error within NSIS itself that is apparently most often caused by corruption in the downloaded installer or incorrect permissions set on the machine's TEMP directory.

I'd suggest clearing your browser's cache (as well as IE's cache) and downloading a fresh copy via the Download link up to and then running that installer directly. You can select your existing installation to upgrade by pointing it at the directory that contains Start.exe in your current install if it doesn't detect it automatically.

Sometimes, the impossible can become possible, if you're awesome!

NotMine
Offline
Last seen: 1 year 9 months ago
Joined: 2013-11-18 15:58
Follow Up

I tried again today to use the updater in the PA Menu. Same error.

Rebooted the computer after closing Firefox and some Windows Updates that needed a reboot. Tried again after reboot. Same error.

Gave the Windows TEMP and TMP folder "full access" in the Security Privileges of "Users" in Folder->Properties->Security. Tried again. Same error.

Downloaded the PortableApps menu from your website's download link. Locally executed the installer. Pointed it to the "custom location" of my existing installation (my download was not in the same folder as the Portable Apps stuff). Success.

So based on John's message above along with my own testing, corruption during the download process when using the updater element of the PortableApps Menu is the suspect in this "crime". I wonder if adding a checksum or signature to these downloads along with the appropriate processing code in the PA Menu Updater to check for corruption is a reasonable, but time consuming, program upgrade for the PA Menu.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 7 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Already Does

That's the thing, the updater already verifies the MD5 of the downloaded file. Plus the updater has a built-in CRC check. And it's digitally signed. The suggestions I gave above are the standard NSIS suggestions. 76,000 people have updated to 14.2 by the platform's updater thusfar and yours is the only complaint. The only thing that changed in the updater from 14.1 vs 14.2 is NSIS switching from 3 Beta 3 to 3 Stable. So, it stands to reason - at least at the moment - that something specific on your PC was going on. The only other thing I can think of offhand is either a custom TEMP directory with the platform, a software firewall messing about with things, or some sort of OS issue like an infection or failed update.

Sometimes, the impossible can become possible, if you're awesome!

bigpallooka
Offline
Last seen: 2 weeks 1 day ago
Joined: 2009-07-29 13:07
Yeah. Not the only one.

Yeah. Not the only one. I do run as admin. I'll try the suggestions.

EDIT:
Worked beautifully.
Thanks.

SDD
Offline
Last seen: 2 months 3 weeks ago
Joined: 2008-01-25 16:20
Upgrade to 14.2 not working -Aborts half way

I've tried to upgrade, but the installer halts when it cannot get write access to PortableAppsPlatform.exe. This leaves me with a partly destroyed PortableApps (since icons, etc. have already been deleted). How do I restore? I can't use the PA menu, since any mouseover complains about a missing button icon, I can't invoke the updater outside PortableApps. -Frustrating! I've otherwise been very happy with the platform, and used it for many years, both on Windows and under Vine on Ubuntu.

==Update==
I took the advice posted above: seems to do the trick.

best regards
= Simon Drew =

Log in or register to post comments