You are here

Apps failing to launch with an error when Mandatory ASLR is enabled

5 posts / 0 new
Last post
rejzor
Offline
Last seen: 4 years 7 months ago
Joined: 2014-10-01 14:32
Apps failing to launch with an error when Mandatory ASLR is enabled

I have "Mandatory ASLR" enabled in Windows 10 (Fall Creators Update) and everything works fine with it, except bunch of Poratble Apps like CPU-Z, GPU-Z, LibreOffice, TAudioConverter, qBitorrent, PhotoFiltre etc that just fail to start with an error (that I then connected to Mandatory ASLR being enabled.

If I launch these same apps directly (not through PortableApps launcher), they work fine. Can this be addressed please? I'm not experiencing any issues with any other apps or games and some apps work just fine even through PortableApps launcher, but the mention above do (and probably many others). And it doesn't seem to be an issue with apps themselves because they do work even with mandatory ASLR enabled when launched by themselves directly from Windows Explorer.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 51 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
All NSIS2-based installers and EXEs should fail under ASLR

All apps using the PortableApps.com Launcher for the AppNamePortable.exe launcher should fail when mandatory ASLR is enabled. These are made with NSIS 2.x which does not support ASLR. That's why you can launch Firefox and Chrome (custom launcher using NSIS 3) but not those you listed (PAL using NSIS2). They should fail whether or not they are launched from another process and I know they used to. Perhaps Microsoft made a small change to it in a recent update and they somehow launch directly now for some reason. I'd wager you can't launch them from any process, not just the PA.c Platform (aka menu). You could try the platform beta, which is made with an entirely different version of the Delphi compiler than stable, to see if that works.

Sometimes, the impossible can become possible, if you're awesome!

vikaskundu
Offline
Last seen: 4 years 6 months ago
Joined: 2018-03-22 07:02
Hi John, today I have

Hi John, today I have completed few pending system and driver updates on my Win 10 PC. Unfortunately now whenever I will open the PA Platform software it simply crashing right on the startup. I've the crash logs where am I supposed to send them?

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 51 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Seperate Issue

This would be something different than what's being discussed above (manually enabling ASLR causes some app launchers not to work, but the platform will work just fine). Please create a new thread in the platform support forum with complete details (platform version, new vs upgrade, full path, exact error message, windows version/type/bit depth, antivirus in use, etc) and we'll take it from there: https://portableapps.com/forums/support/portableapps_menu

Sometimes, the impossible can become possible, if you're awesome!

freakygurl
Offline
Last seen: 4 years 1 month ago
Joined: 2018-08-15 02:50
It's Keep on Crashing what to

It's Keep on Crashing what to Do? Please Help Me with this.

Log in or register to post comments