You are here

AbiWord: Difficulty with Spell checker

11 posts / 0 new
Last post
symiggy
Offline
Last seen: 15 years 3 months ago
Joined: 2006-09-10 17:38
AbiWord: Difficulty with Spell checker

I have rather peculiar problem which I really cannot understand.

When I run AbiWord on my regular home computer, the spell check works normally as I would expect it to.

But when I run AbiWord Portable from a USB thumb drive while plugged into my regular computer, I always get the message: "Could not load the dictionary for the English (New Zealand) [en-NZ] language" and following this dialogue box, no spell checking is possible.

But when I plug the exact same USB thumb drive into my (much less powerful and much older) laptop, there is no problem at all, spell checking occurs normally.

In other words there is something that is preventing the dictionary to load when I run AbiWord portable which does not happen when I run the regular AbiWord.
And there is nothing wrong with the thumb drive since the dictionary loads normally when AbiWord Portable runs on a laptop.

I would really appreciate some suggestions, explanations or advice.
Thank you.

John T. Haller
John T. Haller's picture
Online
Last seen: 9 min 20 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
NZ? Check for files...

I don't see English (New Zealand) as a supported language (nor was I aware that it had its own variant). I think they dropped support for it as I only see it in some archives files.

That said, are there any files you see on your local PC in X:\Documents and Settings\[login]\AbiSuite that look like dictionary files (aside from custom.dic)? I think that may be where you have it for some reason. Dictionary files are supposed to be installed within AbiWord itself. So in the portable version: AbiWordPortable\App\AbiSuite2\dictionary

Sometimes, the impossible can become possible, if you're awesome!

symiggy
Offline
Last seen: 15 years 3 months ago
Joined: 2006-09-10 17:38
On the local PC the only

On the local PC the only files located in C:\Documents and Settings\[login]\AbiSuite are:
Abiword.Profile and customlocal.dic
No other files.

In the Portable version the string consisting of: AbiWordPortable\App\AbiSuite2\dictionary

The folder contains two files: american.hash HASH File 2106KB
ispell dictionary list.xml XML Document 8 KB

Perhaps there is some conflict between English NZ and English American.
I have absolutely no problem using an American English dictionary and I am not aware as to why Abiword is trying to load a NZ dictionary.

Do you have any thoughts as to what I can do to rectify this.
Also please note that this does NOT happen when I run Abiword portable on my laptop that is supposedly configured in a similar way to my desktop.

andw
Offline
Last seen: 15 years 2 months ago
Joined: 2007-03-11 09:46
I had the same problem with

I had the same problem with English Australian.
I too am happy to use the American dictionary (better than none).
Anyway, go to the folder
xxx\AbiWordPortable\App\AbiSuite2\dictionary (where 'xxx' is where the program is run from)
Open ispell_dictionary_list.xml with a program that can edit xml files (Notepad++ here)
Look for the line that says

 (dictionary tag="en-NZ" name="british.hash"        encoding="iso-8859-1" /) 

and change it to

 (dictionary tag="en-NZ" name="american.hash"       encoding="iso-8859-1" /) 

At least that worked for the en-AU one here.

edit - had to put '(' and ')' in the above lines as '' break this forum coding

Georges-V
Offline
Last seen: 14 years 11 months ago
Joined: 2007-06-18 13:50
No Canadian Dic either - but British is available

Checking the AbiWord site, on their Downloads page, in the Windows box, in the Get Dictionaries list, I see British as well as American. There are no Canadian versions for either French or English - so I get along here using British and French.

For help installing, I used the information in the replies to the chap in this forum needing to install a Swedish dictionary.

I had to do a bit of file moving as I did not want to rename folders - the essential is that the hash file ends up in the Dictionay folder on your portable drive (USB key/thumb drive in my case.)

Hope this helps.

antagonise
Offline
Last seen: 14 years 1 week ago
Joined: 2008-05-09 09:02
AbiWord Portable dictionaries

AbiWord dictionaries are available from here:

http://abiword.com/downloads/dictionaries/Windows/

The dictionary installer will ask you for the local installation of Abiword but, if you point the installer at the root install directory for AbiWord Portable, it seems to put the dictionary file in the wrong place for portable installations. To get around this, make sure to point the installer at the AbiSuite2 directory on your portable device:

PortableApps\AbiWordPortable\App\AbiSuite2\

Click 'Next' and the installer will do the rest for you.

Alternatively, you can point the installer at a temporary directory (e.g. \Temp) and hit 'Next'. You will then find the dictionary file in:

Temp\AbiSuite2\dictionary

The dictionary directory will contain a .hash file named after the language you just installed.

Next just copy the .hash file to the AbiSuite2\dictionary directory on your portable device. E.g.:

PortableApps\AbiWordPortable\App\AbiSuite2\dictionary

Simeon
Simeon's picture
Offline
Last seen: 7 years 7 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
Thats exactly

what it says here on the Support page.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

opsimathic
Offline
Last seen: 13 years 3 months ago
Joined: 2006-07-07 15:55
Difficulty with Spellchecker

This is still a live issue under 2.6.6 just released on Portableapps.com. In my case the message refers to "Cannot load the dictionary for the English (Canada)[en-CA] language."

Like a number of other users in the wider non US English world, I am prepared use the American spell check in order to use this product. I am running VISTA home premium edition.

Abiword appears to picking up the machine language setting and using that - in theory, I should be able to go to TOOLS PREFERENCES and under the general tab, tell Abiword to use English US which is the only option the drop down box offers me. The setting only takes place on restarting Abiword - however, when I restart it, the setting is lost and not activated. I wonder if this a VISTA specific problem.

I have read some of the more complex fixes offered by others, but feel there is something more fundamentally wrong that needs to be fixed. Meanwhile I will stay with slow but reliable OpenOffice.

Hope someone can provide a good lasting fix.

Many thanks.
/opsimathic

opsimathic
Offline
Last seen: 13 years 3 months ago
Joined: 2006-07-07 15:55
Difficulty with Spellchecker

I have just downloaded and installed the British dictionary - strangely, I now have available spell checking with American English but AbiWord is not recognizing the British dictionary. In other words, I have moved ahead but the underlying problem still remains.

Thanks again.
/opsimathic

opsimathic
Offline
Last seen: 13 years 3 months ago
Joined: 2006-07-07 15:55
Dificulty with Spellchecker

For comparison, I downloaded the non-portable version of AbiWord (2.66) from AbiSuite.com and installed it on the same Vista Home Premium machine. The installation recognized that my machine is set to English (Canada) and established spellcheck without difficulty. Further it lets me change the language setting (under TOOLS PREFERENCES)and shows language options for Australian, Canadian, Irish, American and British versions of English (plus many other languages).

Regrettably, I conclude that there is something not quite right in the PortableApps.Com packaging of this application that needs investigation. Hopefully, it can be fixed without too much difficulty by those who are more expert than I.

Thanks!
/opsimathic

SwampCat
Offline
Last seen: 2 years 1 month ago
Joined: 2008-05-03 13:03
SpellChecker doesn't work

Hi Guys,

I tried latest portable available here 2.8.2
I need 2 languages for spelling (English & Russian)

But despite many languages in the list & its' declared that spellcheck is available by default The Spellcheck option is dimmed

How to fix it?

Thanks in advance

Log in or register to post comments