You are here

time for a portable version of 64-bit VLC

15 posts / 0 new
Last post
thank_you_for_p...
Offline
Last seen: 7 months 3 weeks ago
Joined: 2017-12-31 21:06
time for a portable version of 64-bit VLC

This issue has been discussed on this forum in the past. The reasoning given was that there's no real benefit of the 64-bit over the 32-bit, so only the 32-bit is available on PortableApps.

Well, now there is a real benefit. OBS can use VLC directly as a source (useful for streaming). But only 64-bit VLC.

John T. Haller
John T. Haller's picture
Online
Last seen: 19 min 11 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Support Portable?

Does OBS support it when they're both running portable? You can grab the 64-bit files from the VLC site and drop them into VLC Portable to test. If it does work between OBS Portable and VLC Portable, I'll consider updating it to dual mode. If it doesn't, then there's no need.

Sometimes, the impossible can become possible, if you're awesome!

thank_you_for_p...
Offline
Last seen: 7 months 3 weeks ago
Joined: 2017-12-31 21:06
I just tried it. Sadly, it

I just tried it. Sadly, it seems the portable OBS cannot pick up from portable VLC-64-bit.

In case anyone's curious about what I meant by VLC as a source for OBS, you may

1) watch this video: https://www.youtube.com/watch?v=c4DBj6XXpF8&ab_channel=ScottFichter

2) or google: VLC Video Source in OBS

Thanks for your quick response in offering to help. Sadly, it seems seems it won't work.

John T. Haller
John T. Haller's picture
Online
Last seen: 19 min 11 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Know Details?

Do you know any additional details about what OBS is looking for to use it as a source? It might be something I could build into the OBS Portable launcher to check if VLC 64-bit is available and point to it.

Sometimes, the impossible can become possible, if you're awesome!

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 10 hours 16 min ago
DeveloperModerator
Joined: 2008-07-24 18:46
Registry Key?

It appears that there is a registry key check happening: https://github.com/obsproject/obs-studio/blob/190ab876cc727a1d9ef89a32f0...

So, we should be able to easily build this into the launcher as you've noted.

John T. Haller
John T. Haller's picture
Online
Last seen: 19 min 11 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
HKLM, so admin

Unfortunately, it's checking in HKLM, so we'll need admin rights when launching OBS to be able to get it working. Also, not sure if we can pass in VLCPortable.exe and it'll work or if it requires vlc.exe as it exists in an installed version. If the latter, it's a no go since it would be run in local mode.

Sometimes, the impossible can become possible, if you're awesome!

Carmina Maud
Carmina Maud's picture
Offline
Last seen: 2 months 6 days ago
Joined: 2021-06-15 23:08
VLCPortable 3.0.15

The update 3.0.15 of VLC Portable don't work.
My system: Windows 8.1
I must (re)install update 3.0.14 to have a functional app
More: When we go on the VLC website, the last update is 3.0.14.
Question: What is this update 3.0.15 on PortableApps?

Carmina

John T. Haller
John T. Haller's picture
Online
Last seen: 19 min 11 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
VLC Pulled It

Sometimes, the impossible can become possible, if you're awesome!

Kyle_Katarn
Offline
Last seen: 6 days 17 hours ago
Joined: 2018-01-14 13:25
It seems that the PA package

It seems that the PA package rolled back to "3.0.14 Rev 2" but contains some leftover from 3.0.15. See : https://www.wilderssecurity.com/threads/sumo-keep-your-software-up-to-da...

Am I (and SUMo) wrong about this ?

John T. Haller
John T. Haller's picture
Online
Last seen: 19 min 11 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
By Design

The package version is by design. 3.0.15.1 is greater than 3.0.15 and will replace VLC Portable 3.0.15 for existing users.

Sometimes, the impossible can become possible, if you're awesome!

Kyle_Katarn
Offline
Last seen: 6 days 17 hours ago
Joined: 2018-01-14 13:25
Thanks for your help !

Thanks for your help !
But as a general use, should SUMo use PackageVersion or DisplayVersion to indicate the currently installed "version" of a PA product ?

John T. Haller
John T. Haller's picture
Online
Last seen: 19 min 11 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
PackageVersion

We use PackageVersion to indicate to our own platform when an app is in need of an upgrade, hence using the odd PackageVersion for the Rev 2. It forces users to downgrade so they don't encounter issues as they move around.

Sometimes, the impossible can become possible, if you're awesome!

Kyle_Katarn
Offline
Last seen: 6 days 17 hours ago
Joined: 2018-01-14 13:25
So not easy to find the best

So not easy to find the best option... either is stay on PackageVersion in order to catch up emergency downgrade (but version does not reflec installed software) or use DisplayVersion but in this case i'll not notify emergency upgrades such as rollback...

John T. Haller
John T. Haller's picture
Online
Last seen: 19 min 11 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Internal vs External

Use both if you can. If not, use PackageVersion

Sometimes, the impossible can become possible, if you're awesome!

Kyle_Katarn
Offline
Last seen: 6 days 17 hours ago
Joined: 2018-01-14 13:25
I'll stay on PackageVersion

I'll stay on PackageVersion then.
Thanks for your clarification !!!!

Log in or register to post comments