You are here

[Fixed] Platform unable to update K-Meleon Portable

5 posts / 0 new
Last post
John T. Haller
John T. Haller's picture
Offline
Last seen: 4 hours 20 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
[Fixed] Platform unable to update K-Meleon Portable

The PA.c Platform's updater is unable to update K-Meleon Portable. It may be due to a bug/limitation in the VersionCompare function in NSIS and its ability to handle large dotted 4 versions like 76.45.2021.1204. I'll be investigating the issue and including a fix in the next platform one way or another. As a workaround for now, please download a K-Meleon Portable manually and install it via the Platform's manual paf.exe install to upgrade it.

RaphaelRB
Offline
Last seen: 1 month 1 week ago
Joined: 2011-07-20 11:10
Mixed strings maybe?

I've noticed that there's a difference between PackageVersion and DisplayVersion strings.

The PackageVersion is 76.43.2021.0522 or 76.45.2021.1204 (version 76 and subversions 43 or 45).
DisplayVersion changed from 76.4.3-2021-05-22 to 76.4.5-2021-12-04 (version 76, subversion 4 and sub-subversion 3 or 5).

If PortableApps Installer compares the new DisplayVersion's number with the installed PackageVersion's number, it will see the following:
installed version is 76 and new version is 76: draw
installed subversion is 43 and new version is 4: installed version is greater than version on site, therefore it keeps the current version.

Please check if PortableApps Installer is matching "PackageVersion with PackageVersion" or "DisplayVersion with DisplayVersion" and not mixing these two.

I've checked other programs with subversion "xx" (more than one digit) as Boinc, Skype and mssPortable) amd they have no difference between PackageVersion and DisplayVersion strings (at least not before the sub-sub-subversion).

It's just a thought, brainstorming here. And I hope it helps.

RaphaelRB - Brazil

RaphaelRB
Offline
Last seen: 1 month 1 week ago
Joined: 2011-07-20 11:10
Changing PackageVersion it works fine

The update to 76.4.5-2021-12-11 isn't working yet.
Old version: 76.4.5-2021-12-04.
I changed a line in file appinfo.ini in PortableApps\K-MeleonPortable\App\AppInfo from "PackageVersion=76.45.2021.1204" to "PackageVersion=76.4.5.2021.1204" (changed 45 to 4.5) and K-Meleon appeared on automatic update.

RaphaelRB - Brazil

John T. Haller
John T. Haller's picture
Offline
Last seen: 4 hours 20 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fixed

This whole time, I had a typo in the updater database with the second version place wrong. It's working now. Sorry about that.

Sometimes, the impossible can become possible, if you're awesome!

RaphaelRB
Offline
Last seen: 1 month 1 week ago
Joined: 2011-07-20 11:10
Fixed indeed

I've installed an old version (76.4.5-2021-11-06) just for test purpose and then PortableApps updater has offered the new one (76.4.5-2021-12-11). Thanks a lot!

RaphaelRB - Brazil

Log in or register to post comments