You are here

RapidSVN Portable Beta-0.5 (Testers needed and splash screen creators wanted).

18 posts / 0 new
Last post
Espreon
Espreon's picture
Offline
Last seen: 5 years 8 months ago
Joined: 2006-09-29 18:23
RapidSVN Portable Beta-0.5 (Testers needed and splash screen creators wanted).

Ok here is my 1st attempt of a portable app with an NSIS Launcher! The launcher is based off of John's Miranda Portable Launcher. I already know that this leaves nothing in the Registry but for some reason it won't export the keys. When I compiled it it said that the Registry Backup Label was not used. So long story short it cannot yet retain its settings, but it won't leaving any keys in the Registry though. I am not talented with NSIS.

Also anyone who is talented at making splashes please let me know cause I need a splash screen creator (I am not careful with the mouse and I don't have Photoshop, I am not talented with the GIMP and I'm not spending $800 on Photoshop (Adobes like the M$ of multimedia) and I no nothing about computer art (well almost nothing.

Now RapidSVN is an SVN app that is quite easy to use. It is infact my favorite non-KDE SVN client.

Link: https://downloads.sourceforge.net/armogohmasuites/RapidSVNPortable.paf.exe
(May take a few mins to hit all the servers)

Edit: Installer Issue Resolved, RapidSVN Portable will be fully pafed when I fix the current issue with the data not being saved.

If anyone could look at the .nsi file of the launcher and help me fix it.

Launcher Link: https://downloads.sourceforge.net/armogohmasuites/RapidSVNPortable.nsi
(May take a few mins to hit all servers)

Simeon
Simeon's picture
Offline
Last seen: 3 years 6 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
OK

Ill test it.
Where did you have problems compiling the installer?
You should:

  • put the 3 folder (App, Data and Other) in a folder called "files".
  • edit one of John installers to fit your App
  • Run one installer but dont press any buttons and copy the wizard.bmp from your temp folder to the same folder the "files" folder is in.
  • copy your installer.nsi from /Other portablesource/ to the same folder the "files" folder is in.
  • run installer.nsi

“I can live with doubt and uncertainty and not knowing. I think it is much more interesting to live not knowing than to have answers that might be wrong.” - Richard P. Feynman

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

Espreon
Espreon's picture
Offline
Last seen: 5 years 8 months ago
Joined: 2006-09-29 18:23
It said a macro was screwed.

""

--
As all of ya should know Micro$oft is the Evil Empire, and Windows (a.k.a. Winblows or Windoze) is their greatest general, so please make a difference and install Linux or FreeBSD on yer Windows comp.

Patrick Patience
Offline
Last seen: 2 months 6 days ago
DeveloperModerator
Joined: 2007-02-20 19:26
You need to have...

the proper sized bitmap image in the same directory as the installer and files dir called "wizard.bmp" like Simeon said, you have it?
______________________
Signature...What Signature?

Espreon
Espreon's picture
Offline
Last seen: 5 years 8 months ago
Joined: 2006-09-29 18:23
I have it, if I did not have it it would give me an error saying

I don't have it.

--
As all of ya should know Micro$oft is the Evil Empire, and Windows (a.k.a. Winblows or Windoze) is their greatest general, so please make a difference and install Linux or FreeBSD on yer Windows comp.

Patrick Patience
Offline
Last seen: 2 months 6 days ago
DeveloperModerator
Joined: 2007-02-20 19:26
No...

It would give you an error about english macros. Smile

______________________
Signature...What Signature?

Espreon
Espreon's picture
Offline
Last seen: 5 years 8 months ago
Joined: 2006-09-29 18:23
This is the error
!include: error in script: "F:\PortableApps\NSISPortable\App\NSIS\Contrib\Modern UI\Language files\English.nsh" on line 4
Error in macro MUI_LANGUAGE on macroline 5

This error does not occur when the language is set to "Default" but then the bitmap won't display when the installer is launched, plus many other errors occur. Is there any way to fix this?

Could someone tell me how it everything should be organized. Since it has been awile since I have been compiling these (and all those have been successful on Win-2K) and I have a rotten memory.

--
As all of ya should know Micro$oft is the Evil Empire, and Windows (a.k.a. Winblows or Windoze) is their greatest general, so please make a difference and install Linux or FreeBSD on yer Windows comp.

Patrick Patience
Offline
Last seen: 2 months 6 days ago
DeveloperModerator
Joined: 2007-02-20 19:26
Ok.

Sounds like the bitmap error.

Assuming you're using John's installer.

The bitmap image should be 164 x 314 pixels, and called "wizard.bmp", it is placed in the same directory as Installer.nsi. Also in the SAME directory is a folder called "files", within that is "App" "Data" "Other" and your exe, it should compile now. Make sure "files\App\appinfo\appicon.ico" exists as well.

______________________
Signature...What Signature?

Espreon
Espreon's picture
Offline
Last seen: 5 years 8 months ago
Joined: 2006-09-29 18:23
Error still occurs

And everything as u described is true and I am using John's installer.
In the mean time I will make a Google Earth Portable Launcher.
I don't know why this does not happen on 2K.

--
As all of ya should know Micro$oft is the Evil Empire, and Windows (a.k.a. Winblows or Windoze) is their greatest general, so please make a difference and install Linux or FreeBSD on yer Windows comp.

Patrick Patience
Offline
Last seen: 2 months 6 days ago
DeveloperModerator
Joined: 2007-02-20 19:26
When you get a second.

Zip up the whole directory layout you're compiling in with ALL its files and give me a link please.

______________________
Signature...What Signature?

Espreon
Espreon's picture
Offline
Last seen: 5 years 8 months ago
Joined: 2006-09-29 18:23
Here u go

http://download239.mediafire.com/9zmcf4xttf4g/8nfkje2uort/Stuff.zip

--
As all of ya should know Micro$oft is the Evil Empire, and Windows (a.k.a. Winblows or Windoze) is their greatest general, so please make a difference and install Linux or FreeBSD on yer Windows comp.

Patrick Patience
Offline
Last seen: 2 months 6 days ago
DeveloperModerator
Joined: 2007-02-20 19:26
Thanks.

Haha, without changing a think I compiled it and it worked perfectly. Here, I thru my bitmap image in thereinstead only because the PortableApps.com one is trademarked. Maybe try with a clean install of NSIS Portable, cause I'm using NSIS Portable and it worked fine.

______________________
Signature...What Signature?

Espreon
Espreon's picture
Offline
Last seen: 5 years 8 months ago
Joined: 2006-09-29 18:23
Nice! a 404

The Link gives me a 404 error.

--
As all of ya should know Micro$oft is the Evil Empire, and Windows (a.k.a. Winblows or Windoze) is their greatest general, so please make a difference and install Linux or FreeBSD on yer Windows comp.

Patrick Patience
Offline
Last seen: 2 months 6 days ago
DeveloperModerator
Joined: 2007-02-20 19:26
Gees man.

You're two quick, I spelt it wrong. Blum

http://nascent-project.org/RapidSVNPortable-0.9.4.paf.exe

______________________
Signature...What Signature?

Espreon
Espreon's picture
Offline
Last seen: 5 years 8 months ago
Joined: 2006-09-29 18:23
Thanx

Now to recompile. I really need an artist. Patrick who does your splashes/installer bitmaps? Was it ZGitrdun?

EDIT: ZOMFG! It works thanx Patrick, I was too lazy to reinstall til u told me too. Thanx.

--
As all of ya should know Micro$oft is the Evil Empire, and Windows (a.k.a. Winblows or Windoze) is their greatest general, so please make a difference and install Linux or FreeBSD on yer Windows comp.

ZachHudock
ZachHudock's picture
Offline
Last seen: 3 months 1 week ago
Developer
Joined: 2006-12-06 18:07
I made the wizard.bmp image,

I made the wizard.bmp image, and I made a template for his splashes. Patrick adds each application's icon and changes the text in the splash himself.
_________________________
I don't believe in signatures

The developer formerly known as ZGitRDun8705

fer135
Offline
Last seen: 9 years 2 months ago
Joined: 2009-01-07 13:10
Apache mod_dav_svn mod_authz_svn

Hello, I'm testing and I found one problem when I try to checkout new working copy from a secure repository (you need permission to read), it doesn't ask for password and automatically says access forbidden.

I haven't tried it in svnserve yet, but i guess will be the same.

FeArX

Zach Thibeau
Zach Thibeau's picture
Offline
Last seen: 4 years 5 months ago
DeveloperModerator
Joined: 2006-05-26 12:08
you do realize this is

you do realize this is severly outdated

your friendly neighbourhood moderator Zach Thibeau

Log in or register to post comments