You are here

Profile don't work right after upgrade to 2.0.0.9

10 posts / 0 new
Last post
Franz49
Offline
Last seen: 16 years 7 months ago
Joined: 2007-12-08 06:56
Profile don't work right after upgrade to 2.0.0.9

Hi anyone!
I upgraded my previous version to the last.
Now all my settings are away, including my mails. The Folder I still see, but there are no mails into - I checked also the .js files, I can't understand few of the entrys.
If I check by Explorer, I can find my mail and setting files but Thunderbird dont use they. Can anyone give me informations about the right structure where the different setting and mailfiles must be located? What kind of system is used to setup the right paths and settings, there exists more .ini files - I don't know the right one.
Thanks for help

wsm23
Offline
Last seen: 12 years 5 months ago
Joined: 2006-01-09 22:05
Start with the obvious.

You of course backed up your profile before you upgraded right?

Are you using a standard structure with PA menu installed in the root of your flash drive and did you use the PA menu to install the upgrade?

The easiest way to fix your problem is to delete the TB folder, reinstall TBPE then copy your profile back over. That is if you backed up your profile of course.

Life is about the journey not the destination!

The Kazoo Spartan

Franz49
Offline
Last seen: 16 years 7 months ago
Joined: 2007-12-08 06:56
Start with the obvious

Thanks for answer. I had copied my backupfolders back on the right place, but the system still not recognice my folders and ask me to create a new account. If I lock on the folderstructure, I found more entrys like Locale Folders 1, Locale Folders 2 and so on. In my opinion the .js may have invalid entrys generated by few fault situations.
An other question: can I use any other Utility to convert (get) the database back in a original format (especialy the attachements)?
I recogniced that my XP sometimes loose the directory and files of the USB stic. But the drive (in my case G:) is possible to access - there is no entry to see.
If I stop the device, physically disconnect and reconnect all the data are there.
A check of the drive by chkdsk reports no errors.
I don't know whats going on.

wsm23
Offline
Last seen: 12 years 5 months ago
Joined: 2006-01-09 22:05
Major question

Upgrade from what version of TBPE?

Life is about the journey not the destination!

The Kazoo Spartan

Franz49
Offline
Last seen: 16 years 7 months ago
Joined: 2007-12-08 06:56
The former version was from

The former version was from 1.5.0.5
I think there is any mistake by loading the preferences.
If I don't find out was going on, I just use the mail storage from Yahoo.
I hope, they don't have similar troubles with.
I went from Outlook to TBPE in order to have my data with me - now I must recognize my decision was not so good.
Thanks
Franz

bergerk
Offline
Last seen: 16 years 6 months ago
Joined: 2007-08-13 03:20
Experienced the same ....

Hi,

I do face a similar (or maybe the same) problem.

Update to 2.0.0.9 (from 1.5.0.5) and all profiles are gone, a "naked" Thunderbird starts and asks me to create a profile...

The structure of the folders in the ...\portable thunderbird folder is a different in 1.5.0.5 than in 2.0.0.9

I tried everything (updating by using the portableapps menue as well as updating by just using the .exe file), the update simply doesn´t work.

Can anybody help?

Thanks,

Karl

Franz49
Offline
Last seen: 16 years 7 months ago
Joined: 2007-12-08 06:56
Soloution found

... after spending two days for experiments, now I found a soloution for:
I deleted the upgraded version of TBP completely (including the root folder).
Theirafter, I installed the TBP V2.0.0.9 again.
Next step, I checked the backup of the DATA folder and deleted all files and folders I can't associate with my mail data.
Then I copied the structure in the DATA folder from the USB STIC.
Now I started TBP - I was funny, all my old structure and files was there.
Only the setup of the accounts I loosed and must make new.

My Intends was based on Informations of a German website

Simeon
Simeon's picture
Offline
Last seen: 9 years 9 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
I think I know the problem

For some reason, one cant update a 1.5.*.* installation of Thunderbird Portable directly to 2.0.0.9. Someone in the german Forum had this problem and got it to work with a 2.0.0.6 version. My guess is that this has to do with the othre thing that the auto-update doesnt work any more. Maybe both of these problems were introduced in 2.0.0.9 (there is no 7 or 8 )???

So I think John or someone else should put this on the support page.
And all of you should know in case someone asks so you can respond nicely Smile

EDIT I checked the releasenotes of 2.0.0.9 and it seems that they changes some things regarding how the installer handles old registry entries (bugs 393149 and 389244)...:(

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

Tim Clark
Tim Clark's picture
Offline
Last seen: 13 years 3 months ago
Joined: 2006-06-18 13:55
U3 situation

Simeon,

This was my concern with the migration from PTB4U3 1.5.old to TBP 2.0.current. I remember reading somewhere that copy and past of the profile might not be enough in a major version change and I was sure it could not be any easier in the U3 to PA.com migration. Same probably goes for PFF4U3 1.5.x to FFP 2.0.x

I'm glad you are investigating this Smile
Thank you

Tim

Things have got to get better, they can't get worse, or can they?

Simeon
Simeon's picture
Offline
Last seen: 9 years 9 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
Yes

I see now.
I hope/think this is a "TB only" issue as I happily converted the old FF to the 2.0
But maybe I have to do more research.
The whole thing would be a lot easier if John would make a new Launcher who handles that Smile but it looks like that John is either working on something really big or again has a close friend in the hospital.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

Log in or register to post comments