You are here

Pidgin: Updating Manually from 2.1.1 to 2.3.1

8 posts / 0 new
Last post
Gizmokid2005
Gizmokid2005's picture
Offline
Last seen: 1 month 1 week ago
Developer
Joined: 2007-01-17 19:24
Pidgin: Updating Manually from 2.1.1 to 2.3.1

Now, because I know what some people might think this thread is, it's not. I'm not asking when the next release/update will be, but rather a question for those who work behind the scenes.

I just got an idea today, to upgrade my Pidgin from 2.1.1 to 2.3.1. I figured I could easily do it, but just replacing the files in the App/Pidgin/ directory under the PidginPortable folder to the recent files from the standard local install (with the except of the pidgin.exe) and it should run.

I managed to do that, and it seems to run, but my question is, is it possible to update it like this?

I can't think of any reason why it wouldn't as I'm not replacing any of the launchers/ini files, just the .dll and app files for pidgin.

Any thoughts/input?

Thanks!

Simeon
Simeon's picture
Offline
Last seen: 9 years 8 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
maybe

the new pidgin requires some registry keys or files to be handled and the old launcher doesnt do that?

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

Gizmokid2005
Gizmokid2005's picture
Offline
Last seen: 1 month 1 week ago
Developer
Joined: 2007-01-17 19:24
Well, I went ahead and

Well, I went ahead and copied them from my local install into my App/Pidgin/ folder and all seems to be well so far. MyspaceIM works, and I haven't found any bugs yet. I will be sure to keep you updated, but so far, so good Smile

I just did a manual copy of the pidgin folder and the dlls that needed to be in root, no launcher or anything.

Miokawaii
Offline
Last seen: 16 years 5 months ago
Joined: 2008-01-14 00:19
anybody manage to get

anybody manage to get guification working with this method of manual upgrade/update?

Gizmokid2005
Gizmokid2005's picture
Offline
Last seen: 1 month 1 week ago
Developer
Joined: 2007-01-17 19:24
I had guifications working

I had guifications working before I upgraded. You just have to make sure to install it via the ZIP install not the EXE from the developer. It is still working currently.

BDKMPSS
Offline
Last seen: 15 years 3 months ago
Joined: 2007-08-06 16:52
not 100%...

This way you are not updating the GTK runtime and the Version shipped with 2.1.1 has some bugs in it which got fixed since than.
But even with the old GTK it is usable and better than 2.1.1

(btw engineman has done exactly the same thing and posted his steps to upgrade and new versions some time ago)

<German>
"Sozialismus ist der Versuch die Gesellschaft mit
verordneter und erzwungener Freiheit zu unterdrücken."
(2007-07-24)
</German>

Gizmokid2005
Gizmokid2005's picture
Offline
Last seen: 1 month 1 week ago
Developer
Joined: 2007-01-17 19:24
True, and I understand that.

True, and I understand that. But as long as the old Rev of GTK still works, I see not hurry in upgrading.

But you can use the same fashion to update GTK Smile

Gizmokid2005
Gizmokid2005's picture
Offline
Last seen: 1 month 1 week ago
Developer
Joined: 2007-01-17 19:24
I just thought I'd update on

I just thought I'd update on this. I have been running Pidgin in this fashion ever since I made this post. I haven't updated GTK and I have experienced absolutely no issues whatsoever. Can't wait for the actual release from John!!

I'd offer to help work on this if I had any idea what to do.

Log in or register to post comments