You are here

[DOSBox Portable] installing german language (not KEYB)

6 posts / 0 new
Last post
Traeumer76
Offline
Last seen: 6 months 4 days ago
Joined: 2008-02-26 04:43
[DOSBox Portable] installing german language (not KEYB)

Hello everybody,

i need some help installing the german language file in "DOSBox Portable". Maybe it´s the same problem with other languages, too.

I downloaded the file and put it into my \DOSBoxPortable\App\DOSBox\ where the original README.txt is located. (That seemed to be the directory similar to the "Application folder" mentioned in the instructions.)
Afterwards i changed the dosbox.conf from "language=" (standard setting) into "language=deutsch.lng"

When i then started DOSBox, it exited with the error message: "Exit to error: MSG:Can´t load messages: deutsch.lng"

For testing i also installed a normal DOSBox v0.72 and there it worked.
I recognized that the directory structure is different from the portable version. So i tried placing the file in some other folders, but it had always the same effect.

Does anybody have an idea on what went wrong? Where could be a difference between portable and normal version that may cause this problem?

Thanks for your help!

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 5 years 2 months ago
DeveloperModeratorTranslator
Joined: 2006-01-16 04:08
It works ...

...if You'll edit the right dosbox.conf Smile
Please edit /Data/settings/dosbox.conf

Tested with DOSBox-german-lang-070 (copy deutsch.lng to /App/DosBox)

German Layout and Welcome Message is present.

Regards
Marko

Paid for Software more or less?
What You need is OSS!

Traeumer76
Offline
Last seen: 6 months 4 days ago
Joined: 2008-02-26 04:43
Thanks for the

Thanks for the response...

Unfortunately it didn´t work. Same error message again. Did you test it with the portable version?

By the way, with your info and a look into the readme of that portable-launcher i now understand the directory structure.

Regards

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 5 years 2 months ago
DeveloperModeratorTranslator
Joined: 2006-01-16 04:08
Yes, tested with last portable version ...

... and only portable.
Perhaps there are problems with a local installed version.

BTW: Please ignore all other tipps in the german lang readme. It only works, if You only edit this inf direct. Don't try to modify the ini from the DOSBOX promt! Don't start DOSBOX with additional parameters.

Simply set:

[dosbox]
language=deutsch.lng

[dos]
keyboardlayout=gr

regards
Marko

Paid for Software more or less?
What You need is OSS!

Traeumer76
Offline
Last seen: 6 months 4 days ago
Joined: 2008-02-26 04:43
So somewhere...

...in my system a former installation of DOSBox must have left its traces that are now confusing my portable version? Why is a "portable" application responding that much to the local installation? Strange!

But i believe you are right. I installed PortableDOSBox on another PortableAppsSuite running on my colleagues machine and setup of german language worked at first go.
Last thing will now be to test my usb stick on his machine... tomorrow. I will tell you the finding.

And i will have a look for that parts of an older DOSBox installation (that actually existed months before and has been uninstalled). Maybe there´s something left in registry.

Bye,
Traeumer.

DjDiabolik
Offline
Last seen: 1 year 1 month ago
Joined: 2015-12-28 13:46
Apparently there's no working

Apparently there's no working for 0.74.

I have put a itlalian.lng on D:\DOSBoxPortable\App\DOSBox where's the original dosbox.exe......... after that i have modified the cfg files and i have put language=italian.lng.

Return to main windows have launch the DosBoxPortable.exe and it's be launched in english...... apparently the lng files it's be ignored.

I have also tryed to put the file in same folder of .conf file......same problems...... do not work...........

*EDIT*
Apparently crash when i try to launch in fullscreen......

Log in or register to post comments