You are here

Toucan 1.2.1.1: Parameter is incorrect, zip format, incremental backup

8 posts / 0 new
Last post
siroquen
Offline
Last seen: 16 years 3 months ago
Joined: 2008-04-01 12:40
Toucan 1.2.1.1: Parameter is incorrect, zip format, incremental backup

Hi all,

I get the following error when trying to do an incremental backup of one of my folders. I have also tried Toucan 1.2.2 PR2, but the same thing happens. I have also tried using a newer version of 7-Zip: nothing changes.

Any ideas?

Starting...
7-Zip Angel 4.42 Copyright (c) 1999-2006 Igor Pavlov 2006-05-14

Scanning

Creating archive I:\Backups\PortableApps\2008-04-05-14-36.zip

Error:

System error:
The parameter is incorrect.

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 10 years 10 months ago
Developer
Joined: 2005-12-10 15:22
Hi,

I am afraid that I cannot reproduce this issue, does it work if you use the 7zip method?

siroquen
Offline
Last seen: 16 years 3 months ago
Joined: 2008-04-01 12:40
With the 7-zip format it

With the 7-zip format it works, it seems that this bug only arises when using the .zip format.

I have tried many different workarounds but none seemed to work (different 7-zip executable versions (7za.exe) , different toucan versions, launching from command line, launching from within toucan, always the same error). I have also run checkdisk on both involved hard drives (0 errors), and also checked the .zip files for consistency (0 errors as well).

The worst of all is that this happened overnight, yesterday night I run an incremental backup of one of my folders, and the basefile.zip was created succesfully. I then modified a file on purpose and run the backup again just to test the application and it worked (and then I decided to replace my usual backup application with toucan!!). No idea why this happens, but I've seen many other users reporting the same bug Sad

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 10 years 10 months ago
Developer
Joined: 2005-12-10 15:22
Ahh

but the bugs reported by other users have been fixed. Can anyone else reproduce this?

Pavel.Petrov
Offline
Last seen: 16 years 1 month ago
Joined: 2008-06-10 07:43
Same problem with incremental backup

Hi,
i've got the same problem with Toucan 1.2.2.0, when i use 7-zip format everything works fine, but once i switch to zip it make basefile normally, but can't make incremental file.
Once i tested it on simple folder(1 file in 1 folder, added 1 file later for incremental) it works ok - Toucan made base file with 1 file and incremental with other file.
But once i tried to run it on my main "My documents" folder it made BaseFile successfully but i got a system error on incremental part:
==============================
Starting...
7-Zip Angel 4.42 Copyright (c) 1999-2006 Igor Pavlov 2006-05-14
Scanning
Creating archive F:\Work\BackUp\test\2008-06-10-16-43.zip
Error:

System error:

==============================

Another problem is that Toucan doesn't write the reason of errors and system errors, i get only empty strings.

Also seems like Toucan got some bug in log writing, once i made an abort of backup it started writing "Aborted..." in the end of every operation log(even successfull backups). It continues till application restart.

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 10 years 10 months ago
Developer
Joined: 2005-12-10 15:22
This

should all be fixed in the Pre-release of version 2 now avalible in the Beta Testing forum, could you test with this please as I cannot reproduce it.

Pavel.Petrov
Offline
Last seen: 16 years 1 month ago
Joined: 2008-06-10 07:43
Version 2

Seems like version 2 works fine with zip-archives, but it have lots of minor bugs and errors. I will probably wait for more stable version.
Tnx for response )

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 10 years 10 months ago
Developer
Joined: 2005-12-10 15:22
Could

you post any errors on in the Toucan 2 post so that I can fix them please Smile

Log in or register to post comments