You are here

Auto Update to 1.5.0.2 Fails

21 posts / 0 new
Last post
Anonymous (not verified)
Auto Update to 1.5.0.2 Fails

As I recall PFF updated just fine from 1.5 to 1.5.0.1 ...

Are other people having a problem updating to 1.5.0.2? If so, is there a fix?

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 10 years 10 months ago
Developer
Joined: 2005-12-10 15:22
I dont think that it did

I dont think that it did update fine (1.5 - 1.5.0.1)

Yours

Steve Lamerton

Developer Profile Sync & PortaLog

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 4 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Server issues

The update server itself is a bit overloaded. I tried updating a local copy earlier and it failed to connect. I just updated my copy of PFF and it worked fine.

Sometimes, the impossible can become possible, if you're awesome!

bwbass (not verified)
Oops!

No, it wasn't the update server, it was my too-full flash drive. Freeing up a little extra room allowed the update to install.

Sorry 'bout that!

srf21c
Offline
Last seen: 17 years 10 months ago
Joined: 2006-03-22 13:36
update to 1.5.0.2 jacks up browser window.

The update has created an inch high band of grey "nothingness" between the bottom of the firefox window, and the status bar. Can I roll back? Maybe I should call this an "upgrate" Wink

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 4 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Extension

99% of the time, it's an extension that isn't happy with the update. It happens with local FF, too.

Sometimes, the impossible can become possible, if you're awesome!

srf21c
Offline
Last seen: 17 years 10 months ago
Joined: 2006-03-22 13:36
Right you are. I

Right you are. I uninstalled the "Firefox Extension Backup" extension and viola! Problem solved. Thanks John.

dauge
Offline
Last seen: 15 years 7 months ago
Joined: 2006-04-24 20:55
Grey Bar

My understanding is these are caused by a bad extension. Try disabling one at a time and see if it disappears.

TheTiGuR
Offline
Last seen: 8 months 1 week ago
Joined: 2006-03-20 16:14
'other' issue with updating

I have had a couple problems problems with updating:
1. The 'patch' isn't working, it downloads, applies, then indicates it failed, so it downloads the full install. It applies the full install, but something is still borked. I can go to Help->About and see it says 1.5.0.2, but it doesn't seem to recognize this and will try to upgrade again later.

2. A plugin (pass2go, a.k.a. roboform) says unsupported browser, supports 1.5.0.2 and detected version is blank.

Any thoughts on how to resolve this?

wsm23
Offline
Last seen: 12 years 5 months ago
Joined: 2006-01-09 22:05
Latest Version of Roboform

The latest version of Roboform is 6.6.7. Check your version. I think it came out last week. http://www.roboform.com/browsers.html

It may also auto update itself if you check for updates under your extension menu.

Life is about the journey not the destination!

The Kazoo Spartan

TheTiGuR
Offline
Last seen: 8 months 1 week ago
Joined: 2006-03-20 16:14
Thats one of the problems, I

Thats one of the problems, I *have* the update, but it cannot detect the version of PFF at all.

As mentioned as well, PFF doesn't seem to know its own version either as it is still trying to update itself to 1.5.0.2, even though 1.5.0.2 is actually installed.

wsm23
Offline
Last seen: 12 years 5 months ago
Joined: 2006-01-09 22:05
Extension

This is getting beyond my abilities if this doesn't work.

Have you installed the extension directly into your browser manually?

BTW-I quit using Pass2Go(Roboform) for just these kind of issues. I now use SignupShield U3.

Life is about the journey not the destination!

The Kazoo Spartan

TheTiGuR
Offline
Last seen: 8 months 1 week ago
Joined: 2006-03-20 16:14
I don't blame pass2go, I

I don't blame pass2go, I blame PFF. The root of the problem lies in PFF and its failing to update properly. I could click right now and attempt supposedly update PFF to 1.5.0.2, even though the help screen for PFF shows 1.5.0.2 already. And after that installation was complete, I could do it again. Once *that* issue is resolved, I am fairly confident that my pass2go problems will go away. The pass2go issue was originally mentioned as a demonstration that there is something wrong with PFF, not because I was indicating that I thought there was a problem with it.

Thank you to anyone who has some insights on how to resolve this (preferring to *not* reload pff and all my misc extensions).

TheTiGuR
Offline
Last seen: 8 months 1 week ago
Joined: 2006-03-20 16:14
....oh yeah.... I had

....oh yeah.... I had previously renamed firefox.exe to ff.exe (so I can use torpark and pff at the same time). Having remembered this, I renamed the NEW firefox.exe to ff.exe and restarted, and voila! And yes, pass2go works great, now that it can find the right version.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 4 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Renaming

Renaming any files within Firefox will mess with its ability to auto-update correctly. This applies to any version of Firefox... standard, Portable or U3.

I don't recommend running TorPark and Portable Firefox at the same time. This is not a supported configuration and is at your own risk.

Sometimes, the impossible can become possible, if you're awesome!

TheTiGuR
Offline
Last seen: 8 months 1 week ago
Joined: 2006-03-20 16:14
I understand and am aware of

I understand and am aware of the concerns. I have the need/desire to run both because of a less than friendly work environment, which includes potentially getting reprimanded for researching information not directly related to tasks at hand. As far as renaming, I'll just have to remember with each release to resolve that little issue up front. =-)

raggedy (not verified)
Update successful but PFF doesn't run at all!

It autoupdated itself and I chose to restart later, which I did. Since then, the splash screen comes up but that's it. Reinstalled 1.5.0.1 and this time took ages applying the update. Still the same result. Have tried memory stick on other computers and no change. No files have been renamed and I have about 20mb free on a 128mb stick.

Any ideas?

Cheers!

Ashes for Tears
Offline
Last seen: 16 years 9 months ago
Joined: 2006-01-11 08:41
It may just be taking a bit

It may just be taking a bit to initialize. I had a similar problem, except I was also able to watch the process via taskmanager. It just had to think for a while, then it came up just fine.

IMHO: Best for the job:
ProcessExplorer

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 4 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
More than 20mb

You need more than 20mb free on the key to use the autoupdate process. It requires a lot of space. And, due to a bug in FF, doesn't warn you if you're out of space.

Copy the directory locally. Update it. Copy it back.

Sometimes, the impossible can become possible, if you're awesome!

Ashes for Tears
Offline
Last seen: 16 years 9 months ago
Joined: 2006-01-11 08:41
Hmmm...good to know. `

Hmmm...good to know. Smile
`

raggedy (not verified)
Re: More than 20MB

That was it!

Nice one John. Keep up the good work!

Topic locked