You are here

First Lightscreen bug (confirmed)

20 posts / 0 new
Last post
Simeon
Simeon's picture
Offline
Last seen: 7 years 8 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
First Lightscreen bug (confirmed)

I think i found the first bug, but maybe its Lightscreen itself.
Bug-Description:
If I run the programm, a window appeares with a big "screenshot"-labelled button on the left. If I click on the button I get a menu, whose last entry is "Go to Folder". If I click it, nothing happens. It doesnt go to the desired folder.
OS:
Windows Xp Professional SP 3 limited user, Admin and Guest

wk
wk's picture
Offline
Last seen: 2 weeks 5 days ago
Joined: 2007-09-05 12:31
had the same bug..

go to options and reconfirm the path..
after that it should work..

"Lorem ipsum dolor sit amet, consectetur adipisici elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis .." Friday Next -
"May The Schwartz be with You!" Yogurt the Yoda

Simeon
Simeon's picture
Offline
Last seen: 7 years 8 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
Thanks

Right. That solved it. I think David should mention that somewhere...

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

John T. Haller
John T. Haller's picture
Online
Last seen: 35 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
What was it?

What was it set to before you set it? It should automatically set itself to X:\Documents\Pictures

Sometimes, the impossible can become possible, if you're awesome!

Simeon
Simeon's picture
Offline
Last seen: 7 years 8 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
Dont worry John

It was set to X:\Documents\Pictures as its suppost to be.

I just have to manually browse to the location to make the "Go to folder" button work. Dunno why though.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

wk
wk's picture
Offline
Last seen: 2 weeks 5 days ago
Joined: 2007-09-05 12:31
right

I upgraded from o.4 prerelease, the path has been set as mentioned above.I´ll try with a fresh install...
EDIT: same here with a fresh install on desktop
path is set correctly but has to be confirmed on first start..

"Lorem ipsum dolor sit amet, consectetur adipisici elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis .." Friday Next -
"May The Schwartz be with You!" Yogurt the Yoda

samcleve
Offline
Last seen: 9 years 1 month ago
Joined: 2008-04-19 13:16
Is the trick forward v. backward slashes?

For me, resetting the path as instructed changed the direction of the slashes. It went from the original, non-functioning X:\Documents\Pictures to the properly-functioning X:/Documents/Pictures. Hope that helps.

wk
wk's picture
Offline
Last seen: 2 weeks 5 days ago
Joined: 2007-09-05 12:31
Hey, you´re right

good eyes..;)

"Lorem ipsum dolor sit amet, consectetur adipisici elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis .." Friday Next -
"May The Schwartz be with You!" Yogurt the Yoda

Simeon
Simeon's picture
Offline
Last seen: 7 years 8 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
ditto

thats it. Too bad prerelese time is over Sad

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

OliverK
OliverK's picture
Offline
Last seen: 1 year 2 days ago
Developer
Joined: 2007-03-27 15:21
Rev 1!

Rev 1!

Too many lonely hearts in the real world
Too many bridges you can burn
Too many tables you can't turn
Don't wanna live my life in the real world

David Dixon II
David Dixon II's picture
Offline
Last seen: 4 months 2 weeks ago
Developer
Joined: 2007-06-11 22:54
Lightscreen Itself

So it this a lightscreen itself bug or it this a problem with my version? Cry

Na na na, come on!

Simeon
Simeon's picture
Offline
Last seen: 7 years 8 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
yours

Its a problem with your version.
I cant try it myself, but I think the solution is as follows:
In the launcher on line 219, it specifies the default screenshot folder.
Now it reads "$1:\Documents\Pictures"" but I think it should read "$1:/Documents/Pictures".You have to change line 223 too.

I cant verify atm if thats right, but i think it is.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

David Dixon II
David Dixon II's picture
Offline
Last seen: 4 months 2 weeks ago
Developer
Joined: 2007-06-11 22:54
Well I Fixed Mine

It works now.
Users will have to delete thier registry key in "Data\settings" and then start it up.

I downloaded a fresh install of the official version just in case, so if John wants to release my fix as Rev 1, can you, john, please reply. Thanks

Na na na, come on!

John T. Haller
John T. Haller's picture
Online
Last seen: 35 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Maybe

Maybe we'll just do a Rev 2 sans release announcement since it only affects first run and the fix is easy.

Sometimes, the impossible can become possible, if you're awesome!

David Dixon II
David Dixon II's picture
Offline
Last seen: 4 months 2 weeks ago
Developer
Joined: 2007-06-11 22:54
Explain

Can you please explain to me what that means? And what i will have to do?

Me talking to myself
I dont understand what so ever why we have to use / instead of \, When \ is the main slashy thing. And when you open the folder, explore shows the slashys as \.... I will never understand... :|

Na na na, come on!

John T. Haller
John T. Haller's picture
Online
Last seen: 35 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Bug

Essentially, it's a bug in Lightscreen itself. It only uses the forward slashes, so you can't past a standard Windows path in that box. So we have to accomodate for that bug.

Sometimes, the impossible can become possible, if you're awesome!

JRViejo (not verified)
Unusual

John, users might hide LightScreen (not using its GUI) before taking a screen capture because if one uses Alt-PrtScrn, while on screen, it takes a picture of the application window instead and perhaps that's why this bug did not appear during testing. Not making any excuses just a personal observation.

I just installed it on 2 USB drives. After installation, the first thing one sees is the Options windows, and if you click OK without changing anything, the main LightScreen window opens. I can confirm the stated issue and the steps to resolve it.

However, I don't want to throw in another monkey wrench but my Zone Alarm Firewall lights up with a Security Alert stating that the program is trying to connect to the Internet. I deny it and it does not seem to affect the operation of the program thereafter but I can't find why it does this (no visible option to tweak). Only happens during the installation process; afterwards, it doesn't try to connect at all. ???

Tim Clark
Tim Clark's picture
Offline
Last seen: 11 years 2 months ago
Joined: 2006-06-18 13:55
Security Alert

Security Alert stating that the program is trying to connect to the Internet

It is checking for updates, i really feel this should be documented somewhere.
It will check on first install, and no one seems to know how often after that. It seems there's no way to stop it.

Tim

Things have got to get better, they can't get worse, or can they?

JRViejo (not verified)
Agreed

Tim, that's why I mentioned the Alert because I didn't see the info anywhere. Someone could suspect that LightScreen is a rogue program, although we know it is not. I'll keep an eye out to see if it tries to connect again after a period of time.

Bart.S
Offline
Last seen: 6 months 3 days ago
Developer
Joined: 2008-07-23 07:56
Well, another small thing

The file \LightscreenPortable\App\Lightscreen\lightscreen.ini can be deleted.
Keep up the good work!

Log in or register to post comments