You are here

multiple proxies

9 posts / 0 new
Last post
znaya
Offline
Last seen: 15 years 4 months ago
Joined: 2005-12-10 04:57
multiple proxies

Hello.

I use PFF in several places and extensions like "SwitchProxy" and "Yahoo! Mail Notifier" are really helpful.

I tried PFF 1.5 but i'm experiencing some problems with proxy handling.
"SwitchProxy" button acts a bit weird... there are no proxy names on it and there is a proxy password form constantly poping up! Sometimes it pops up 6 and 7 times while a webpage is loading and everytime "Yahoo! Mail Notifier" checks for new mail! First i thought it could be a problem of "SwitchProxy", maybe a compatibility problem between "SwitchProxy" and PFF 1.5. I disabled "SwitchProxy" and installed "xyzproxy". The problem persists. The proxy password hasn't changed recently and is correct.

I never had this problem with previous PFF versions. Maybe there was a proxy password form pop up once in a while... but not constantly.

Does anyone have the same problem?
Does anyone have a clue of a solution to this (annoying) problem?

Thanks in advance.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 15 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Start from scratch

I think SwitchProxy had some issues when upgraded from FF 1.0 to 1.5. Try starting with the default Portable FF profile and add in SwitchProxy. If all works well, rebuild the rest of your profile.

If you're heavy on extensions, I recommend rebuilding a fresh profile for FF 1.5, both regular and portable.

Sometimes, the impossible can become possible, if you're awesome!

znaya
Offline
Last seen: 15 years 4 months ago
Joined: 2005-12-10 04:57
Default PFF

Hello.
I'm using a default PFF instalation (no extensions at all) and I still have the very same problem. Sad Everytime i click a link it asks me (at least one time per click) for the proxy password). It may also be a proxy issue, i dont know (although i never had this kind of problem with other PFF versions). At this moment i can't test it on another proxy.

-Z-

-Z-

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 15 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Test with local FF

Test it with a local copy of FF using the sample configuration. If it doesn't work their either, it's a SwitchProxy or config issue and you should probably ask the SwitchProxy folks.

Sometimes, the impossible can become possible, if you're awesome!

znaya
Offline
Last seen: 15 years 4 months ago
Joined: 2005-12-10 04:57
Local FF

I also thought of using a local FF copy. The problem is that i'm using a very limited windows embedded account, at the work, from a "HP Compaq t5000" terminal. There is no space available to download files and no possibility to install anything... Tonight i'll try to use PFF 1.5 at another place and i'll give feedback about it.-Z-

-Z-

znaya
Offline
Last seen: 15 years 4 months ago
Joined: 2005-12-10 04:57
Local FF

I also thought of using a local FF copy. The problem is that i'm using a very limited windows embedded account, at the work, from a "HP Compaq t5000" terminal. There is no space available to download files and no possibility to install anything... Tonight i'll try to use PFF 1.5 at another place and i'll give feedback about it.-Z-

-Z-

znaya
Offline
Last seen: 15 years 4 months ago
Joined: 2005-12-10 04:57
Normal PC, other proxy

PFF 1.5 seems to work fine here (normal pc [not a HP terminal], other proxy). Only asked password on opening. So far, so good.
I keep thinking of what the problem is when using it on the HP terminal. It's weird...
-Z-

-Z-

luxnews
Offline
Last seen: 16 years 2 months ago
Joined: 2006-01-31 03:25
Microsoft Proxy continously asking for password!

I'm sorry but thre have been some modification betwen FF107 and FF150. At least in the portable "porting" (sorry for the alliteration) with 107 I can use with no problems (no plug-ins). If i close it and reopen pFF150 on every page I have to press enter to the prompt of Domain\Username - pw ...which is quite boaring Sad !!

It was a known problem in Firefox 0.9x and was solved with .... i don't recall which statement in prefs.js

The problem is that PortableFirefox.exe always rewrites over it and if you make some change this change is overwritten.

I tried to keep away some NTLM statement. The login is infact NTLM related and there is a new statement from 1.07 to 1.50:

user_pref("network.ntlm.send-lm-response", false);

In 1.07 there is NOT this statement and all works smoothly!

I hope someone can help me.

BTW I didn't have time to redo the experiment but as far as I remember the FF 150 NOT portable DOES work with micro$oft proxy server !!!

Luca

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 15 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
That's FF, not PFF

FF 1.5 had some changes. The FF within PFF is completely unaltered except for some minor changes to settings (disabling history, form saves, etc). It isn't even compressed. So it's a FF issue.

Sometimes, the impossible can become possible, if you're awesome!

Topic locked