You are here

Problems with command-line

9 posts / 0 new
Last post
alan-g
Offline
Last seen: 9 years 7 months ago
Joined: 2008-09-11 02:01
Problems with command-line

Hello,

when starting Toucan in command line modus I get an error message, that is:

Can't load image from file 'addvar.png': file does not exist.

When I click 'OK', then Toucan does the sync job, but I think the error message is not wanted.

What can I do to solve this problem.

Thank you for helping.

Alan Göttle

PS: A screenshot is here:

http://www.bilder-space.de/show.php?file=ihJdsS3MW6Z3Xj7.jpg

123martin321
Offline
Last seen: 15 years 7 months ago
Joined: 2008-09-11 04:58
Annother commandline question

@Allen: Are you sure the current directory is .\Toucan\App\toucan ?

I have another command line problem. I can't get Toucan to run scripts.
It tells me "Sorry the command is not recognized". It works fine with syncjobs though.

Thanks you for an excellent app! Smile

/Martin

alan-g
Offline
Last seen: 9 years 7 months ago
Joined: 2008-09-11 02:01
@Martin: Thank you for your

@Martin: Thank you for your answer. This solved my problem (I should read the help file better).

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 10 years 10 months ago
Developer
Joined: 2005-12-10 15:22
Hmm

I shall have a look at this and try to get it fixed for the next release.

EDIT: This does work, the manual is wrong! You need to do Toucan Script "JobName"

123martin321
Offline
Last seen: 15 years 7 months ago
Joined: 2008-09-11 04:58
Yup!

Yes, thanks a lot! That did the trick!

Speaking of the help file, would it be too much to ask for a few examples?
I can understand if the help file isn't prioritized, but it would greatly help beginners I think.

Thanks again,
Martin

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 10 years 10 months ago
Developer
Joined: 2005-12-10 15:22
Yes

I shall try and add them, but as you guess I don't really spend that much time on the help file, which it why that mistake was in it Smile

mth
Offline
Last seen: 15 years 9 months ago
Joined: 2008-09-25 06:15
Sorry, I've the same problem

Sorry, I've the same problem with a script job in the command-line, and no solution. (Sync jobs at the command line are working well). For example:
I've a sync job named "sydat1"
I've a script job named "sc1" with the command sync "sydat1", it works well.
but in the comand-line (...\app\toucan I've tried both:
toucan script "sc1" - and - toucan "sc1". Allways I've get the message "Sorry, the comman is not recognized"

What I'm doing wrong? Thanks for help!
Mikel

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 10 years 10 months ago
Developer
Joined: 2005-12-10 15:22
Hmm,

that is odd, I shall take another look into this, it should be working fine.

EDIT: You need a capital S at the start of Script!

123martin321
Offline
Last seen: 15 years 7 months ago
Joined: 2008-09-11 04:58
A change..?

Has commandline Syncjobs/scripts changed between ver. 2.0.1 and 2.0.2?
I can't get the scripts from command line to do anything after I made that update.
It works fine inside Toucan though.
I'm entering the following in the command prompt:
L:\PortableApps\Toucan\App\toucan>Toucan Script "SyncAll"

Thanks,
Martin

Log in or register to post comments