You are here

Internal Backup does not work after update

9 posts / 0 new
Last post
Stephan@work
Offline
Last seen: 13 years 8 months ago
Joined: 2009-03-10 03:47
Internal Backup does not work after update

Hello and sorry for my poor english!

I have installed the new version of PortableApps on my USB-stick over an older version. Everything looks wonderful - just the (internal) Backup doesn not work anymore. On two computers (one with XP and one with Vista) there is an error a few moments after the start of the Backup.

Possibly there is something corrupt after an update?

Update: I deleted the whole folder and made a new installation, but the problem is still there? Does anybode else have the same problems?

Sincerely
Stephan

Bruce Pascoe
Offline
Last seen: 10 years 11 months ago
Joined: 2006-01-15 16:14
...

What's the error? Your OS, etc.? We can't help you if we don't have any specific details on the problem.

abumap
Offline
Last seen: 13 years 8 months ago
Joined: 2009-03-10 07:50
Internal Backup does not work after update

I have the same problem.

When backup is beginning Win XP wants to send a error message to MS.

AppName: portableappsbackup.exe AppVer: 1.5.0.0 ModName: unknown
ModVer: 0.0.0.0 Offset: 2e747268

When I start portableappsbackup.exe from explorer it works.

Another problem: I've updated Pidgin and 7-Zip. The setup freezes when PortableApps Menu should be reloaded. (No error message. I have to kill the process.)

When I start the setup from explorer there are no problems.

May be the backup- and the setup-problem have the same reason?

Best regards,

Andreas

BTW: Used language for PA is German.

----[edit]----
I've installed the English version of PA. Now Internal Backup is working. Now I've tested the setup of 7-zip, but the installation freezes at the point 'Refreshing PortableApps.com Menu'.

It seems it is a different kind of 'error'.

Stephan@work
Offline
Last seen: 13 years 8 months ago
Joined: 2009-03-10 03:47
Error message

After I chose a backup and start the backup I get the message "PortableApps.com Backup hat ein Problem festgestellt und muss beendet werden" (The application has caused a problem and has to be stopped).

Problem signature:
AppName: portableappsbackup.exe AppVer: 1.5.0.0 ModName: unknown ModVer: 0.0.0.0 Offset: 2e747268

As I wrote Windows XP and Vista (both with the actual SP).

I also use the german version.
Also when I switch to the english version of PortableApps everything is fine!

John T. Haller
John T. Haller's picture
Online
Last seen: 9 min 32 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Confirmed

I'm looking into this and will try and get this into the 1.5.1 release within a day.

It only appears to affect the German translation. Dutch, English, Polish and Portuguese are fine.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Online
Last seen: 9 min 32 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Possible Fix

Ok, download this ZIP file:
https://portableapps.com/temp/PortableAppsBackupRestore1.5FIX.zip

And unzip it to X:\PortableApps\PortableApps.com replacing the existing Backup and Restore files. That should fix the problem and this will be included officially in 1.5.1.

Sometimes, the impossible can become possible, if you're awesome!

Stephan@work
Offline
Last seen: 13 years 8 months ago
Joined: 2009-03-10 03:47
Thank you!

Great work!
Everything is fine again.

Obviously it was the "revenge of the german Umlaute and Sonderzeichen" Wink

Sincerely
Stephan

John T. Haller
John T. Haller's picture
Online
Last seen: 9 min 32 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Nope

It was actually a string that was too long in the German translation for one of the plugins that handles the progress bar. I switched to a standard one for all translations so it won't be an issue.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Online
Last seen: 9 min 32 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fixed in 1.5.1 RC2

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments