You are here

"Check for new messages" turns itself off

3 posts / 0 new
Last post
KevinTMC
Offline
Last seen: 7 years 5 days ago
Joined: 2006-04-14 10:45
"Check for new messages" turns itself off

I've got an issue that's cropped up for me recently. I think it started round about the last time I upgraded PTB, but I'm not positive on that. I'm running version 1.5.0.2 (without Enigmail+GPG). I also have a dozen extensions loaded; if none of y'all are having the same problem I am, that would make it quite likely that one of them is the culprit.

I have six POP accounts set up, and for five of them I checked the "Check for new messages every __ minutes" box. The feature seems to work fine so long as I keep the same session going; but whenever I restart PTB, I find that the checkboxes have unchecked themselves.

(Oddly enough, the time values--which I had set differently for several of my accounts--were correctly remembered, albeit greyed out. Also, I haven't had any trouble with the "Check for new articles every __ minutes" option for News & Blogs; it stays checked from one session to the next.)

Anyone else experience this issue? Any ideas on what might be going wrong?

-- Kevin

P.S. Here are the extensions I have loaded in PTB, in case anyone would like to know:

Launchy 4.2.0
Zombie Keys 1.0
Unselect Message 1.3
SmtpSelect 0.1.1
Easy Get Mail Button 0.31
Display Quota 0.1.10
Change quote and reply format 0.4.9
NestedQuote Remover 0.7.10
ProfilePassword 0.7.3
Empty Trash 1.3.06
Tb Progress History Extension 0.1.6
Buttons! 0.5.2

John T. Haller
John T. Haller's picture
Online
Last seen: 21 min 26 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Settings not saving

Are there any other settings not being saved? I can't think of anything that would be affecting that setting. Granted, I don't use POP. And I don't use any extensions with Thunderbird, so I don't know if any of those might be contributing to the issue. Perhaps try disabling all your extensions... restart... change your settings... close TB completely and be sure it fully closes (not just the window... check task manager)... then fire it up again and see if it sticks. If it does... it's an extension issue... and you can enable them one at a time to figure it out. If not, there's something else afoot in your profile that will be harder to figure out.

Sometimes, the impossible can become possible, if you're awesome!

KevinTMC
Offline
Last seen: 7 years 5 days ago
Joined: 2006-04-14 10:45
Culprit found and eliminated

It would appear that one of my extensions, TB Progress History, was the culprit. It turns out it is supposed to uncheck the boxes I mentioned (D'oh!); but it is also supposed to still auto-check for new messages at the durations specified, and it wasn't doing so. (The extension works by totally taking over the retrieve-mail process, it seems.)

Oh well. I'll miss being able to see a log of progress reports; but it looks like this extension was trying to do stuff that was just too funky.

Thanks, as always, for the helpful reply.

Topic locked