You are here

BUG: Hotmail login link from WLM don't login to my hotmail automatically.

13 posts / 0 new
Last post
spam2009
Offline
Last seen: 13 years 9 months ago
Joined: 2009-05-07 15:54
BUG: Hotmail login link from WLM don't login to my hotmail automatically.

There is a service in MSN protocol that can login you into e-mail acount with
you pass if you are logged in MSN/WLM AND Miranda MSN Protocol. FF Portable is the
default browser so when i click on "Hotmail" service in Miranda MSN, FF Portable try to log in with long url in adders bar but it constantly asking me for password even if I'm logged into MSN. Cheeking "Remember my username and password" don't
work on this page but it remember my account name. This is NOT Miranda bug. I do several test and with normal installation of Firefox everything works fine. If i set my FF Portable as default browser that bugs occurs. I think that FF Portable launcher can't handle long MSN login links.

My patch: D:\Programs\FirefoxPortable

Reproducible: Always

Steps to Reproduce:
1.Set FF Portable as default browser.
2.Login into you MSN account in Miranda.
3.Click "Show my Hotmail"

Actual Results:
FF load a page where you must enter again you pass.

[image removed, links to provider with pornographic ads[

Expected Results:
FF should load Hotmail page like, without asking about pass if I'm logged into
MSN and after clicking "Hotmail" in WLM/Miranda.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 44 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Unsupported

If you're setting Firefox within Firefox Portable as the default, then it's not using your portable profile. Setting Firefox Portable as the default browser on a PC is neither supported nor recommended.

Sometimes, the impossible can become possible, if you're awesome!

spam2009
Offline
Last seen: 13 years 9 months ago
Joined: 2009-05-07 15:54
I don't have FF default, and

I don't have FF default, and i only use FF Portable. Also i use "DefaultBrowser" program to get everyone link i click be open by FF Portable. There is nothing wrong with this and its main reason why i use FF Portable: after reinstall of Windows i have FF as it was before.

Now as i mention: FirefoxPortable.exe is the reason to not transform proper link with login information. Can you give to this some attention ?

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 44 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
It Doesn't

Whatever you pass on the command line to FirefoxPortable.exe is passed directly to firefox.exe as the last part of its command line. No changes are made to it. The only thing I can think of is if it is passing unencoded spaces (which it should not be) and may confuse firefox.exe when additional command line paramters are used (namely -profile $PROFILEDIRECTORY).

Sometimes, the impossible can become possible, if you're awesome!

spam2009
Offline
Last seen: 13 years 9 months ago
Joined: 2009-05-07 15:54
My Profile is loaded without

My Profile is loaded without problems. See for you self:

Download Miranda with MSN test account from here: http://www.speedyshare.com/186542797.html , set FF Portable as default browser via "DefaultBrowser.exe", run Miranda, go online at MSN and click "Show my Hotmail".

I hope that it will help you solve this.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 44 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
URL?

Can you post the URL that is causing the issue? The possible bug I mentioned would be an issue within Firefox when it is passed additional command line parameters. Your profile would work fine, but a URL with unescaped spaces would fail. Without the URL I can't really assist. You can XXX out your details within the URL.

Sometimes, the impossible can become possible, if you're awesome!

spam2009
Offline
Last seen: 13 years 9 months ago
Joined: 2009-05-07 15:54
Links

It is oblivious not full link in address bar. I'm sorry that i didn't spot this faster:

FF Portable link:

[hidden by mod JTH]

IE Link:

[hidden by mod JTH - I got it, I'll look at it]

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 44 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
URL Too Long

I figured it out and it's that the URL is too long for the launcher to handle. It can't handle strings longer than 1024 characters. Technically, the SGML spec says that an attribute value (like in HTML when doing A and HREF=) can't be longer than 1024 so the Hotmail link is out of spec. It looks like most browsers handle it properly (Firefox can handle 2000 chars, Opera and IE can handle about 8000) though pretty much across the board everyone recommends a URL longer than 255 characters be shortened as it can be broken by some other things.

NSIS, the language we write our launchers in, can only handle strings 1024 characters. We're looking into switching to NSIS Unicode soon which will allow us to use longer strings.

Sometimes, the impossible can become possible, if you're awesome!

spam2009
Offline
Last seen: 13 years 9 months ago
Joined: 2009-05-07 15:54
.

Thank you for this and good luck in fixing that.

reepicheep
Offline
Last seen: 11 years 7 months ago
Joined: 2008-04-29 11:32
Technically not so.

Technically, the SGML spec says that an attribute value (like in HTML when doing A and HREF=) can't be longer than 1024

Strictly speaking the ISO 8879 SGML does not say that. The standard allows an arbitrary number of characters in an attribute value. A specific limit, such as that 1,024, is established using a declaration of the standard as a "concrete syntax". It is possible that HTML is presumed to use a specific "contrete syntax" with a limit on attribute values of 1,024 characters.

(I was a member of the ISO committee responsible for development/maintenance of SGML.)

qwertymodo
qwertymodo's picture
Offline
Last seen: 11 years 7 months ago
Joined: 2008-03-17 19:08
Doesn't NSIS have a special

Doesn't NSIS have a special "long string" build? Or is that just the Unicode build?

http://nsis.sourceforge.net/Special_Builds

I know you have your Windows 7 patch, but isn't there any way to apply your patch to that build?

Quamquam omniam nescio, nec nihil scio.

spam2009
Offline
Last seen: 13 years 9 months ago
Joined: 2009-05-07 15:54
Any news on the upcoming fixes ?

Or we will need to wait some more time ?

Janek22
Offline
Last seen: 13 years 9 months ago
Joined: 2010-05-09 11:39
I test it with newest Google

I test it with newest Google Chrome Portable and it has same to short url Sad
I see that you move to unicode so can this be finally fixed ?

Log in or register to post comments