You are here

Pending loss of all PTB mails. Need help.

11 posts / 0 new
Last post
mafi0002
Offline
Last seen: 1 year 1 month ago
Joined: 2006-06-10 07:03
Pending loss of all PTB mails. Need help.

Dear Forum,

I started my use PTB with version 1.0.5 beta.

Migrated to PTB 1.0.7 beta by extracting the new version to its own folder named "Portable Thunderbird". Afterwards I copied the complete "\profile" folder into the new location.
As far as I can remember, everything worked just fine that way. I had my two accounts properly "imported", as well as "subfolders", into which I manually used to move received mails, depending on who sent me that specific mail.

Yesterday I had to add a "line" to that prefs.js file, of which I found 6, named prefs.js and prefs-1.js to prefs-5.js, that I found in a forum somewhere on the internet, that dealt with a timeout problem, since I had problems receiving large mails. This timeout value was changed to 600 or something like that, but I don't think, that this is important to what happens now.

Yesterday I arrived at home, after having used it throughout the day on another machine, plugged my external harddrive in and then this happened:

PTB 1.0.7 beta asked whether I want to create a new e-Mail account, RSS-Feeds and so on, as if i hadn't used it before. I immediatly shut down the program via the taskmanager to prevent loss of data and copied the "\profile" folder to a save locatrion on my desktop pc. It still had the size of around 440MB including folders named after my accounts and those "subfolders" named after senders names, like explained above.

I have tried the above described "migration"/ importing method by re-extracting to a brand new folder and inserting the "\profile" folder into the "\data" folder.

Tried the same on a second run, by first starting this "blank" version of PTB, created my two accounts and did exit the program. I did not use the checkmail funtion. Then I moved the "\profile" folder to its dedicated loaction under "\Data" and started PTB again, in hope that it would work this time....

BUT NO!

Tried all the above also with version 1.5.0.2 en/us. The same happened.

Now what can I do?

Thanks to any kind of help, that leads to the access to my mails.

Greets

John T. Haller
John T. Haller's picture
Online
Last seen: 2 min 48 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Partially Corrupt Profile

Sounds like you have a partially corrupt profile. Most likely, your prefs.js and a few other bits are corrupt. Your mail is, most likely, intact.

Try starting with a fresh copy of PTB 1.5.0.2. Copy your mail folder in (PortableThunderbird\profile\mail in the old, PortableThunderbird\Data\profile\mail in the new). Then fire up PTB and make sure it shows up as expected. Then close and try copying in your address book (abook.mab) from one to the other and fire it up again to make sure that piece works. Then close and copy in your passwords (cert8.db, key3.db, secmod.db) from old to new and fire up the new one again and see if your passwords are there (Tools - Options - Privacy - Passwords - View Saved Passwords). Lastly, recreate your mail accounts in the new copy through the interface one-by-one (optional: in the same order you created them in the old copy). You can pop open your prefs.js in the old one in a text editor (notepad is fine) and see if there is any info about them still in your prefs.js to help you along this process.

Sometimes, the impossible can become possible, if you're awesome!

mafi0002
Offline
Last seen: 1 year 1 month ago
Joined: 2006-06-10 07:03
Pending loss of data

Dear John T. Haller,

first of all, thanks a lot for replying so fast!

I tried the following, following your hints:

1. I have extracted the PTB 1.5.0.2 to a directory called "Portable Thunderbird"
2. I did not execute the programm afterwards.
3. I copied the "old" "Mail" folder, which I found under the "old" "\profile" folder to its new destination, that is now located at "\Portable Thunderbird\PortableThunderbird\Data\profile\Mail", meaning, that by copying that "old" folder to this place I let Windows replace everything.
4. Launched PTB, but I still get that window, where I am asked to decide whether I'd like to create a new account, RSS...and so on.

Unfortunatly this didn't seem to work.

Is there a work-around using another program to import this old "\profile" folder and then having it re-imported to PTB?

If it wasn't so sad at all, I'd laugh about losing 440MB of essential e-mail
; - ) .

Looking forward to hearing from you.

Greets
Mark Fischer

p. s.: Was it sufficient to solely backup that "\profile" folder - including its subfolders and files - from the former version?

Bruce Pascoe
Offline
Last seen: 6 years 8 months ago
Joined: 2006-01-15 16:14
Sucks, doesn't it?

For as much as I love the Thunderbird UI, it has to be one of the buggiest email clients there is. It's why I chose to keep my Gmail messages on the server when I was using it with my Gmail account.

I actually ran into a problem a while back where Thunderbird would show duplicate versions of existing emails in my folders. Unfortunately, if I deleted the duplicates, the originals, while they didn't disappear, became completely blank. No subject, no contents. Very bizarre.

-
fatcerberus@yahoo.com  [aim: fatcerberus]
I have no witty remarks or quotes to share at the moment.

John T. Haller
John T. Haller's picture
Online
Last seen: 2 min 48 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
One piece at a time

Of course, you'll get prompted after copying just your mail folder.... you haven't created any new accounts yet. Cancel the dialogue and ensure that your mail copied. Then proceed as I outlined, canceling the prompt on each step. You WILL have to manually recreate the accounts as you're corrupted, but you can save your address book, passwords and mail using the process I laid out.

Sometimes, the impossible can become possible, if you're awesome!

mafi0002
Offline
Last seen: 1 year 1 month ago
Joined: 2006-06-10 07:03
Dear John T. Haller, thanks

Dear John T. Haller,

thanks again for your time. Since english is not my native language and I am not that deep into this application, please take my excuse for the fact that I may not be that fast at understanding the how's and why's or may have misunderstood something.

After which step will I see, that the mails reappear (in the best case including their subfolders), if I have "fulfilled" the above mentioned necessary steps by you? I assume, after the very last (creation of accounts), is that correct?

1.Can it be regarded as normal, that I have more than one of those *.js files?

(I moved the files named by you to the profile folder (tried it with just the "first" prefs.js file and in a second try with all of them. Also moved the other mentioned files to \profile. Will try this once again in a file-by-file "copy-process")

2. Do I have to re-import the address book, since I didn't have many contacts stored in it.

3. Do I have to re-"integrate" my passwords? I do remember them.

4. I hope that I understood you right, that I will have to re-create the accounts in the correct order, as done before and that I can find out that order by looking at those *.js files. Done so and found those records, asssuming to get the right order by reading from top to bottom.

5. Since I have created several "sub-folders" in my inbox, do I also have to recreate them, to get things running properly?

Thanks again!! Is there a way to make a donation, for your help? I am really willing to, since those 440MB haven't been backed up throughout the last 2 months. Shame on me....

Regards
Mark Fischer

John T. Haller
John T. Haller's picture
Online
Last seen: 2 min 48 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Please re-follow the directions

Please re-follow the directions and all steps from my original post taking in to account that you should ignore the "Please setup an account" at each step. I've made the directions about as clear as I can make them. Follow each step as laid out. In order.

Sometimes, the impossible can become possible, if you're awesome!

Ryan McCue
Ryan McCue's picture
Offline
Last seen: 8 years 11 months ago
Joined: 2006-01-06 21:27
Hmm

Well, he does have a Paypal donation button somewhere...
----
R McCue
PortaBlog Home and My Website
PortaBlog is now officially out of beta!

"If you're not part of the solution, you're part of the precipitate."

mafi0002
Offline
Last seen: 1 year 1 month ago
Joined: 2006-06-10 07:03
Throughout the week-end I

Throughout the week-end I will have the time again, to do it the way you layed out, ignoring, that some actions don't show a direct result. Wink wish me luck....:)

Bronco200
Offline
Last seen: 12 years 3 months ago
Joined: 2006-06-21 03:34
Funny i have the same problem

Hi,

i have also the same Problem, try this:

  1. Create new account(s) like your old accounts.
  2. Close the appliacation.
  3. Copy all the files from your old mail folders (data/mail/oldaccountname) into the new account folders.
  4. Restart PTB and you will get your mail back.

So for passwords etc following the instructions from John above.

cheers
Kirsten

mafi0002
Offline
Last seen: 1 year 1 month ago
Joined: 2006-06-10 07:03
Problem solved

Hello there,

first of all I'd like to say thanks a lot for all your help!

I got it back working again with the latest version of PTB.

The reason why all my trials could not result in something working, was, that one of those folders in \Mail was named like pop3.xyz.net. Since that server-name has been changed to something like mail.xyz.net, my newly created account in PTB resulted in a folder named after that mail.yxz.net server-name, which was correct but did not match the former server-name.

So all I had to do, was to create the new account(s) in PTB with the old server-names and settings. Then exit the program and copy only the \Mail folder (including subdirs) into the right location. Restart PTB, change the individual account server-settings...and it worked.

So in this specific scenario, the hint to take a second look at the prefs*.js files, helped "the most".

Regards
Mark Fischer

Regular Backup will include PTB in the future ; - )

Log in or register to post comments