You are here

In 3.2 Math does not show the plus sign correctly

8 posts / 0 new
Last post
rdoerrer
Offline
Last seen: 11 years 6 months ago
Joined: 2010-03-02 08:56
In 3.2 Math does not show the plus sign correctly

I installed OpenOffice Suite 3.2 and found that the plus sign as in "a + b" is not shown correctly, but replaced by a square. This was not the case for Version 3.0. I assume it is a bug in the fonts.

BTW. The are also replaced by squares whereas the is correctly shown as the NOT-EQUAL sign.

Any help?

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 5 years 10 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Sorry, but I can not reproduce this issue

... no problems with OpenOffice.org Portable 3.2. All signs including + are ok.

Did You install a fresh copy or update an older version?

Please check if the fonts folder is present under App/openoffice/share

Paid for Software more or less?
What You need is OSS!

rdoerrer
Offline
Last seen: 11 years 6 months ago
Joined: 2010-03-02 08:56
I still have the problem

I tried both. First I did an update. This did not work. Then I installed it in another location (no Update!) -> same effect. Finally I installed in on a brand new virtual machine (VMware Server 1.0.6 + Windows XP SP3) and again the same problems.

Strange ...

p.s.: Yes, the fonts folder is present and its contents are identical to those of version 3.0.0. I even copied the 3.0.0 fonts to the 3.2.0 fonts folder just to be sure ...

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 5 years 10 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Fix for the font problem

the font management of OpenOffice.org seems to be changed again.

Please move the folder fonts from openoffice/share to openoffice/Basis/share.

This should fix the issues.

Paid for Software more or less?
What You need is OSS!

bh2ooo
Offline
Last seen: 10 years 7 months ago
Joined: 2006-07-08 10:22
Plus sign is/was fine, but get boxes in Standard and Portable

If I use a sample formula that OO offers up, like "a + b", it creates a formula of two empty/useless boxes with a good plus sign in between.

I get the same problem in both 3.2 portable and in 3.2 standard install.

Just so we're on the same page, I access the formula editor via the top menu Insert..Object.. Formula.

That 1/4 height window opens at the bottom of the page (formula edit window maybe?).

Clicking any of the sample formulas (let's use "a + b" to be consistent) and I note that the "a + b" is now pasted in the edit window as "> + >". If I click in my document, the edit window closes and it inserts a formula with two small useless boxes with a good plus sign between them.

I'm thinking "undefined variables"

If I click on that formula, the edit window opens, and if I delete those > and use something fixed verses variable, the resulting formula in my document works fine (no useless boxes).

typing "a + b" (without the quotes) works.

"(a + x -Returns + (T/4) over G)" works.

(I don't know how to write this in plain text, so) "less than sign x greater than sign + less than Y greater than sign" is a mess with inverted question marks a good + sign.

I think the > is to be looked at over at OO.org. I don't get just how it should work, but something there seems borked. Maybe they use to code so it would insert the sample. I don't use this often and when I do I think I just eliminated the things and typed into the editor what I needed (I'd seldom need "a + b", but some words like div and over were of help from other samples).

MARK: the OP didn't mention just what he did to get a bad "+" sign. Maybe that is some other arrangement of the things verses the +. Anyway, I don't notice yet any problem with the "+". OTH:

Anyway, moving the font folder didn't change anything in my portable, but I've got dejavu as "installed fonts" on this machine, so maybe I don't know what a mess I've fixed by moving the folder.

Bh2ooo

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 5 years 10 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
If the problem is in the standard version too ...

... please report it at OpenOffice.org directly.
But I think it is not a problem its the way the new formular assistent works.

If You'll use the assistent to insert a formular You'll insert not the shown formular itself but an example for this kind of formular (the kind of relation between two or more variables). This is real useful in complex formulars and works the sam way as the assistent f(x) in calc. The 'useless' boxes are place holders in order to show You have to add real content here and (!) they are clickable buttons.

Klick (center) on one box and the place holder item (like >) is marked for editing, type the character You want and it will be shown now in the formular ;-).

If You know what You want to add (like a+b or a over b) type it directly and it will be added to the formular (no need for the assistent).

Paid for Software more or less?
What You need is OSS!

rdoerrer
Offline
Last seen: 11 years 6 months ago
Joined: 2010-03-02 08:56
That's it!

That fixed my issue.

Thank you

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 5 years 10 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
You're welcome ...

... and thank You for reporting this issue and don't give up asking for a solution Wink

Paid for Software more or less?
What You need is OSS!

Log in or register to post comments