You are here

Maxima Portable 5.41.0 Development Test 1

77 posts / 0 new
Last post
scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Maxima Portable 5.41.0 Development Test 1

Application: Maxima
Category: Education
Description:

Maxima is a system for the manipulation of symbolic and numerical expressions, including differentiation, integration, Taylor series, Laplace transforms, ordinary differential equations, systems of linear equations, polynomials, and sets, lists, vectors, matrices, and tensors. Maxima yields high precision numeric results by using exact fractions, arbitrary precision integers, and variable precision floating point numbers. Maxima can plot functions and data in two and three dimensions.

Download Maxima Portable 5.41.0 Development Test 1 [101MB download / 540MB installed]
(MD5: 341221383679fa680f5575cc7ade7e74)

Release Notes:
5.41.0 Development Test 1 (2017-11-28)

  • Updated to Maxima 5.41.0

5.40.0 Development Test 1 (2017-06-11)

  • Updated to Maxima 5.40.0

5.39.0 Development Test 1 (2017-03-06)

  • Updated to Maxima 5.39.0

5.38.1 Development Test 1 (2016-09-18)

  • Updated to Maxima 5.38.1

5.37.3 Development Test 1 (2016-02-05)

  • Updated to Maxima 5.37.3

5.36.1 Development Test 1 (2015-05-27)

  • Updated to Maxima 5.36.1

5.35.1 Development Test 1 (2015-01-12)

  • Updated to Maxima 5.35.1

5.31.2 Development Test 1 (2014-03-17)

  • Updated to Maxima 5.31.2
  • Removed Xmaxima GUI, making wxMaxima the default (and only)

5.24.0 Development Test 1 (2011-04-20)

  • Updated to Maxima 5.24.0

5.23.2 Development Test 1 (2011-02-27)

  • Updated to Maxima 5.23.2

5.21.1 Development Test 2 (2010-04-28)

  • Launcher now displays an error when trying to run from a path with spaces

5.21.1 Development Test 1 (2010-04-27)

  • Updated to Maxima 5.21.1
  • Fixed the maxima.bat process looking in the wrong directory for maxima.exe
  • Fixed crash with maxima.exe on startup
  • Fixed crash with PA.c Launcher when trying to load wxMaxima and XMaxima at the same time

5.21.0 Development Test 1 (2010-04-24): Initial release

Known issues:

  • Language switching has not yet been implemented
  • wxMaxima will not run from a path that contains spaces

Notes:

  • Taken over from previous packages by wmacevoy and aamiel here
aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Not working here, 2 errors (+1 now)

The interface starts and works here but maxima does not start. I found 2 errors:

1)Uncompress:
\MaximaPortable\App\Maxima\lib\maxima\5.21.0\binary-gcl\maxima.exe
For some reason it does not like being compress and you save nearly no space compressing it.

2)In:
PortableApps\MaximaPortable\App\Maxima\bin\maxima.bat

Change the line:
set maxima_prefix=C:\PROGRA~2\Maxima
to
set maxima_prefix=%~dp0%..

It should then be working

Apart from that, great work

EDIT: Also found this in you xmaxima launcher
settings\.xmaximarc=%USERPROFILE%
I believe should be
settings\.xmaximarc=%DOCUMENTS%

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
1. Hmm, that's odd. It works

1. Hmm, that's odd. It works for me, I'll look into it after class.

2. Wouldn't that never be set from the .bat file anyway, since it is set in the launcher? Doesn't it first check if it's set before setting it? (Though, I'll take a look at this too.)

3. What version of Windows are you using? For me, the .xmaximarc file is put into "C:\Users\Kenny Williams" which is %USERPROFILE%. Where is it placed for you?

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Does not work here

Up to now I only tried it on my work PC, XP SP2 with "My Documents" mapped on a network drive H:

1.] Seems to crash on startup if 2.] is implemented
2.] I think it is set by the launcher then overwritten by the BAT file. If not corrected, here maxima does not start. I guess it can't find it.
3.] for me the file ends up in "My Documents"

Will try at home later today

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
1.] Confirmed. 2.] Confirmed,

1.] Confirmed.

2.] Confirmed, only some of the other paths are checked for in the .bat file. MAXIMA_PREFIX is set regardless.

3.] Cannot reproduce. It's still %USERPROFILE% for me, and Gringoloco tested it on XP SP3 and it's put in %USERPROFILE% for him as well.

Mark Sikkema
Offline
Last seen: 6 years 10 months ago
Developer
Joined: 2009-07-20 14:55
Hi aamiel,

Can you confirm that the registry plugin is doing it's job or not ?

Formerly Gringoloco
Windows XP Pro sp3 x32

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.21.1

Updated and fixed some bugs.

Can someone do a regshot for wxMaxima and XMaxima? I haven't been able to because Regshot keeps crashing on me for some reason.

dboki89
Offline
Last seen: 3 years 5 months ago
Joined: 2009-11-30 20:44
.

A quicky... Bad news... Other than the usual Windows crap, these were left on XP SP2 system:

[HKEY_CURRENT_USER\Software\wxMaxima]
"ShowTips"="dword:01000000"

[HKEY_CURRENT_USER\Software\wxMaxima]
"tipNum"="dword:01000000"

[HKEY_CURRENT_USER\Software\wxMaxima]
"pos-x"="dword:28000000"

[HKEY_CURRENT_USER\Software\wxMaxima]
"pos-y"="dword:28000000"

[HKEY_CURRENT_USER\Software\wxMaxima]
"pos-w"="dword:B6030000"

[HKEY_CURRENT_USER\Software\wxMaxima]
"pos-h"="dword:8A020000"

As for files, it's clean.

My posts are old and likely no longer relevant.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
There has to be something

There has to be something wrong with XP SP2, as there have been a lot of problems lately with it. I thought this was fixed though.

These should not be left behind, as I have this in the launcher:

[Activate]
Registry=true

[RegistryKeys]
wxMaxima=HKEY_CURRENT_USER\Software\wxMaxima

EDIT: I just looked in the PA.c Launcher thread, and it was aamiel who originally reported this (with Maxima), but it was supposedly fixed. I'll have to talk to Chris about this.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated.

Launcher now shows an error when trying to launch from a path with spaces, since the maxima.exe process terminates.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Question for Maxima users.

Should I include a "Command Line Maxima" launcher, or leave it as is?

kilele
Offline
Last seen: 1 year 3 months ago
Joined: 2007-03-05 11:12
I believe that this software

I believe that this software is worth a command line launcher Wink

gombosg
Offline
Last seen: 7 years 8 months ago
Joined: 2010-04-25 05:39
Thanx!

It works! First version didn't work though.
Keep up the good work! Smile

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Plans for update

Since this release, Maxima has gone thourough a few iterations. They do not change the way the launcher works.

Any plan to update?

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Sorry.

I haven't updated because I wanted to fix a few things first (add language switching, etc.), but since I've been so busy I just might have to update the base app only.

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
No problem

I understand. It is not a problem. Thanks for your work

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
This weekend.

Sorry for not doing this sooner, but I've been busy with homework and studying.

I hope to have an update this weekend, but no promises.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.23.2

Updated to Maxima 5.23.2

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Thanks for that

I will start using it next week.

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Little bug...

In Maxima.bat, you forgot to change the line to:

set maxima_prefix=%~dp0%.. as detailed above.

Arnaud

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Launcher.

I take care of that environment variable within the launcher.ini.

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Not working here

For some reason, it is not working here, wxMaxima does start fine, but not Maxima itself.
By changing maxima.bat by hand as indicated, everything works fine

I am using windows7 64 bit

Arnaud

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
How very odd.

Works perfectly for me (just tested again). I'll take a look at it later. Maybe I'll add code into the maxima.bat file to check if it's already set, otherwise use set maxima_prefix=%~dp0%.. (like it does with the image and temp directories).

I wanted to avoid having to customize any code in the App\Maxima directory in case I forgot to save it through updates, but it looks like I might have to.

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
I will check on other PCs

I am currently trying to fix my XP pc which has a blown power supply. I will try on there (or at work).

I understand what you are trying to do but it is not working here... for now.

Arnaud

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Question.

Could you do a clean install, run XMaxima, and copy+paste the folder url from the window?

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
The URL is

file:/G:/PORTAB~1/MAXIMA~1/APP/MAXIMA/share/maxima/523~1.2/xmaxima/INTRO~1.HTM

And then Maxima does not start.

I think that maybe your launcher sets the environment variable to the right value but that it is then overwritten by the maxima.bat script.

Let me know if I can be of any help.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
odd.

I believe XMaxima uses maxima_prefix to find that directory (you can test it, I'm not 100%), which is the correct path. Which makes it even more odd that it doesn't work.

Pchief1
Offline
Last seen: 3 years 8 months ago
Joined: 2013-03-28 01:38
still has a small issue

Simply

set maxima_prefix=%~dp0..

is still with a subtle problem: it can cause .. to be inserted into some file searching list that can't be correctly interpreted by maxima.

What we need here is retrieve the literal value of the batch's parent folder. IMO the following is better:

pushd %~dp0..
set maxima_prefix=%cd%
popd

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Okay.

I'll look into this the next time I have time to update it. Thank you.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Sigh.

Maxima is not my friend at all. I've realized that it worked for me before because I had installed a local copy, so now I understand why it doesn't work. However, there appears to be a bug in Windows 7 such that %dp0.. won't work if there's a space in the path. I commented out that line in maxima.bat and left it to the launcher, but it still doesn't work.

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Windows 7 This may be of interest

Have a look there:
Windows 7 dp0 bug.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Yeah.

That's exactly the bug to which I was referring.

3D1T0R
3D1T0R's picture
Offline
Last seen: 2 months 2 weeks ago
Developer
Joined: 2006-12-29 23:48
That's %~dp0 right? And did you try "quoting" it?

In this post I assume you mean %~dp0, not %dp0, if you used %dp0 you could try %~dp0 ;).
The Batch interpreter simply replaces %~dp0 with the path, exactly as it is, thus if the Batch file that's running is X:\Path To\Folder\file.bat and the line of the Batch file is command %~dp0 then the line read to the Command Prompt will be command X:\Path To\Folder\ and command will think you are giving it two parameters 1st X:\Path and 2nd To\Folder, and this will confuse alot of programs, so you should quote the %~dp0 like so command "%~dp0" and since DOS (and Windows' "Command Prompt") understands that anything between quotes is all one thing, command should now realize that it's getting one parameter of "X:\Path To\Folder\".

Note: I have noticed that some commands don't like the \ on the end of %~dp0 paths, so if you can figure out how to make it ignore the last letter (preferably without copying it to another environment variable and then using it) I'd appreciate that.

~3D1T0R

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Yes, sorry.

I used %~dp0.. (quoting also didn't work).

As for your note, %cd% should do what %~dp0 does without the last \ (though I haven't tried it and I'm done for today).

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 3 years 3 weeks ago
Joined: 2007-04-15 21:08
%cd% may be incorrect

%cd% refers to the working directory, whereas %0 refers to the batch file under execution.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Ah.

Yeah, that too.

EDIT: Well, now it gets to "Maxima started, waiting for connection," but never goes any further than that.

3D1T0R
3D1T0R's picture
Offline
Last seen: 2 months 2 weeks ago
Developer
Joined: 2006-12-29 23:48
Exactly; Sorry

That's exactly why I don't want to keep using %CD%, currently I've got a couple of Batch files which I have shortcuts to, just so that I can set the "Start In:" option for the shortcut and have %CD% point to the right location. ugh :(.

@ScriptDaemon: I'm sorry I apparently couldn't be of much help to you on this one.

~3D1T0R

John T. Haller
John T. Haller's picture
Offline
Last seen: 4 hours 15 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Ditch the Batch?

Any way you can just ditch the batch and do it all in PAL, possibly with custom code? I know a couple other apps use batch files locally for launching but we just use code instead.

Sometimes, the impossible can become possible, if you're awesome!

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
I wish I could.

But it's not PAL that launches the batch script, it's wxMaxima and XMaxima.

PAL -> wxMaxima.exe/xmaxima.exe -> maxima.bat -> maxima.exe

John T. Haller
John T. Haller's picture
Offline
Last seen: 4 hours 15 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
So have PAL handle it

If that's the case, can you have PAL launch maxima.exe directly? And if not, how about a custom NSIS script to handle the bits in the .bat that don't work right.

Sometimes, the impossible can become possible, if you're awesome!

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
.

If I launch maxima.exe directly, then it won't launch wxMaxima or XMaxima. Is there a way to tell wxMaxima.exe to stop calling maxima.bat and let PAL handle it instead? (I wouldn't think so though, because I think maxima.exe has to be a child process of wxMaxima.exe.)

The only part that doesn't work right is setting the maxima_prefix env var, which I try to handle with PAL by commenting out that line and setting it in the env var section of the launcher.ini file.

John T. Haller
John T. Haller's picture
Offline
Last seen: 4 hours 15 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Ah Ok

That should work then since it's a child of a chile process.

Sometimes, the impossible can become possible, if you're awesome!

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Yet it doesn't, which is why

Yet it doesn't, which is why I'm having difficulties. I'll take another look at it and if I still can't figure it out I'll .zip it up and see if anyone else has any ideas.

EDIT: When launching Xmaxima, a console and a browser is loaded. The browser shows things like help files I guess, but the interesting thing is that it points to the correct file, yet maxima.exe still doesn't want to connect.

John T. Haller
John T. Haller's picture
Offline
Last seen: 4 hours 15 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Update The bat

You could update the .bat using the FileWriteN in config mode and give it a full path each time. That would do it.

Sometimes, the impossible can become possible, if you're awesome!

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Nope.

Still not working. Tried in paths with and without spaces, and checked the .bat file and it is indeed edited correctly.

EDIT: Here is a link to the current version. http://dl.dropbox.com/u/1442139/MaximaPortable.zip Maybe having others take a look at it will help pinpoint the problem.

EDIT 2: Oops, when I copied it from one directory to another, not everything copied (the cmd.exe process was still hanging). Should be okay now.

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
A small edit

Comparing your version with the previous working version, I found that in "maxima.bat" on the first line removing "rem" makes it work

so

rem @echo off

becomes

@echo off

Don't ask me why though...

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Oops.

I commented that out when I was debugging. And now it does work (albeit only from a directory with no spaces, but that's Maxima's problem).

I'll package this up later today. There are some other things I want to try getting to work in this.

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Shouldn't you quote the whole line

'set maxima_prefix=%~dp0%..'
and not
set maxima_prefix='%~dp0%..'

Sorry, I can't try it at the moment...

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
I'll try it when I get out of

I'll try it when I get out of class. I still don't think that's the issue though. When commenting out that line entirely and leaving it to PAL, the maxima_prefix variable is what it should be, and it still hangs for some reason.

3D1T0R
3D1T0R's picture
Offline
Last seen: 2 months 2 weeks ago
Developer
Joined: 2006-12-29 23:48
%PAL:AppDir%

I just realized that you're using PAL, so you could probably use %PAL:AppDir%\Maxima.
So I'll suggest that you try that:

set maxima_prefix=%PAL:AppDir%\Maxima

~3D1T0R

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
I know.

This is easier to update, however. If I do it that way, I have to manually edit the .bat file every update. The way it works now, it's taken care of.

3D1T0R
3D1T0R's picture
Offline
Last seen: 2 months 2 weeks ago
Developer
Joined: 2006-12-29 23:48
OK, Fine by me.

If you've got it working, and you're happy with it, then I'll stop thinking about it. Wink

~3D1T0R

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.24.0

This release should actually work now (=P).

Maxima doesn't support paths with spaces after all, and I figured out what mistake I made last time to make me think that it did.

It took so long for a release because I tried to get language switching to work. Understanding the VB script it uses (for whatever reason) a little better, it appears to look at the LANG environment variable, however wxMaxima appears to always override it so I can never change it even with PAL. I'll have to dig deeper.

aamiel
aamiel's picture
Offline
Last seen: 4 years 4 months ago
Joined: 2008-11-03 04:53
Thanks

Thanks for all the hard work. It seems to be working fine here, but I don't use language switching and I have no spaces in my path(like, I guess, most of the PAf platform installations).

computerfreaker
computerfreaker's picture
Offline
Last seen: 6 years 10 months ago
Developer
Joined: 2009-08-11 11:24
Rotating a function graph

I'm working on a project that requires me to graph a function (i.e. y = x^2), then rotate that graph around a specified line (i.e x = 4). Something like this is exactly what I need my final result to be.

Keeping in mind that I'm on Windows, so gnuplot_pipes isn't available, do you know if I can do this with Maxima? If Maxima can't, do you know of a tool that can do this? I know Maple and Mathematica can, since I have the Mathematica source code for the movie I linked to above, but I can't figure out a way to have Maxima or another portable, OSS app do the same thing.

"The question I would like to know, is the Ultimate Question of Life, the Universe and Everything. All we know about it is that the Answer is Forty-two, which is a little aggravating."

tal
Offline
Last seen: 3 months 2 weeks ago
Developer
Joined: 2009-08-07 07:34
wow :)

I see you did a great job here.
how you add wxMaxima? you compile it by yourself?

Thanks for your time.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated.

Sorry for the (very) late update.

With this release, I have removed the Xmaxima GUI entirely as we are moving away from multi-app packages. However, with this leaves one thing to question: Should this remain Maxima Portable, or instead should I change the app ID entirely to wxMaxima Portable? Thoughts?

tal
Offline
Last seen: 3 months 2 weeks ago
Developer
Joined: 2009-08-07 07:34
Thanks for the update!

if you asking me, i think you need to change it to wxMaxima.
the purpose of the wxMaxima, it to take maxima, and add her another GUI.
and i assume you taking the project from here:
http://andrejv.github.io/wxmaxima/

so in short answer it will be: wxMaxima

tal.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
.

This was taken from Maxima's sourceforge site. wxMaxima is bundled with Maxima.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.35.1

Updated to Maxima 5.35.1

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.36.1

Updated to Maxima 5.36.1

Qwillou
Qwillou's picture
Offline
Last seen: 3 years 1 day ago
Joined: 2015-06-29 09:27
Plots crashes

Am I the only one to have maxima to crash when launching a plot?. (gnuplot issue)
I'm running it under windows 7 enterprise

Thks for any support
BR

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Sorry for the late response,

Sorry for the late response, this was buried in my emails.

What exactly are you seeing when this occurs? Have you tested against the base application installed separately?

I've tested using gnuplot as the plot format, and I do indeed receive a pop-up message stating that the program can't load correctly. Does this happen to you using the base app as well, or just the portable app?

It could be an issue of not finding the path, as they a script to load the environment that I bypass in the launcher, so it's possible I left something out. I should be able to take a look at this sometime this week, hopefully, to verify and fix.

Qwillou
Qwillou's picture
Offline
Last seen: 3 years 1 day ago
Joined: 2015-06-29 09:27
I have tested the portable

I have tested the portable version on my personnal laptop (win8.1) and it creates wxplot without issue.
The base one is working too.

Same commands on my professional laptop (win7) and it crash. Can't install the base one here.
I get a window saying "wgnuplot.exe has stopped working" with 2 options "check online for solution and close the program" or "close the program.

Here are the problems details:

Problem signature:
Problem Event Name: APPCRASH
Application Name: wgnuplot.exe
Application Version: 0.0.0.0
Application Timestamp: 5f223a6d
Fault Module Name: libgcc_s_dw2-1.dll
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 0001b009
OS Version: 6.1.7601.2.1.0.256.4
Locale ID: 1036
Additional Information 1: 4c0d
Additional Information 2: 4c0d4d78887f76d971d5d00f1f20a433
Additional Information 3: 4c0d
Additional Information 4: 4c0d4d78887f76d971d5d00f1f20a433
Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409
If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

Wondering if it is a compatibility issue between my win7 version and wgnuplot.
When I tried to launch wgnuplot under the maxima folder ... it crashes too.
What ever the compatibility options I choose ... crash

???

Qwillou
Qwillou's picture
Offline
Last seen: 3 years 1 day ago
Joined: 2015-06-29 09:27
Have to say an earlier

Have to say an earlier portable version is working
wxmaxima 13.04.2 - maxima 5.31.12

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Still on todo

Sorry about the lack of activity on this. I've been busy with a new job and getting close to my move date.

Just thought I'd let you know that this might be a little delayed (more than it already has, I suppose).

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.37.3

Updated to Maxima 5.37.3

For some reason, the gui during the first launch is screwed up. I'll have to look into this a little more to find out what's causing that.

Other than that, this seems to work for me so I hope any previous issues have been resolved.

Komzar
Offline
Last seen: 1 year 4 months ago
Joined: 2015-10-27 08:12
Plots error.

Hi.
I try this new update and have same problem with plots.
" wgnuplot.exe - Application Error. This application was unable to start correctly (0x0000005)."

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Hello,

Hello,

What version of Windows are you using?

Have you tried installing Maxima directly (i.e. not using the portable version)?

If so, did you experience the same error?

Thank you.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.38.1

Updated to Maxima 5.38.1

Drazick
Offline
Last seen: 1 hour 49 min ago
Joined: 2010-09-06 06:36
Maxima 5.39.0

Maxima 5.39.0 is released.

Could you update please?

Thank You.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.39.0

Updated to Maxima 5.39.0

Sorry for the delay.

Drazick
Offline
Last seen: 1 hour 49 min ago
Joined: 2010-09-06 06:36
Thank You Very Much!

Thank You Very Much!

Downloading...

branchus
Offline
Last seen: 1 year 2 months ago
Joined: 2016-04-29 08:33
Thank you so much

Thank you so much Smile

Drazick
Offline
Last seen: 1 hour 49 min ago
Joined: 2010-09-06 06:36
Version 5.40 Is Out

Hello,

Any chance for updated version for version 5.4?

Anyone can make it official release?

Thank You.

[Duplicate comment removed - mod GC]

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated

Updated to Maxima 5.40.0. Might want to give it some time to mirror.

Sorry for the delay.

scriptdaemon
Offline
Last seen: 3 weeks 4 days ago
Developer
Joined: 2008-10-10 17:40
Updated to Maxima 5.41.0

Updated to Maxima 5.41.0

Log in or register to post comments