You are here

[Resolved] GVim Portable : did not pick plugins and color in Data\settings\vimfiles\

6 posts / 0 new
Last post
curvenut
Offline
Last seen: 12 years 8 months ago
Joined: 2010-05-17 14:52
[Resolved] GVim Portable : did not pick plugins and color in Data\settings\vimfiles\

Hi,

I just download GVim portable 7.2

I usually use a couple plug ins and color scheme ,
As instructed in the readme () , I put them under the directory :

Data\settings\vimfiles\

Under that directory I have the following sub-directory that contain my colors and plugins:

colors\
doc\
plugin\

But the Gvim portable did not pick any plygins and colors from that Data\settings\vimfiles\ directory.

Any help is appreciated
!

Thanks

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 7 months ago
Joined: 2007-04-15 21:08
Not reproducible

I use gVim Portable extremely regularly at Uni, and I use a custom color scheme (molokai) in Data\settings\vimfiles\colors\molokai.vim. It works fine. As for the help files, I imagine you haven't regenerated the help tags which is necessary for it to detect them; run this command: :helptags $HOME\vimfiles\doc. I haven't got any plugins myself, but I have observed that the ftplugin directory (file-type plugins) in $VIMRUNTIME/ftplugin and $HOME/vimfiles/ftplugin are not loaded, and have been unable to ascertain why (it's just weird). When Vim 7.3 comes out (planned for within the next couple of months or so I believe) I'll be asking Bram to make an OLE-free build for us which will mean that it's not dependent on my build environment (which was missing Python/Perl/Ruby/Tcl), which could potentially have other side effects too, I imagine.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

curvenut
Offline
Last seen: 12 years 8 months ago
Joined: 2010-05-17 14:52
I reinstalled GVimportable in

I reinstalled GVimportable in order to start from scratch.

I put the coloscheme in the directory as instraucted.

gVimPortable\Data\settings\vimfiles\colors\peaksea.vim

And gvimportable is still unable to load the scheme

Did you put a special instruction in your vimrc ?????

THanks

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 7 months ago
Joined: 2007-04-15 21:08
Correct

That's the correct location. You should then be able to load it with :colo peaksea. If that's still not working, could you please try the following; :version (which should confirm that it's looking in $HOME for the [g]vimrc - it is loading that file, isn't it?) and :echo $HOME to make sure HOME is set properly (it most certainly should be).

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

curvenut
Offline
Last seen: 12 years 8 months ago
Joined: 2010-05-17 14:52
Hi, I screw up with my own

Hi,

I screw up with my own vimrc !!
Now it works as instructed. I can get my color loaded.

And furthermore, the plug ins are loaded too when I put the plugins directory in

gVimPortable\Data\settings\vimfiles\plugin

Thanks

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 7 months ago
Joined: 2007-04-15 21:08
Good

Glad you've got that sorted out.

In my own case, the plugins (plugin) are working, but not the filetype plugins (ftplugin).

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

Log in or register to post comments