You are here

Pidgin: Yahoo can't connect

7 posts / 0 new
Last post
weary_girl
Offline
Last seen: 14 years 1 month ago
Joined: 2010-05-02 17:55
Pidgin: Yahoo can't connect

I just updated from Pidgin 2.6.6 to 2.7.1. When I started Pidgin up, my GTalk account is fine. I'm given this message for my Yahoo account: "[name of account] disconnected: Unable to connect: The server's response did not contain the necessary information." I restarted Pidgin, and I'm getting the same message.

Does anyone know what is wrong and how to fix it?

Darkbee
Darkbee's picture
Offline
Last seen: 4 years 2 months ago
Joined: 2008-04-14 09:41
Yahoo works for me

I know this probably won't help you at all (sorry) but I can connect with Yahoo fine. However, I did have (still have) major problems with my anti-virus program F-Secure messing with v2.7.1 of Pidgin. My point, there may be another program that doesn't like your Pidgin. Try disabling firewalls, security programs and such temporarily to see if you can connect.

You should also confirm that you can still connect using the previous version of Pidgin.

weary_girl
Offline
Last seen: 14 years 1 month ago
Joined: 2010-05-02 17:55
My virus program is AVG.

My virus program is AVG. Thank you for that link to the old Pidgin. With 2.6.6, I can connect to Yahoo. Maybe I'll just stick with 2.6.6...heh

Darkbee
Darkbee's picture
Offline
Last seen: 4 years 2 months ago
Joined: 2008-04-14 09:41
I use AVG also

it looks like AVG isn't the issue.

According to this page on the Pidgin ticket tracking system, others are having this problem also. I guess something has been changed with the way Yahoo authenticates/logs in, and it would seem that you're probably using some kind of proxy which breaks things.

Sorry, looks like the only work-around for now is to do what you've done; use 2.6.6.

weary_girl
Offline
Last seen: 14 years 1 month ago
Joined: 2010-05-02 17:55
Yeah, okay, thanks.

Yeah, okay, thanks. Sometimes, Pidgin sets people's statuses (on Yahoo) to idle or offline (when they're busy or available), but at least I can actually connect now, which is a plus. (This is when I'm using 2.6.6.)

Amarus
Amarus's picture
Offline
Last seen: 11 years 12 months ago
Joined: 2008-04-25 17:00
hmmm....

I'm using PidginPortable v.2.7.1 . I'm able to connect to yahoo and engage in chats with others no problem.

Perhaps, if you are still interested in using v.2.7.1, you should try a clean installation of PortablePidgin v.2.7.1 and retry yahoo.

The only unusual errors I see on the debug window when I connect to yahoo are things like the following:

(19:44:39) yahoo: Unhandled service 0xef
(19:44:39) yahoo: Unhandled service 0x12

And a lot of these. I guess it is one per every buddy on the list, even if they are offline [since there are so many of these]

(19:44:39) yahoo: Unknown status key 198
(19:44:39) yahoo: Unknown status key 204
(19:44:39) yahoo: Unknown status key 205
(19:44:39) yahoo: Unknown status key 213
(19:44:39) yahoo: Unknown status key 283
(19:44:39) yahoo: Unknown status key 317
(19:44:39) yahoo: Unknown status key 300
(19:44:39) yahoo: Unknown status key 440
(19:44:39) yahoo: Unknown status key 441

-------
Also since it doesnt' hurt to say, remember that Yahoo and Yahoo JP are handled separately.

in_vino_veritas,_in_aqua_sanitas.

weary_girl
Offline
Last seen: 14 years 1 month ago
Joined: 2010-05-02 17:55
My debug window is completely

My debug window is completely empty. Hopefully, this problem will be fixed in the next release of Pidgin. Smile

Log in or register to post comments