You are here

Executor Portable 0.99.11 Dev Test 2

39 posts / 0 new
Last post
Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Executor Portable 0.99.11 Dev Test 2

Application: Executor
Category: Utilities
Description: from website This is a multi purpose launcher and a more advanced and customizable version of windows run. The program originated as I was sick of spending too much time searching for programs through my ever growing windows start-menu, and also I missed a tool that could ease and optimize my daily work flow. There was of course already programs like this available, but each had it's annoyance or missing features or too(!) geeky.

Download Executor Portable 0.99.11 Development Test 1
1 MB Download / 3 MB Installed
MD5: 42778c3d98bb18d14f250d69ec69ef86

Release Notes
0.99.11 DT2 - Added FileWrite5 per Gord's suggestion. Updated the launcher, installer, and format, and added AppNamePortable.ini to source. Updated help.html images. Updated AppInfo.ini to ANSI encoding.
0.99.11 DT1 - March 10, 2012: Updated to latest release. Got rid of random [Activate]:Registry=true entry in the launcher.
0.99.10 DT1 - April 10, 2011: Updated version to latest release. App's now written in PAL.
0.99.07 DT1 - December 12, 2010: Updated app to latest version. Now removed splash dll from before. Its not an online installer because I realized that it said you could freely distribute it.
0.99.04 DT1 - June 21, 2010: Initial Release

vf2nsr
vf2nsr's picture
Offline
Last seen: 1 year 6 months ago
DeveloperModerator
Joined: 2010-02-13 17:10
??

Installer fails to even run just locks up ..I get the option to run and then choose it and it goes no where

“Be who you are and say what you feel because those who mind don't matter and those who matter don't mind.” Dr. Seuss

OliverK
OliverK's picture
Offline
Last seen: 1 year 6 months ago
Developer
Joined: 2007-03-27 15:21
Wow, now that is slick. Out

Wow, now that is slick. Out of curiosity, do you use the zip file? and is the freezing in the program itself, or in the installer for the program?

Too many lonely hearts in the real world
Too many bridges you can burn
Too many tables you can't turn
Don't wanna live my life in the real world

vf2nsr
vf2nsr's picture
Offline
Last seen: 1 year 6 months ago
DeveloperModerator
Joined: 2010-02-13 17:10
Installer

the installer freezes so never even gets to first screen

“Be who you are and say what you feel because those who mind don't matter and those who matter don't mind.” Dr. Seuss

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
can you send me a screenshot?

try re-downloading and installing.

I tried that, seems to work fine for me. I doubled checked everything, (like appinfo.ini Blum ) and its not getting any issues.

Is anyone else experiencing this problem?

vf2nsr
vf2nsr's picture
Offline
Last seen: 1 year 6 months ago
DeveloperModerator
Joined: 2010-02-13 17:10
4th

4th time was the charm finally got it downloaded and installed Smile

“Be who you are and say what you feel because those who mind don't matter and those who matter don't mind.” Dr. Seuss

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
good to see that

I'm still worried that others might get this problem, too, though. Did you do anything differently the time you made it work?

vf2nsr
vf2nsr's picture
Offline
Last seen: 1 year 6 months ago
DeveloperModerator
Joined: 2010-02-13 17:10
hmm

the only thing i did different was not to delete the previous download ( I usually save to desktop then install and then archive them elsewhere) this time I saved to a folder then installed???

“Be who you are and say what you feel because those who mind don't matter and those who matter don't mind.” Dr. Seuss

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
yep, I used the zip ;)

why do you ask?

OliverK
OliverK's picture
Offline
Last seen: 1 year 6 months ago
Developer
Joined: 2007-03-27 15:21
I wondered if the installer

I wondered if the installer freezing was referencing your installer, or the executor installer

Too many lonely hearts in the real world
Too many bridges you can burn
Too many tables you can't turn
Don't wanna live my life in the real world

Mark Sikkema
Offline
Last seen: 6 years 7 months ago
Developer
Joined: 2009-07-20 14:55
Hi Pyromaniac

Installer is fine on my site !

And regshot is clean, besides NewAdvSplash plug-in being left behind in $PLUGINSDIR

To solve this, just add:

    newadvsplash::stop /WAIT

to the end of your script

Formerly Gringoloco
Windows XP Pro sp3 x32

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Installer is fine on my

Installer is fine on my site!
do you mean side? Blum

I was wondering why that dll wouldn't get outa there Blum will fix in dev test 2

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Updated to 0.99.07 DT1

see release notes for changes.

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
Version?

Is there any particular reason the about page of the app says 0.9.9 Build 4 - or wasn't the Executor application itself updated to say Build 7? Still, whatever version it is, it is good to have an alternative to Launchy (which is a nice app, but the program's frequent opening of my browser to display the donations page when you hit the hotkey to bring up the app itself is pretty annoying - no option to disable this either, except to remove the donations page coding from the source and compile your own binaries).

Anyway, there is a new Build 10 of Executor out as well, released a few days ago.

I used to have a sig...until one of the mods ate it

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
ok

I'll update asap.

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
Oops, forgot the link...

Would have helped had I posted the link - the new version is buried away in the forums a bit!

http://executor.21.forumer.com/viewtopic.php?t=171

I used to have a sig...until one of the mods ate it

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Updated to 0.99.10

Added path portability, and rewrote the app in PAL.

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
Thanks

Up and running here, no problems so far. Is the "Clear Last Input when Focus" setting disabled by default with a normal, non-portable install, or is it something specific to the portable version?

I used to have a sig...until one of the mods ate it

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
Not quite portable?

For some reason, this release seems to have added an executor.ini file in my AppData folder (C:\Users\username\AppData\Roaming\Executor\executor.ini). Using Win7 64bit.

I used to have a sig...until one of the mods ate it

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
hmm

I don't know why, but I know I took care of it in the launcher INI:

[DirectoriesMove]
Executor=%APPDATA%\Executor

(compiled with PAL 2.1 beta 2)

I know it cleans it up on XP, but I might have to add custom code for later versions...?

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
AppData?

Are you sure it is still AppData on Win 7? The file was created in a sub-folder of AppData (on Win 7 as a standard install, you have three folders in AppData, these being AppData\Local, AppData\LocalLow, AppData\Roaming - none of which you have on XP). The Executor.ini file was in the AppData\Roaming\Executor folder. So unless AppData points to AppData\Roaming on Win 7, that would probably be the problem.

I used to have a sig...until one of the mods ate it

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 41 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
APPDATA

APPDATA is C:\Documents and Settings\username\Application Data on Windows 2000/XP and it's C:\Users\username\AppData\Roaming on Windows Vista/7. It's automatic.

Sometimes, the impossible can become possible, if you're awesome!

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
hmmm...

as John posted above, it should be taken care of. Maybe it was just a fluke. Try deleting ...\AppData\Roaming\Executor and re-running the portable app.

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
Will try that

Yes, it could have just been a one off. I've deleted the ini file from my hard drive, and I'll try reinstalling the app again and see what happens.

I used to have a sig...until one of the mods ate it

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
Right, worked it out

Ok, when you launch Executor Portable, it creates an Executor folder in AppData\Roaming. If you then exit the program, it should delete this folder - and it does normally. But if something abnormal happens, then the folder and ini file get left behind. As will the other two files it creates, scancache.dat and executor.ini.bak

I used to have a sig...until one of the mods ate it

depp.jones
Offline
Last seen: 8 hours 1 min ago
DeveloperTranslator
Joined: 2010-06-05 17:19
Normally a second launch

Normally a second launch should detect if the launcher was closed abnormally and cleanup on the next launch. I am not shure of that functionality but I once read an answer to a similar problem with another app in the forums. I don't know the exact parameters how that is determined, maybe Chris could enlighten us on that. Wink

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
New(ish) Version

I'm not sure if the app is really developed any more (the dev seems to have left the forums at least, and that is never a good sign), but there was a .11 version posted last year:

http://executor.21.forumer.com/viewtopic.php?t=171

Edit: Actually, that seems to be the same version number available from the downloads page:
http://www.1space.dk/executor/download.html

They are different downloads though, so I don't know if they are in fact the same version or not, despite having the same version number. The downloads page says 30 July 2011, the beta thread says 17 July 2011.

I used to have a sig...until one of the mods ate it

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Ok,

I'll look into it, and if I update, it'll probably tomorrow, as I've got plans today.

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Updated to 0.99.11

Just love this app.

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
v0.99.12 Beta

Looks like development may have started up again after a long hiatus. A 64bit compatible version has been released:
http://executor.21.forumer.com/viewtopic.php?t=1077

This will be handy - there are some processes on a 64bit Windows install that just can't be accessed by a 32bit program launcher.

I used to have a sig...until one of the mods ate it

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Ok

Well, it looks like the it has the same functionality as the 32-bit build, but was recompiled with a 64-bit compiler. Let's wait a bit to see if he releases any revisions before releasing an update.

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
Agreed

The dev says that he is testing it on his own 64bit system, so I wouldn't be surprised to see some revisions Smile

I used to have a sig...until one of the mods ate it

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 11 hours 24 sec ago
DeveloperModerator
Joined: 2008-07-24 18:46
Comments

I'm starting to go through the apps in the "ready for release" list, and figured I'd start with yours.

Here's what the dev toolkit has to say:
PortableApps.com Format validation failed with 3 errors and 1 warning.

Errors

  • File Other\Source\AppNamePortable.ini is missing
  • appinfo.ini: [Details], required value AppID is missing
  • appinfo.ini: [Details], invalid value AppId

Warnings

  • File App\AppInfo\Launcher\splash.jpg is missing

Ok, now my comments:

  • Update to PAF 3.0, including using the 2.4 AppTemplate.
  • Also, in order to allow the DT to test appinfo.ini, I had to change the encoding. For some reason, you had it encoded with UCS-2 Little Endian, when it should be ANSI encoded.
  • This is my personal reccomendation, you can disregard if you want:
    I suggest adding

    [FileWrite5]
    File=%PAL:DataDir%\Executor\executor.ini
    Type=INI
    Section=Setup
    Key=autostart
    Value=0

    This ensures that the "start on Windows startup" option is not selected on starting. Alternatively, you could put that as a custom code on close.

That's all I found. Thx, I have this running every time I use the platform. Don't use it often, but nice to have available.

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Updated to 0.99.11 Dev Test 2

See release notes for changes.

@Gord, thanks. I'm not sure how the encoding of AppInfo.ini is important, or why it was different than the other apps in the first place, but I've changed it to ANSI anyway. As a showing of my gratitude, I've increased the number of likes on your Facebook Aquatics page by nearly 17% :P.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 11 hours 24 sec ago
DeveloperModerator
Joined: 2008-07-24 18:46
heh

It's just one of those standardization things. I don't know if it really makes much of a difference, other than to the dev toolkit.

Thanks for the like lol

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 11 hours 24 sec ago
DeveloperModerator
Joined: 2008-07-24 18:46
AppId != AppID

JW,

Only one thing I found: change AppId in appinfo.ini to AppID Other than that, I'd say this is fully ready for official.

However, it is worth it to note that the base app seems to be in perpetual beta, and that there is now 0.99.12 available (for 64-bit machines only).

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 3 years 2 weeks ago
Developer
Joined: 2008-09-30 19:18
Okay

I guess I forgot to fix that one. I've just used the Notepad2-mod Portable app as a template, which has it as AppId and I never bothered to change it. I don't think it's worth releasing another dev test though, so I'll hold off until there's I need to change something else in the package.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 11 hours 24 sec ago
DeveloperModerator
Joined: 2008-07-24 18:46
No worries

I wouldn't make a new dev test just for that either Smile

romulous
Offline
Last seen: 8 months 3 weeks ago
Joined: 2009-10-23 03:58
New Version

v0.99.13b released as beta:
http://executor.fr.yuku.com/topic/1077

I used to have a sig...until one of the mods ate it

Log in or register to post comments