You are here

Still problems with 3.0.2

7 posts / 0 new
Last post
FoxyStrut
Offline
Last seen: 12 years 4 months ago
Joined: 2008-11-30 10:28
Still problems with 3.0.2

Hi --

I still have the same problems as with all the previous (pre-release or not) 3.0 issues: I use the "mirror" option in sync mode. Files that do not exist anymore in the source directory are not deleted in the destination directory, while they should be. Back to 2.2.1 Sad

(by the way, while I'm here, the help in versions 2.x was better -- no need to read the html files within a browser)

-cheers-

Darkbee
Darkbee's picture
Offline
Last seen: 2 years 7 months ago
Joined: 2008-04-14 09:41
The good, the bad and the ugly

The HTML help files are part of the PortableApps specification I think, so Steve is just following that. Not really his decision. On the plus side it was argued that now you're able to have both help and Toucan itself open at the same time.

Pros and cons, pros and cons.

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 9 years 2 months ago
Developer
Joined: 2005-12-10 15:22
Hi,

thanks for the report. If you could give me a set of exact steps to reproduce the issue you are having then I can track it down and fxx it. Something like:

  1. Create three blank files in the source and four in the destination
  2. Run Toucan and select mirror and the following options...

Also the operating system you are using would be helpful too. Thanks in advance! Smile

FoxyStrut
Offline
Last seen: 12 years 4 months ago
Joined: 2008-11-30 10:28
Report

Hi --

I'm on Windows XP Service Pack 3.

I'm using Toucan every day to save what I've done at work on a USB key.

Here is what I'm doing (which was working perfectly well with previous versions of Toucan, although much slower than now -- but incomplete now):

- Function: Mirror
- Rules *.ini files are excluded
- File checks: Modified time (I've also tried with full and short comparison)
- Other: Retain attributes + Ignore read-only + Retain timestamps
- Language: French

Then, when running the sync, all new files in the Source Directory are correctly copied into the Destination Directory. The problem is that all files that were present in both directories, but deleted from the Source Directory (after the last sync) are not deleted from the Destination Directory while they should be using the Mirror Sync function.

Hope this can be resolved.

-Cheers-

Darkbee
Darkbee's picture
Offline
Last seen: 2 years 7 months ago
Joined: 2008-04-14 09:41
Accented Characters

Others have been having issues with non English versions, in particular special characters with accents etc. Do any of your paths/rules/file names have special characters? That could well be the issue.

dbkblk
dbkblk's picture
Offline
Last seen: 12 years 3 months ago
Joined: 2010-07-21 04:57
Hi ! I'm also french and i

Hi ! I'm also french and i use almost the same settings.
The problem was solved using the english language.

More details here: https://portableapps.com/node/24320

We'll have to wait for a fix to use it in french Wink

FoxyStrut
Offline
Last seen: 12 years 4 months ago
Joined: 2008-11-30 10:28
Seems to work now...?

Hi --

1) @Darkbee - Nope, I don't have any special characters in my folder's names (i.e. no accent, hyphen, etc.)

2) @dbkblk - I've tried using the English version and now it seems to work. I've just tested it now, deleting a file from the Source, running a mirror, and the file has been deleted from the Destination (which was not done before). Just to see, I've deleted another file, re-ran the mirror, but using the French language, and the file has not been deleted from the destination.

It's not anymore an issue for me, now that I know that I have to use the English version -- but the problem might remain for some others: DO NOT USE THE FRENCH VERSION!

-- thanks for your help --

Log in or register to post comments