You are here

[Javascript Application] download prompt bug? FFP v3.6.10

4 posts / 0 new
Last post
Logos A
Offline
Last seen: 3 years 9 months ago
Joined: 2010-08-13 04:32
[Javascript Application] download prompt bug? FFP v3.6.10

For the last few days when I use my firefoxportable v 3.6.10 I am now getting a weird pop-up window that says this

[javascript-application]
Content [application/octet-stream] found
Do you want to download it to C:\Users\charlie\ ?

no matter how many times I click "cancel" it pops again dozens of times while Im on one page.If I say "yes" it downloads small litle images from the webpage such as icons from the webpage often with ".cur" at the end.But also .ico and other icon types.

Can anybody shed some light on the cause for this?Im out of my depths.I need help.Its so annoying

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 8 years 11 months ago
Joined: 2007-04-15 21:08
Malware

That looks to me like it's probably malware (probably an extension installed into the browser though possibly just a website?). Try starting Firefox in safe mode (FirefoxPortable.exe -safe-mode) and take a look at the add-ons that it shows.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

Logos A
Offline
Last seen: 3 years 9 months ago
Joined: 2010-08-13 04:32
well it now happens even when

well it now happens even when Im googling stuff.and it only downloads the icons.I closed firefox and typed what you told me to the run box.I dont understand why running in safe mode tells me anything different than regular mode?I can see my extensions in regular mode.But I went ahead and disabled a few extensions that I use to download media from webpages.

I disabled downloadhelper 4.8 (no change).but when I disabled Media Stealer 1.2.0 the pop up stopped.so I guess thats the culprit

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 8 years 11 months ago
Joined: 2007-04-15 21:08
OK

OK, so that's it. Genuine extension misbehaving. The behaviour you're noting has also been observed in a review of it. I think you're on your own for working out how to fix it - some configuration change may do it, or you may just need to not use the extension. (They say of 1.1 that "The annoying alert messagebox has gone. Tt was a shaming bug.", not sure if it's come back in 1.2 or your issue is different or if you just don't have the latest version.)

The reason I said safe mode was that if it was malware of some sort it could be putting something in which would prevent you from fixing it, whereas in safe mode you can always get rid of an extension or plugin. Fortunately in this case that wasn't the issue, so safe mode wasn't necessary.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

Log in or register to post comments