You are here

Gaim Portable 2.0 Beta 3.1 Pre-Release - Testers Needed (Especially if you've had problems in the past)

20 posts / 0 new
Last post
John T. Haller
John T. Haller's picture
Online
Last seen: 14 min 39 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Gaim Portable 2.0 Beta 3.1 Pre-Release - Testers Needed (Especially if you've had problems in the past)

I've just posted a pre-release of Gaim Portable 2.0 Beta 3.1 and need some folks to test it out... especially if you've had problems with Portable GIMP or Portable Gaim in the past. For the unfamiliar, Gaim is a multi-network instant messaging client that works with AOL, MSN, Yahoo, etc. This release has many of the features of the other new apps, plus some new stuff:

Live CD Support - Gaim Portable fully supports running from a CD. Just extract it to your local hard drive, run it at least once and configure it to your liking, and burn it to CD.

In-Place Upgrades - Gaim Portable supports the ability to do what I'm calling an "in-place upgrade". This means that you can extract it right over an existing installation of Gaim Portable without losing any of your existing preferences and it'll Just Work (tm).

Language Selection - You can now specify the language that Gaim Portable will use independent of the operating system you're currently running it in. After running it at least once (and generating your default settings), head to GaimPortable\Data\settings and open up GaimPortableSettings.ini. In there, set GAIMLANG equal to the language you wish to use... de for German, for instance. It's blank by default, which means it will use the operating system default).

WINE Support? - Currently, Gaim will not function running within a standard WINE install if it does not include the Windows fonts package. I'm not sure if it will if those fonts are included (Anybody that can test?)

Grab the self-extractor here: Gaim Portable 2.0 Beta 3.1 Pre-Release

From the Beta 3 Pre-Release, this updates the MSN plugin and Gaim to 2.0 b3.1 and it includes an additional fix in the launcher for computers where Gnumeric is installed.

Thanks,
John

alf149
Offline
Last seen: 10 years 1 month ago
Joined: 2006-02-11 18:29
Works like a charm, but

Works like a charm, but there are some of the prefs i can't set any more eg. send on Crtl + Enter

I din't have any error on the GIMP Portable 2.2.12 Pre-Release with the "new" .dll file that also worked.

Other then that its very fine keep up the good work.

sory about my english natvie is danish.
---------------------
Rolf

Rolf

barlas
Offline
Last seen: 14 years 2 weeks ago
Joined: 2006-04-13 16:17
"Working fine for me

"Works like a charm, but there are some of the prefs i can't set any more eg. send on Crtl + Enter"

This has nothing to do with portable, this option is removed from gaim.

tmm0f5
Offline
Last seen: 13 years 8 months ago
Joined: 2006-04-19 00:49
It's working great for me.

It's working great for me. MSN works fine.

Thanks for all of your work!

Timothy
AIM: TimothyDMB
http://www.mollyandtim.com/

Timothy

raym
Offline
Last seen: 11 years 8 months ago
Joined: 2006-08-04 14:43
gaim 2.0 b3.1

just decided to test this version everything seems to work ok i'll know when i talk to my kids in another part of aust

if you don't know-ee you should ASCII

bastya_elvtars
Offline
Last seen: 14 years 4 months ago
Joined: 2006-06-01 06:53
Some errors

[quote]head to GaimPortable\Data\settings[/quote]
Does not create such file... Sad

Moreover, I get write errors and disconnects (Yahoo, MSN, Jabber, ICQ, IRC). Everything is fine with 2.0beta2 (also portable, of course Wink ). Does not matter whether I am clean-installing or copying the setiings over from 2.0b2.

John T. Haller
John T. Haller's picture
Online
Last seen: 14 min 39 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Bad download?

Possibly a corrupt download? It creates the settings environment on your first run.

Sometimes, the impossible can become possible, if you're awesome!

bastya_elvtars
Offline
Last seen: 14 years 4 months ago
Joined: 2006-06-01 06:53
Nope, tried that.

GaimPortable\Data\settings\GaimPortableSettings.ini does not get created. Tried on different partitions, different filesystems.

John T. Haller
John T. Haller's picture
Online
Last seen: 14 min 39 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Device, Download or File system

It must be something with your device then. The very first thing that the Gaim Portable Launcher does is copy the GaimPortableSettings.ini file from the App\DefaultData\settings directory. It does this even before launching Gaim. If it can't, then there's something wrong on your PC, device or with the download. It's one of the three. It's a simple file operation (CopyFiles in NSIS) and nothing should normally interfere with that unless something is messed up.

Any chance you're on a unicode os?

Sometimes, the impossible can become possible, if you're awesome!

bastya_elvtars
Offline
Last seen: 14 years 4 months ago
Joined: 2006-06-01 06:53
"Any chance you're on a

"Any chance you're on a unicode os?"

WinXP SP2 is meant to be supporting unicode if you mean this...
I'll try the download from another mirror.

John T. Haller
John T. Haller's picture
Online
Last seen: 14 min 39 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
No, directories

No, I mean unicode paths. As in, the full path where you're running it from, if it has any non-ASCII characters, it won't work right. The portable launchers don't support unicode paths. Many of the apps themselves don't either.

Sometimes, the impossible can become possible, if you're awesome!

bastya_elvtars
Offline
Last seen: 14 years 4 months ago
Joined: 2006-06-01 06:53
No, it's like

No, it's like L:\GaimPortable or similar. But I just installed Gaim 2.0 b3.1 under Linux and faced the similar writing error on MSN. What is the GTK version you bundled GaimPortable with?

John T. Haller
John T. Haller's picture
Online
Last seen: 14 min 39 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
MSN Issues

There are MSN issues with every released version of Gaim at the moment, unfortunately. Check your local PC for a file called iconv.dll within your Windows or system or system32 directories. This is incompatible with GTK+.

Sometimes, the impossible can become possible, if you're awesome!

bastya_elvtars
Offline
Last seen: 14 years 4 months ago
Joined: 2006-06-01 06:53
YEAH!

Thanks, John, I could solve the problem. Had to deinstall GTK+ 2.8 from my system which was needed by GIMP 2.4 testversions and it's all fine, the file is created and all protocols work.

cbj0129
Offline
Last seen: 1 year 7 months ago
Joined: 2006-04-03 21:59
Cannot get it to work at all

Gaim 2.0 Beta 3 does not work for me at all. I have tried the the non-portable version with the same symptons.

It loads OK, and attempts to connect to AIM, but never connects. All parameters are the same as Gaim 1.5.0 which works fine. I loaded Miranda and after some bit fiddling, it works fine, but I am used to Gaim and would really like to continue to use it.

Since Gaim Portable uses GTK, I am suspicious of a version conflict with Gimp, but I am at wits end trying to track this down. Any suggestions.

edit: Just noticed I posted this to the wrong thread, Sorry should have posted to PreRelease 2

Clair

bastya_elvtars
Offline
Last seen: 14 years 4 months ago
Joined: 2006-06-01 06:53
Gaim 2.0 is compatible with

Gaim 2.0 is compatible with GTK 2.6 only.

cbj0129
Offline
Last seen: 1 year 7 months ago
Joined: 2006-04-03 21:59
I am aware...

I am aware that Gaim 2.0 requires GTK 2.6. I thought that Gaim Portable loaded and used its own GTK. I also thought that it would not use any GTK loaded by another app. I will find a machine that doesn't have GTK loaded and try it there.

Edit: Works fine on W2K without Gimp installed, so there is still some mechanism where it trys to use the installed GTK.

Thanks,
Clair

bastya_elvtars
Offline
Last seen: 14 years 4 months ago
Joined: 2006-06-01 06:53
Yeah, as discovered a few

Yeah, as discovered a few posts above. Wink

cbj0129
Offline
Last seen: 1 year 7 months ago
Joined: 2006-04-03 21:59
I saw that

but I thought it was the MSN protocol issue. Since I don't use MSN I ignored it.

Sorry,
Clair

bastya_elvtars
Offline
Last seen: 14 years 4 months ago
Joined: 2006-06-01 06:53
It was the iconv hit

from John that helped. Actually few programs used iconv, I removed GTK+ and voilá.

Topic locked