You are here

GnuCash Portable 2.4.4 Rev 2: GnuCashPortable.ini seems to be ignored

7 posts / 0 new
Last post
cashuser
Offline
Last seen: 13 years 3 months ago
Joined: 2011-02-07 15:24
GnuCash Portable 2.4.4 Rev 2: GnuCashPortable.ini seems to be ignored

GnuCash Portable 2.4.4 Rev 2 doesn't recognize
the "PerlPath" - variable in file "GnuCashPortable.ini".
Consequently finance::quote does not work if the
Perl interpreter is not installed in the default path.
This is normally the case if a portable version of
Perl is used.
(Also if a wrong setting for "GnuCashExecutable" is
given it doesn't lead to malfunction.)

John T. Haller
John T. Haller's picture
Offline
Last seen: 13 hours 36 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Dropped

A new launcher is being used as the old one did not properly function with the updated GnuCash. Support for alternate naming of the GnuCash EXE has been dropped. The only options supported are now listed in the Other\Source directory.

I don't think Perl had worked properly in a while, at least since 2.2.something. And as there are no fully-functional portable packages of Perl in stable form, I did not rewrite the custom code for the new launcher.

Would setting it up to auto-detect and work with the test version of Perl Portable be sufficient?

Sometimes, the impossible can become possible, if you're awesome!

cashuser
Offline
Last seen: 13 years 3 months ago
Joined: 2011-02-07 15:24
Perl / finance::quote

I don´t have problems using a portable version Perl
with GnuCash 2.2.9.
I also checked finance::quote with the PortableApps-
version of GnuCash 2.4.0 and it worked!
I checked it by copying Perl from my stick with the
2.2.9 version of GnuCash and the GnuCashPortable.ini file
to the 2.4.0 environment.
I am using copy of Active Perl on my stick using path
"X:\GnuCashPortable\PortableApps\CommonFiles\Perl"
but "X:" changes.
I would prefer if I could still use my "Active Perl".

John T. Haller
John T. Haller's picture
Offline
Last seen: 13 hours 36 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Unsure

As Active Perl is not under an open source license, we can't distribute it or work with it directly without their permission. Strawberry Perl is under such a license, which is why we will be more likely to support it. I'm unsure if we'll consider Perl a CommonFiles plugin or not because hardly any of our apps use it at the moment. However, even if we standardize on Strawberry in CommonFiles\Perl, Active Perl would probably still work when dropped into that location.

Sometimes, the impossible can become possible, if you're awesome!

cashuser
Offline
Last seen: 13 years 3 months ago
Joined: 2011-02-07 15:24
finance::quote

Without finance::quote GnuCash isn't complete. I use
it very often. Not having this feature would mean to me
using GnuCash 2.2.9 as long as practicable. Unfortunatly
the HBCI/FinTS protocols are changing...

John T. Haller
John T. Haller's picture
Offline
Last seen: 13 hours 36 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Ummm

That doesn't appear to be a response to my last posting. I was explaining why we can't package Active Perl and why Strawberry Perl could be. We could configure it to work with that and then you could probably drop Active Perl into where Strawberry Perl would normally go. Would that work for you?

Sometimes, the impossible can become possible, if you're awesome!

cashuser
Offline
Last seen: 13 years 3 months ago
Joined: 2011-02-07 15:24
Sorry

Any solution which makes finance::quote working without
limitations is o.k. for me.

Log in or register to post comments