You are here

Problems with LibreOffice

5 posts / 0 new
Last post
astaroth63
Offline
Last seen: 11 years 5 months ago
Joined: 2011-07-07 19:25
Problems with LibreOffice

I've installed LibreOffice Portable in Brazilian Portuguese. When I launch it from PortableApps Suite, the language change to Portugal Portuguese. This doesn't happen when I launch it directly from the folder: it appears correctly in Brazilian Portuguese. Can anybody tell me what's the problem?

Besides, my F-Secure AV detected Gen:Variant.Kazy.21485 virus in

..\LibreOfficePortable\App\libreoffice\URE\bin\regview.exe
..\LibreOfficePortable\App\libreoffice\URE\bin\regmerge.exe
..\LibreOfficePortable\App\libreoffice\program\unoinfo.exe

In both 3.3.3 and 3.4.1 versions.

Thanks!

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 32 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Platform Language

When you launch from the platform, it will match whatever language you have the platform set to. It doesn't matter what language you installed it as, since it is a multilingual app with multiple languages.

Please report the false positive to F-Secure. It's a bug in their current definitions (shared by BitDefender, nProtect and GData which all use the same definitions).

Sometimes, the impossible can become possible, if you're awesome!

astaroth63
Offline
Last seen: 11 years 5 months ago
Joined: 2011-07-07 19:25
Thanks, but the platform is

Thanks, but the platform is set to Brazilian Portuguese and all other Portable Apps are lanched correctly in this language. Only LibreOffice doesn't.

I will report the false positive to F-Secure ASAP. Thanks again.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 32 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Locale Fix

Explore to the LibreOfficePortable\App\AppInfo\Launcher directory and open the file LibreOfficePortable.ini. In there, find the section called [LanguageStrings] and in that change this line:

pt_BR=pt-br

to read:

pt_BR=pt-BR

That should fix it. It seems LibreOffice is pickier about language codes than the launcher is expecting. And I'll be sure to get this fix out in the next version.

Sometimes, the impossible can become possible, if you're awesome!

astaroth63
Offline
Last seen: 11 years 5 months ago
Joined: 2011-07-07 19:25
Worked fine now

Thanks!

Log in or register to post comments