You are here

[solved] lightning in TB5?

17 posts / 0 new
Last post
ottosykora
Offline
Last seen: 1 day 1 hour ago
Joined: 2007-10-11 17:48
[solved] lightning in TB5?

How do you get the lightning in TB5 work?

After update to TB5, the extensions try update, but on lightning all seems to chrash.

Attempts to somehow stop this forever going update and installing the right version manually failed too.

mgagnonlv
Offline
Last seen: 1 year 2 months ago
Joined: 2008-04-04 21:51
Get Lightning 1.0b4

Michel Gagnon
Montréal (Québec, Canada)

ottosykora
Offline
Last seen: 1 day 1 hour ago
Joined: 2007-10-11 17:48
not on my side

tried to install it, but it does not work on my side, I did so far not discover why.

During the installation of the xpi the whole TB crashes, when restarted nothing left of any lightning.

I also tried to remove the old lightning first and then install the new one, but still same problem.

Simply the installer script freezes and nothing goes on any more.

Tried so far on updated TB only, not complete fresh install, as the copy I would like to use it is the working one.

Is there any trick to do the installation?

Otto Sykora
Basel, Switzerland

tapsklaps
Offline
Last seen: 5 years 9 months ago
Developer
Joined: 2010-10-17 08:11
Containment of the cause

Perhaps the cause is to search in the existing installation of Thunderbird . I would therefore recommend that you install Thunderbird 5.0 again separately. Then you install the Add-on Lightning in this new installation of Thunderbird. If that should work, then you know that the cause is your current installation of Thunderbird.

In addition, when I install Lightning with Thunderbird 5.0 it has worked.

ottosykora
Offline
Last seen: 1 day 1 hour ago
Joined: 2007-10-11 17:48
fresh installation

fresh installation on separate media of the tb5
no other extensions installed, no data from old tb transfered, simply virgin tb5 portable.
go to addons and try to install the most recent version of the lightning.
The installation crashes, in fact the whole tb crashes subsequently.

Tried this while usb stick inserted in XP computer and w7 computer, both have exactly same result.
The message script not responding, thereafter windows crash report of thunderbird.exe crashing.

is there any special trick to install this?

Otto Sykora
Basel, Switzerland

tapsklaps
Offline
Last seen: 5 years 9 months ago
Developer
Joined: 2010-10-17 08:11
Installation of TB + Lightning on hard disk instead on USB-Stick

Possibly the USB-Stick could be the cause. So try a fresh installation of TB + Lightning on the hard drive. Come then still the same problems?

Regarding the installation I've done this in a conventional manner (Extras -> Add-ons -> click on the arrow next gear-wheel -> Add-on install from file...). And how you've installed the Add-on? Do you have used the above recommended version of Lightning for TB 5.0?

ottosykora
Offline
Last seen: 1 day 1 hour ago
Joined: 2007-10-11 17:48
all done standard way

have now tested on two usb sticks, both rather fast variety, so far not tested on hard drive, well need it on stick then anayway.

Installed fresh cpy of the tb5
then got the latest file from mozilla, the 1.0b4
go to extras , addons, then install from file...etc as usual

few seconds later I getting: unreponsive script....message

caused by: //gre/modules/XPIProvider.jsm:846

tested on two sticks, two computers (XP and w7) in both caeses have the same error and some seconds later windows reports crash of thunderbird.exe.

the TB5 portable is of english variety , my windows installs are german

after attempted installation I find under extensions a folder named staged and in this components of the lightning seems to be located, but apparently since the installation was not completed, tb5 does not know anything about it

Otto Sykora
Basel, Switzerland

ottosykora
Offline
Last seen: 1 day 1 hour ago
Joined: 2007-10-11 17:48
ok on hd

copied the folder with the fresh tb5 to root of a fat32 hard drive and run the update there, this time it did work.

hmmm, too bad, this is then not very useful for portable version

Otto Sykora
Basel, Switzerland

tapsklaps
Offline
Last seen: 5 years 9 months ago
Developer
Joined: 2010-10-17 08:11
Hard disk with NTFS file system

I tested it on my hard disk with a NTFS file system, where it worked correctly.

Have you tried to install it on the root of your USB-Stick?

ottosykora
Offline
Last seen: 1 day 1 hour ago
Joined: 2007-10-11 17:48
yes

I tried all possible and simple on two different sticks, both rather of the fast variety.
It seems, that this particular extension can not be installed over usb2 very well. I tried on external disk, also here it did not install.
Only when I copied the installation to root of a hard drive inside the computer all went ok.

the script seems to be too time sensitive and can not cope with traffic speed over usb connection.

So finally I ended up in copying my installation of 3.1 TB to local hard drive partition, did all the updates there and then copied all back to the usb stick. Once installed all works as expected.

This seems to be the solution to this problem at this time until the author of the lightning sets up installer script less sensitive to small delays.

Otto Sykora
Basel, Switzerland

tapsklaps
Offline
Last seen: 5 years 9 months ago
Developer
Joined: 2010-10-17 08:11
apparently a bug in the add-on lightning 1.0b4

In the meantime I have informed myself in a german lightning forum where this issue was also discussed. There a moderator has recommended using the latest Nightly of Lightning 1.0b4. If this Nightly is again unsuccessful, I would recommend that you wait for a corrected version of Lightning.

tapsklaps
Offline
Last seen: 5 years 9 months ago
Developer
Joined: 2010-10-17 08:11
Meaning of "//gre/modules/XPIProvider.jsm:846"

I have been trying find out the meaning of "//gre/modules/ XPIProvider.jsm: 846" about Google. And some users have the same problem as you described. Unfortunately I could find no solution on the fly. Sorry Sad

Presumably, this Add-on seems to have some bugs that cause among other things the problem that you have described here.

tapsklaps
Offline
Last seen: 5 years 9 months ago
Developer
Joined: 2010-10-17 08:11
Solution for your problem

I've now done just an installation of Thunderbird 5.0 (German) and Lightning 1.0b4 in the root of my USB-Stick. And actually, I also received a Warning: Unresponsive script (see screenshot Warnung: Nicht antwortendes Skript). Now I clicked on the button "Weiter ausführen" and after a short time (eventually you have to wait a few minutes here :-)) the Add-on Lightning 1.0b4 installed properly. And I have used the following version Lightning 1.0b4.

After a restart of Thunderbird 5.0 on my USB-Stick I could use without problems Lightning 1.0b4. I use the USB-Stick on my computer with OS Windows XP Home SP3.

ottosykora
Offline
Last seen: 1 day 1 hour ago
Joined: 2007-10-11 17:48
yes tried

tried this few times, actually this was the first attempt to cure the problem, as I know such 'stopped scripts' from the past, and simply clicking on the redo it button solved the issues in general.

Not so here.
The script was not to be persuaded to resume or restart its job. Instead the whole TB did crash in fact, the ram usage did rise up and up, without any work has been done.
In fact, it was even not possible to stop the TB, appart from killing the processes, which is never fine with portable apps.

As stated, experiment on an external hard drive connected via usb2 port had same issues as the usb stick, but installation on a copy placed on hard drive on data partition on the computer itself, lead to normal installation of the extension.

so temporary help might be simply to copy the TB to writable place on the hard drive inside the computer, do all the install there and then copy the whole story back to the portable drive, followed by 'update' of the extensions again, as some of them will show 'broken' after the copy paste operation.

Crude, but leading to results at least until next update is around.

Should we report to the author?

Otto Sykora
Basel, Switzerland

tapsklaps
Offline
Last seen: 5 years 9 months ago
Developer
Joined: 2010-10-17 08:11
Report is a good idea

Probably I had just luck with install of TB 5.0 + Lightning 1.0b4 on my USB stick. John also reported similar problems. Because this problem occurs in principle only on external data devices, probably the reason is an incompatibility of Lightning1.0b4 with the FAT32 file system. To that extent would be a message to the author very appropriate.

ottosykora
Offline
Last seen: 1 day 1 hour ago
Joined: 2007-10-11 17:48
fat32 not sure

I finally tried the installation on a fat32 partition on my computer, this did work well, but did not on any media connected via usb. So from there I just carefully assume it could be some problem with usb communication, to tight timing in some steps of the install script or similar.

Otto Sykora
Basel, Switzerland

tapsklaps
Offline
Last seen: 5 years 9 months ago
Developer
Joined: 2010-10-17 08:11
script timeout probably the cause

If the slow data transmission due to the usb connection the cause is, therefore, must be available a script timeout, which caused the error. Due to my relative fast dual core processor I probably undercut this script timeout, so that the script was still running.

Log in or register to post comments