You are here

Google Chrome - disappearing settings/extensions?

12 posts / 0 new
Last post
htismaqe
Offline
Last seen: 6 years 7 months ago
Joined: 2010-10-01 10:54
Google Chrome - disappearing settings/extensions?

I recently lost my USB drive and had to start from scratch. I had been using Chromium Portable for a long time and was happy with it.

After the crash I was wanting to get back up and running fairly quickly so I tried out Maxthon. It didn't work well with KeePass (issues with window focus) so I downloaded Google Chrome Portable and went with that.

I had been using it for a couple of weeks until yesterday when I started it up and noticed it appeared to be reset to defaults and my bookmarks were gone.

The last time I shut it down was the night before and I had shutdown my PC right after. I was using RunLocally=true so I just figured I shut down before it finished copying my profile back to USB. I restored my profile from backup and went back to using it.

I shut it down yesterday afternoon and when I started it up about 30 minutes later, again it appeared to be back to default settings, my extensions were gone (the directory was actually empty), as were my bookmarks.

So I completely reinstalled Chrome from scratch and restored my profile from backup again. I set RunLocally=false thinking it was something with copying my profile back and forth to HDD.

I shut it down after restoring my settings and started it back up - my extensions were gone, all settings were at default, but this time my bookmarks were still there. I checked the GoogleChromePortable Data folder on my USB and the extensions directory was indeed empty.

It appears Chrome is erasing my settings and deleting my extensions when it shuts down.

Aluísio A. S. G.
Offline
Last seen: 6 years 6 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
Correct

Live mode (a.k.a. RunLocally) is not designed to copy settings back.

Previously known as kAlug.

htismaqe
Offline
Last seen: 6 years 7 months ago
Joined: 2010-10-01 10:54
I'm not talking about Chromium...

Chrome Portable absolutely works that way. It copied my profile back and forth just fine and subsequent testing with RunLocally set to false suggests that it was STILL successfully copying my profile back to USB - it was just deleting my extensions and settings prior to copying it back.

From the ChromePortable INI:

RunLocally=false
; Forces the profile to be copied to the local computer, as if the portable app
; is run from a CD. The profile will be copied back to the portable device
; afterwards (minus cache files).

Like I said, this isn't a problem with running from the local HDD, this a problem with Chrome Portable not preserving my settings. When running straight from USB, it erases my Extensions and settings when I shut it down.

thed0ctor
Offline
Last seen: 10 years 10 months ago
Joined: 2012-03-26 12:52
same problem..

I'm having this same problem where it doesn't seem to be copying back the settings... Has anyone figured out how to resolve this issue? I'm using it to speed up the portable chrome since it's slow running 100% from my flash drive.

htismaqe
Offline
Last seen: 6 years 7 months ago
Joined: 2010-10-01 10:54
It just happened again

and I was VERY careful to allow 4-5 minutes between shutting down ChromePortable and shutting down my PC.

For now, I'm going to disable RunLocally and see if it happens again.

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 12 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Should Disable

As none of the other apps have this feature and it is problematic, I think we'll just disable it. There's no real reason for it at this point.

Sometimes, the impossible can become possible, if you're awesome!

htismaqe
Offline
Last seen: 6 years 7 months ago
Joined: 2010-10-01 10:54
yeah, unfortunate...

I lost everything recently due to physical damage to my USB key. For me, the replacement decision came down to the profile of the unit - speed had to be secondary due to the amount of moving around I do.

I bought a Verbatim drive that is about the size of the wireless transceivers you see on mice (sticks out from the PC about 3-4mm). Unfortunately, running Chrome from this drive means that sometimes pages load instantly and sometimes take 30-40 seconds to load.

I originally tried Maxthon and Chrome again because of the upgrade process I had to do with Chromium Portable (re-compiling the launcher with every new release) but given the stability of the 7zip archive approach of Chromium Portable and the issues I've had, I've gone back to using it.

Aluísio A. S. G.
Offline
Last seen: 6 years 6 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
Challenge accepted

I'll start to provide pre-built launchers in the next release (that I hope to release as soon as I find out why the packed version doesn't work on Windows 7), however you will not be able to e.g. customize the archive's file name. I don't think this will be a problem, though.

A bit unrelated change: my latest build does have Java support. Just set the JAVA_HOME environment variable and it will do the rest Wink

Previously known as kAlug.

htismaqe
Offline
Last seen: 6 years 7 months ago
Joined: 2010-10-01 10:54
I don't use a custom archive name...

but I do use the packed version on Windows 7 and it works just fine. I'm assuming the issues are with the pre-built launcher?

Because I'm posting from Chromium Portable on Windows 7, launched from the packed version, right now...

Aluísio A. S. G.
Offline
Last seen: 6 years 6 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
Packed launcher

The packed launcher's Chrome.exe doesn't run on my school's machines. I'll try to run the normal launcher to make sure it's not blocked. If it is, expect a release tomorrow.

Previously known as kAlug.

htismaqe
Offline
Last seen: 6 years 7 months ago
Joined: 2010-10-01 10:54
Sounds good!

If you need any testing done, let me know.

Aluísio A. S. G.
Offline
Last seen: 6 years 6 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
Released

I tested it in another machine... it ran fine.
I'll release it with 14.0.835.15 (in "Pending Releases").
I'll post it in ~1.5 hours, it the Internet connection cooperates.
http://sourceforge.net/projects/crportable/files/PackedLauncher/14.0.835...

Previously known as kAlug.

Log in or register to post comments