You are here

Auto-update problem/bug when used on a hard drive: It just keeps downloading and re-updating 10.0.1

1 post / 0 new
Megafrog
Offline
Last seen: 3 months 3 weeks ago
Joined: 2009-01-03 01:52
Auto-update problem/bug when used on a hard drive: It just keeps downloading and re-updating 10.0.1

The subject/title just about says it all. I'm running it on Vista64 on the hard drive (because I hate installing anything I don't have to).

Every time I do the "check for apps" then supposedly "update" 10.0.0 to 10.0.1 as the "required platform update" it asks to close all instances of the PA platform, then click ok.

Then it starts up and shows the menu with NONE of my apps and without the custom picture in the upper right corner. I tell it to check for updates there and it says everything is up to date - which not particularly useful since it doesn't recognize even a single app other than the launcher!

It "updates" the portable apps platform in one directory ABOVE my actual app directory, which makes the "real" app directory from my shortcut link keep asking to update 10.0.1 and re-update again and again. Once I figured out I had to move the new one over the old, things were perfect again and auto update got the new apps.

Perhaps this problem happens since I use a shortened folder name rather than the long PortableApps.com official name for my directory. It should be mentioned though for troubleshooting/bug fixing purposes for those of us who prefer portable apps on a hard drive.

Regardless of the ultimate fix method, thank you for making a great product!