You are here

[Closed] German dictionary lost when upgrading LibreOffice

6 posts / 0 new
Last post
zappix
Offline
Last seen: 10 years 6 months ago
Joined: 2012-06-05 06:30
[Closed] German dictionary lost when upgrading LibreOffice

After the last upgrades of LibreOfficePortable the german dictionary (default, also system and installation language) doesn't work any more: no correction, no hyphenation.

Funny is, the dictionary still exists, is registered as an extension, so everthing seems okay, but it isn't shown among the languages in the linguistic options.

I had to do a fresh install to get it working as expected.

This happened twice, for the last two upgrades, so it doesn't seem to be fixed or addressed as a bug...

Rzeznik
Offline
Last seen: 8 months 1 week ago
Translator
Joined: 2009-12-09 06:14
Same with Polish

The dictionaries exist, the extension is installed, but in Options > Language Settings > Spelling there is only "Lightproof Grammar Checker (en)" language module available...

Need to reinstall LOP and manually remove unwanted dictionaries.

EDIT: None of install options works. Neither full install (from a file), nor with language removal. I found that Polish dictionary is not registered with Hunspell (it does not show up on the list of available languages when you select Options > Language Settings > Spelling; other languages are present).

Polish dictionary is very outdated (2008), and there are newer versions available, but its age doesn't seem to be the culprit as it worked fine in LOP 3.5.3...

Rzeznik
Offline
Last seen: 8 months 1 week ago
Translator
Joined: 2009-12-09 06:14
LOP 3.5.3 works fine

I reverted to LOP 3.5.3 (installation from a file over existing LOP 3.5.4, language removal enabled) and dictionaries work fine. So I guess some bad routine was incorporated into 3.5.4. I'll wait with update until Polish spell checking is available again.

John T. Haller
John T. Haller's picture
Online
Last seen: 20 min 30 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Remove Languages?

Did you remove languages (selected option) as you installed? If so, it disables all of them except English and the language you install in.

Sometimes, the impossible can become possible, if you're awesome!

Rzeznik
Offline
Last seen: 8 months 1 week ago
Translator
Joined: 2009-12-09 06:14
Polish as the second language

Yep, I used the language removal option and then full install. Repeated couple times, Polish is my default installation language. Everything is fine in 3.5.3, but in 3.5.4 Polish disappears as I wrote in my 1st post. Even in full install Polish dictionary is not associated with Hunspell, so spell check does not work though dictionaries exist.

John T. Haller
John T. Haller's picture
Online
Last seen: 20 min 30 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
LibreOffice Bug

This is a bug within LibreOffice itself. It can be fixed by manually re-syncing your extensions:
https://bugs.freedesktop.org/show_bug.cgi?id=50552#c8

The directories referenced are within the Data path.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments