You are here

Problems with running a script over commandline

2 posts / 0 new
Last post
mirc00
Offline
Last seen: 10 years 2 months ago
Joined: 2012-07-13 02:15
Problems with running a script over commandline

Hello guys,

i'm currently using Toucan 3.0.4 on my USB flash drive and i'm trying to get a self-made script working over commandline (CMD). My script looks like this:

sync([[Sync_Zeiterfassung_MKU]])
sync([[Sync_Zeiterfassung_MKU_Google]])
secure([[Secure_Zeiterfassung_MKU]])
secure([[Secure_Zeiterfassung_MKU_Google]])

those 4 jobs do exists. the first 2 just sync's one ".xls"-file each. the other 2 should encrypt those synced ".xls"-files in it's destination folder.

so what i did next, was to create a batch-file to run the created script above. the content of the batch-file looks like this:

IF EXIST "E:\Toucan\App\Toucan" (cd /D E:\Toucan\App\Toucan & toucan --script="dofile(getscript([[Test]]))" & pause) ELSE (echo Couldn't find Toucan & pause)

basically, this works to a certain point. here is a screenshot of the CMD while running this script:

http://i.imgur.com/ckNSX.png

as you can see, it does run the first 2 jobs (sync), but then just stucks. i do not get a "input password"-popup for the secure-jobs. it just stucks within the CMD after the sync-job. so.. is it even possible to run secure-jobs within a CMD? and if so, what did i do wrong?

thanks for any help!

mirc00
Offline
Last seen: 10 years 2 months ago
Joined: 2012-07-13 02:15
Nevermind guys.. i'm using

Nevermind guys.. i'm using Toucan 2.1.2 now and with that version it works.

Log in or register to post comments