You are here

[Closed] updater SendRequest download error with proxy

20 posts / 0 new
Last post
Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
[Closed] updater SendRequest download error with proxy

Hi there,
I have the following problem with downloading the updates for portable applications with the official updater:

- I get the SendRequest download error every time for every application
- the link that is given in the error message window works just fine when re-typed in the browser (FF and IE)
- the problem has been there for ... well, almost the beginning - the update worked only for a short some time when it was still new in the beta version of the platform, but not in all versions after that (I completely removed the platform and reinstalled, but no improvement)
- system is Win7, 32-bit

Does someone have any suggestions about this?

I really like the PA but manually updating the apps and it would be great to find the solution to this problem ...

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Other Software, Proxies

What other software is running on the PC in terms of antivirus, antimalware and software firewall? Are you in a corporate or university environment with a proxy? (ProxyGet can help you answer that if you are unsure) Have you tried a fresh install with all the default settings in another location just to ensure it's not a configuration issue? Do the 'online'/live portable app installers that download the app work for you (Google Chrome Portable, for instance)?

Sometimes, the impossible can become possible, if you're awesome!

Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
additional info

The answers to your question are:
- antivirus is Microsoft Forefront Endpoint Protection 2010
- firewall is default windows (Win7)
- it is a university environment
- proxy: unsure, running ProxyGet produces the following result "This computer is using a automatic proxy configuration script with an address of:
This Proxy Get Utility is made available by the friendly folks at PortableApps.com" - no address is actually given
- Google Chrome Portable installer works OK, downloads the app and installs it

I cannot try another location as I am using the suite on this computer only (installed on the hard disk, not on a removable medium)

Thanks for the help, I hope it's not too much fuss ...

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Proxy

It would likely be the proxy then. Though it is odd that the live app installer works and the updater doesn't. Could you do me a favor and try this updated PortableAppsUpdater.exe. Just replace your current one in the PortableApps\PortableApps.com directory. It's a tweaked timeout to give it as long as the online installer.

If that fails, do you even get the list of apps at least? Does everything fail? Have you tried any freeware apps (example: Quick Blackjack) as well as the open source ones?

Sometimes, the impossible can become possible, if you're awesome!

Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
no difference

I tried the updated updater, but still get an error.

I do get a list of available updates and can select which ones I have. Then it tries to download each one of them - after it says "connecting ..." I get the error report, then it moves to the next update, waits, reports an error and so on. After all updates fail, it suggests trying to update at another time.

Freeware apps fail as well.

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Password

Does your proxy have a password that it prompts you for? Do you get prompted with the online installers? How bout with the updater?

Could you try and delete the file WiseRegistryCleanerPortable.ico within the PortableApps\PortableApps.com\App\Graphics\AppIcons directory and then run the Get More Apps feature and see if that file is downloaded and replaced properly?

Sometimes, the impossible can become possible, if you're awesome!

Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
no password

I do not have a password and I am not prompted at any time. We have a (to my knowledge) usual LAN, the computers are in a university domain hooked on an internet cable.
The only prompt I get when running the updater (or "get more apps") is the warning from windows: "the publisher could not be verified" and so on ...

I deleted the icon and yes, it reappears when running "get more apps".

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Hmmm

The code in the updater to get the updater database and to get more icons is exactly the same as the code to download the installers, so something else is at play. Let me try a few more tests here and put together another possible test fix for you.

Sometimes, the impossible can become possible, if you're awesome!

Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
have to rush

I will have to leave the computer in a few minutes and won't be able to reach it until Monday - very sorry about that Sad but I'll certainly get back here at that time.

So thanks a lot for now and have a great weekend!

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Ok

No worries on having other things to do Smile I've marked this as a bug so it is properly tracked and will work with you on it next week.

Sometimes, the impossible can become possible, if you're awesome!

Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
back again

Hi,

This is just to let you know I'm back again and now I will be able to work on the problem again ...

Cheers

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Updater Useragent

Ok, try this patched version of the updater in 11.1 with an updated useragent. That's the only other thing I can think of to try and work with your proxy.

Sometimes, the impossible can become possible, if you're awesome!

Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
still not successful

I'm afraid this still does not solve the problem.

But, listen, apparently this is a very specific error that doesn't seem to affect many (if any) users besides me, so no need to worry too much.
Even in my case, while the problem makes the whole thing less convenient, it does not prevent me from using the PA - and it's still an excellent suite Smile

So thanks a lot for trying!

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
jPortable Installer

Does the jPortable live installer work? At this point, I think the firewall may be purposely blocking downloads from certain locations as well as some EXE downloads. Likely, they allow Google Chrome updates to be pulled. I'm curious about Java. But I'd wager they have sourceforge.net blocked unless you're using a browser.

Version 12.0 of the platform will have a manual proxy configuration as well. And I'll see about updating ProxyGet to get your whole proxy configuration for you as well. It is odd that it can't pull the address at the moment.

Sometimes, the impossible can become possible, if you're awesome!

Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
jPortable works ...

If I downloaded jPortable live installer from your web page, it installed java without problems (either by double-clicking it or installing it through PA platform ("Install a New App").
If I try to install it through "Get More Apps", I get the list of all available apps, can select it, but when clicking "Next", after a while the download fails, just as it does when trying to update.

The firewall is something I cannot change, I'm afraid, since it's managed by the institution.

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Useragent Patch

Does that happen even with the useragent patch I sent you applied? If that's the case, I think they do just block specific download points like SourceForge, then, unless you do it via a browser.

Sometimes, the impossible can become possible, if you're awesome!

Vince999
Offline
Last seen: 9 years 10 months ago
Joined: 2012-09-28 03:40
Useragent Patch - the same

Yes, it happens with the useragent patch as well.

Interestingly, a PA platform update just seems to have downloaded and installed without problems ...

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
12.0 Beta 2

Please try the current 12.0 beta and try the different proxy settings (automatic, direct aka no proxy, manual) to see which work.

UPDATE (2013-02-21): Closed due to lack of user response.

Sometimes, the impossible can become possible, if you're awesome!

22009
Offline
Last seen: 9 years 4 months ago
Joined: 2013-04-04 16:15
Have the same problem and

Have the same problem and tried 12.0 beta without success.
My PC is configured to enforce a proxy. If I set "direct connection" in Firefox I can work around this limitation.
However, setting direct connection in 12.0 Beta 2 doesn't work -> [ URL parts error ]. Manual proxy is no option.

siyman
Offline
Last seen: 8 years 11 months ago
Joined: 2013-08-22 06:21
Confirmation

Hey guys,

I can confirm the same problem - manual proxy connection remains with an [URL parts error] error. At first glance I though of a mistake (URL instead of direct IP) but after substitution with the correct server IP the problem persists.
Currently I'm inside a network which uses a strict firewall and checks every single download above some MB of size. Therefore I can get updates from PA, Chrome (excluded in firewall) and Java, but nothing else, which kind of describes perfectly the situation of the topic's starter.
If I can help in any way, please let me know. I'm interested in a working proxy mechanism in PA. Furthermore, if I'm allowed to, I'ld prefer some kind of user credentials for http proxy as well.

Beste regards,
siyman

Log in or register to post comments