You are here

Firefox or chrome slow/freezing

8 posts / 0 new
Last post
tibbi64
Offline
Last seen: 9 years 11 months ago
Joined: 2011-04-13 17:44
Firefox or chrome slow/freezing

Could it be my flash drive or the computer? But when I try and run either Firefox or chrome the browser is super slow and it freezes. It will say that Shockwave has stopped. Its only a 4 GB, I have a new 32 Gb I will try with a new install of PortableApps.

Thanks,

olneytj
Offline
Last seen: 9 years 11 months ago
Joined: 2012-11-01 17:50
menu/firefox hangup interaction

I have the same issue.

After much fiddling, I isolated it to this combination of things.

1) Launch from the portable apps menu.
2) try to play video somewhere. Youtube will do..

After about 4 minutes you get a this script is slow.
Again and again about 4 minutes apart.

Meanwhile, firefox is unresponsive.

BUT!!!! if you launch firefox from its own command, not using the menu, the stagnation doesn't happen. Youtube and everything else works just fine. Very strange.

Does the menu go looking for other things? Is it always doing callbacks to the very slow portable apps site. (56kps was the most recent download speed.)

I have solved my own problem by making some new shortcuts to use, but it really shouldn't be a problem...
TJ Olney

Ken Herbert
Ken Herbert's picture
Online
Last seen: 54 min 32 sec ago
DeveloperModerator
Joined: 2010-05-25 18:19
Just to clarify when you say

Just to clarify when you say you are not using the menu, are you running the app from Firefox.exe or FirefoxPortable.exe?

gluxon
gluxon's picture
Offline
Last seen: 2 years 4 weeks ago
Developer
Joined: 2008-06-21 19:26
Using the menu should not be

Using the menu should not be creating any different effects in your browser. It launches apps the same way Windows would.

olneytj
Offline
Last seen: 9 years 11 months ago
Joined: 2012-11-01 17:50
using menu

I didn't think it should make any difference either, but it does!
The menu is the portable apps launcher menu by the way and it is
launching the firefoxportable.exe file. Or the
firefoxportable2ndprofile.exe file.

Today, at this moment, it is working properly, but I have thought that it was OK before, only to have it hang the next time I access it from a different machine. Arrgh...

Maybe it's my local university network stopping it.
If I let it sit long enough, as in 10 minutes, I start to get
non-responsive script messages. The first ones from the remote site
and later ones from adblock plus. When I run without adblockplus it still
hangs. When I run it in safe-mode by changing the command in the ini file, it was still hanging.

Stay tuned.

Next Day... I behaves badly again. Starting from a "shortcut" to
U:\PortableApps\Firefox_Mktg_482\FirefoxPortable2ndProfile.exe
It worked fine...

Starting from portablapps.com menu item it hangs on youtube!
INI files listed below...
What is going on?

TJ

U is my network drive share
--------------------------------------
U:\PortableApps\Firefox_Mktg_482\Data\FirefoxPortable.INI
contains this.
[FirefoxPortable]
FirefoxDirectory=..\..\FirefoxPortable\App\firefox
ProfileDirectory=profile
SettingsDirectory=settings
PluginsDirectory=plugins

--------------------------------------------
U:\PortableApps\Firefox_Mktg_482\App\AppInfo\appinfo.ini
contains this:
[Format]
Type=PortableApps.comFormat
Version=1.0

[Details]
Name=Sales 482 Firefox, PE 2nd Profile
AppID=FirefoxPortable2ndProfile
Publisher=PortableApps.com
Homepage=http://voyager.cbe.wwu.edu/courses/482/
Category=Internet
Description=A secondary profile for Mozilla Firefox, Portable Edition
Language=Multilingual

[License]
Shareable=true
OpenSource=true
Freeware=true
CommercialUse=true

[Version]
PackageVersion=1.0.0.0
DisplayVersion=1.0

[Control]
Icons=1
Start=FirefoxPortable2ndProfile.exe
-----------------------------------

TJ

olneytj
Offline
Last seen: 9 years 11 months ago
Joined: 2012-11-01 17:50
startup methods yields different results. Menu start fails

Starting from a "shortcut" to
U:\PortableApps\Firefox_Mktg_482\FirefoxPortable2ndProfile.exe
It worked fine...

Starting from portablapps.com menu item it hangs on youtube!

This has been quite annoying. I have had to switch to using Opera
and it is missing a few of the features that I have come to depend on.

Any suggestions as to how to trouble shoot the issue?

Could it be using different .ini files?

Could it be looking to the local machine's installation for files?

Could it be trying to run the local machine's installed older version of firefox?

Could the launch from the menu trigger different anti-virus behavior?

I have checked the .INI files and all appear to have appropriate relative paths. Should I make them absolute paths?

TJ

John T. Haller
John T. Haller's picture
Online
Last seen: 6 min 1 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Regular

Let's start with your regular Firefox Portable install (aka NOT the 2nd profile one as that's a bit more hacky). Does that work properly in both instances? And if not, what does your FirefoxPortable.ini look like?

Sometimes, the impossible can become possible, if you're awesome!

olneytj
Offline
Last seen: 9 years 11 months ago
Joined: 2012-11-01 17:50
its a flash crash!

Thanks for thinking about what might be wrong.

No, the regular firefoxportable install did not work either. (btw, it did not appear on the portable apps menu.) Since I wrote the last post, I found an older flash nswf32.dll and got rid of the new ones. Now it works from everywhere again.

A second symptom of the newer flash is that the firefox plugin-container.exe does not get flushed from memory when firefox exits. The old one does.

Thanks for thinking about what might be wrong.

For the record, the main installation had:
firefoxportable.ini
[FirefoxPortableSettings]
AgreedToLicense=YES
LastProfileDirectory=U:\PortableApps\FirefoxPortable\Data\profile
[FirefoxPortable]
FirefoxDirectory=App\firefox
ProfileDirectory=Data\profile
SettingsDirectory=Data\settings
PluginsDirectory=Data\plugins
FirefoxExecutable=firefox.exe
AdditionalParameters=
LocalHomepage=
WaitForFirefox=false
DisableSplashScreen=false
AllowMultipleInstances=false
DisableIntelligentStart=false
SkipCompregFix=false
RunLocally=false

Many thanks. I'm getting progessively more annoyed with adobe/macromedia division.

TJ

Log in or register to post comments