You are here

GIMP: Error when logging in "Unable to load ZENautil.dll"

4 posts / 0 new
Last post
tridral
tridral's picture
Offline
Last seen: 10 years 2 months ago
Joined: 2012-02-20 06:34
GIMP: Error when logging in "Unable to load ZENautil.dll"

I've had several occurrences of the same problem logging into my work PC

Error when logging in "Unable to load ZENautil.dll"

Only re-imaging the PC seemed to fix the problem and then it would recur.

We eventually traced it to GIMP Portable. There is an article here:

http://www.wik12tech.org/index.php?option=com_kunena&func=view&catid=19&...

Which says that the problem is due to GIMP Portable renaming c:\windows\system32\xmlparse.dll

Is this a known problem with GIMP Portable? Is there a fix for this?

John T. Haller
John T. Haller's picture
Offline
Last seen: 10 hours 8 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Shouldn't Be There

The XML Parse file is placed in system32 by a very poorly configured, very outdated app from Novell that most modern PCs should no longer be running. The DLL should be in its own directory NOT in system32. The xmlparse.dll file in system32 breaks several apps including GIMP. The only way to fix it is to temporarily rename it while GIMP is running. GIMP Portable handles this for you. But, if you don't properly close down GIMP Portable by exiting it, it won't get renamed back. So, close GIMP properly. Be sure not to just shutdown Windows or unplug the PC (both of which crash it).

Sometimes, the impossible can become possible, if you're awesome!

tridral
tridral's picture
Offline
Last seen: 10 years 2 months ago
Joined: 2012-02-20 06:34
Thank you for the

Thank you for the explanation. It certainly explains what I've been seeing. I've passed it on to our technical people. We're moving from Windows XP to Windows 7. I hope Windows 7 won't have the same problem!

John T. Haller
John T. Haller's picture
Offline
Last seen: 10 hours 8 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Not Windows

It's not Windows, it's your Novell networking client. It breaks local GIMP and other software, too. I think it's from 2005 or earlier and doesn't work on Windows 7, though.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments