You are here

Qbittorrent always gives error message when I exit

20 posts / 0 new
Last post
boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
Qbittorrent always gives error message when I exit

I'm using qBittorrent 3.0.9. Every time I exit the program I get an error message that says "qbittorrent.exe has stopped working. A problem caused the program to stop working correctly. Please close the program." Then I click on the 'close program' button and it exits. Why does it do this every time? I haven't downloaded anything with qbittorrent yet.

I also installed the non-portable version of qbittorrent to see if it did the same thing but it exits without any problem.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 9 hours 9 min ago
DeveloperModerator
Joined: 2008-07-24 18:46
Can't duplicate

How are you exiting? I'm not seeing this error at all, so maybe it's something to do with your workflow?

It could also be some messed up preferences. Try deleting qBittorrentPortable/Data and see if that fixes your problem.

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
I either go to File menu and

I either go to File menu and exit or I click on the close button and they both cause the error.

Deleting the Data folder did not help.

Also, the installer won't let me install to certain locations like the C:\Program Files (x86) folder. It says "the destination folder you located is invalid. Please choose a valid folder. [C:\Program Files (x86) or sub-directories]

So it recommends I install to C:\Program Files (x86) but then it doesn't let me when I try. Seems like the portable version doesn't like my computer.

Bennieboj
Bennieboj's picture
Offline
Last seen: 3 years 7 months ago
Joined: 2010-09-16 07:28
No program files

You can't install PortableApps in the program files (be it Program Files or Program Files (x86)). Some apps will act differently if they are located in there.

As for QBittorrent, I've used it a few times, never had this problem.
Maybe it has something to do with your installation (maybe the path, or the torrents,...) A fresh install works fine here, maybe download all your torrents and try a fresh install?

Yes, I set the working directory!

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
Thanks for informing me about

Thanks for informing me about the Program files folder.

I have tried a fresh install to multiple locations and I always get the error message when I exit. Is there some program that could conflict with qBittorrent?

When I exit the program, qbittorrent.exe and qbittorrentportable.exe are still in Task Manager. They don't disappear until I actually click the Close Program button in the error message.

Bennieboj
Bennieboj's picture
Offline
Last seen: 3 years 7 months ago
Joined: 2010-09-16 07:28
official forums?

So if it also happens with a fresh install, it should also happen with a local install, I guess.
I can't find anybody that has the same problem though.
Maybe you could post this on the Qbittorrent forums, since this probably is a problem with the base app not with the portabilisation of it.
Though the problem most likely won't be with the app itself but, like you already suggested, with some conflicting program. They can help you find out what's wrong.

Yes, I set the working directory!

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
I have installed the regular

I have installed the regular non-portable version of qbittorrent and the problem does not occur.

Bennieboj
Bennieboj's picture
Offline
Last seen: 3 years 7 months ago
Joined: 2010-09-16 07:28
I'm out of ideas here...

I really don't know what the launcher does to Qbittorrent that it doesn't do to another app. Do other portableapps give you the same problem?

Yes, I set the working directory!

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
I think the only other

I think the only other portable app I have is Google Chrome and it seems to work fine. I don't get any error messages with it.

I've been using qbittorrent portable despite this problem as my settings and files are still being rememberd and saved. Strangely when I added a torrent I got the same exit error message but qbittorrent did not close. I clicked the 'close program' button and nothing else happened. But it didn't do this for the first torrent I added.

I also noticed qbittorrent.exe is using 175 MB of RAM in task manager and I only have one torrent active at the moment. Is that normal?

Bennieboj
Bennieboj's picture
Offline
Last seen: 3 years 7 months ago
Joined: 2010-09-16 07:28
Sorry, I can't help you more :/

I don't know what causes the problem :/
175 MB of RAM ain't normal I think, it starts at ~32MB for me, then it increases slowly, but certainly not 175MB.
If you want another portable torrent app, you can try µTorrent Portable.

Yes, I set the working directory!

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
Ya it starts out at around

Ya it starts out at around ~30 MB for me too. I don't know why this portable app is acting so pissy with my computer.

John T. Haller
John T. Haller's picture
Offline
Last seen: 9 hours 22 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Program Files

That message means that C:\Program Files (x86) and sub-directories are invalid. It's not recommending you install there.

As for the issue, what is your full install path of the app, operating system version, what else is running on the system, etc?

Sometimes, the impossible can become possible, if you're awesome!

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
I'm using win7 x64. I've

I'm using win7 x64. I've tried numerous install paths on different drives, C:\qbittorrentportable, Y:\qbittorrentportable, etc. I have lots of things running on my system. I have tried turning off as many running programs as I can in system tray and task manager. Nothing helps.

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
Anyone know where I can

Anyone know where I can download an older version of portable qbittorrent? I want to see if the same thing happens with 3.0.8.

Bennieboj
Bennieboj's picture
Offline
Last seen: 3 years 7 months ago
Joined: 2010-09-16 07:28
Good luck =)

Yes, I set the working directory!

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
thanks Bennieboj!

thanks Bennieboj!

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
So I downloaded v3.0.8 and it

So I downloaded v3.0.8 and it had the same problem. Then I downloaded v3.0.6 rev2 and it worked fine, no error message.

Is there a way to find out what's different about 3.0.6 and the newer versions when exiting?

Bennieboj
Bennieboj's picture
Offline
Last seen: 3 years 7 months ago
Joined: 2010-09-16 07:28
Post to forums

Yes, there is: post this issue to their forums.

I've compared v3.0.6rev2 and v3.0.8 in terms of portabilisation and it's exactly the same. (qBittorrentPortable.ini and custom.nsh are identical in both packages...)
So, I guess it should be a problem with the main app, but then again you said the problem didn't occur on a local install. What version was that local install, if I may ask?

Yes, I set the working directory!

boogadie
Offline
Last seen: 7 years 9 months ago
Joined: 2013-04-03 20:26
It was v3.0.9

It was v3.0.9. They won't help with any issues concerning the portable version since it's not officially supported.

I mentioned previously I get this same error message whenever I add a new torrent from my browser. But this also doesn't happen with v3.0.6. This is very strange. Am I the only one experiencing this?

Bennieboj
Bennieboj's picture
Offline
Last seen: 3 years 7 months ago
Joined: 2010-09-16 07:28
No difference

There's no difference between the portabilisation of v3.0.6rev2, v3.0.8 or v3.0.9 as far as I can tell.
Did you already ask it on the official forums? It doesn't hurt to ask.
If you really need a torrent client, you can always use UtorrentPortable in the meantime.
Maybe a new Qbittorrent release fixes the issue, who knows Smile

Yes, I set the working directory!

Log in or register to post comments