You are here

[Fixed] Language Code setting keeps replicating at the end of filezilla.xml

8 posts / 0 new
Last post
surreal
Offline
Last seen: 7 years 10 months ago
Joined: 2013-07-11 01:38
[Fixed] Language Code setting keeps replicating at the end of filezilla.xml

FileZillaPortable\Data\settings\filezilla.xml

The "Language Code" setting kept replacing the entry inside the settings list before the close with:

<Setting name="Language Code" />

And kept adding duplicate entries at the end of the file after the and closing paramaters every time I went in and saved any settings.

</LastServer>
</Settings>
</FileZilla3>
<Setting name="Language Code" />
<Setting name="Language Code" />
<Setting name="Language Code" />

I tried to manually edit the setting in the main area to:

<Setting name="Language Code"> </Setting>

and it kept resetting it back to:

<Setting name="Language Code" />

Since there are no entries in the Language list in portable, I went into regular FileZilla, selected English and copied over the setting line from there into the portable filezilla.xml:

<Setting name="Language Code">en</Setting>

So far, just checking today, this manual edit has stopped this behavior.

I haven't tried 3.7.1.1 yet.

FileZilla 3.7.1 Portable

Windows 7 Enterprise SP1 64-bit

Install Options selected:
"Please select the language for the installer" - English
"Additional Languages" - Unchecked

Tata Yoyo
Offline
Last seen: 7 years 4 months ago
Joined: 2015-09-21 19:15
Language Code setting keeps replicating at the end of filezilla.

—————————
This is a very old post but I had the problem too with the recent version :

Version 3.14.0 for Windows, Multilingual
6MB download / 14-22MB installed

The solution provided above didn't succeed for me but the following will :

Open FilezillaPortable.ini and in :
App --> AppInfo --> Launcher -->

and replace the following block :

——————————————————
[FileWrite1]
Type=ConfigWrite
File=%PAL:DataDir%\settings\filezilla.xml
Entry='        <Setting name="Language Code">'
Value=%PAL:LanguageCustom%</Setting>

[FileWrite2]
——————————————————

By this :

——————————————————
[FileWrite1]
Type=ConfigWrite
File=%PAL:DataDir%\settings\filezilla.xml
Entry='        <Setting name="Language Code">'
Value=%PAL:LanguageCustom%
TrimRight=</Setting>

[FileWrite2]
——————————————————

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 2 days 23 hours ago
DeveloperModerator
Joined: 2008-07-24 18:46
Not tracked

This was not yet being tracked, due to the [Bug] tag having been missed in the subject. I have fixed that, so we can take care of the change.

John T. Haller
John T. Haller's picture
Online
Last seen: 47 min 53 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Tracked

I've got a note to fix this in the next FileZilla release now. Anyone tested this yet? If not, I'll have to pre-release.

Sometimes, the impossible can become possible, if you're awesome!

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 2 days 23 hours ago
DeveloperModerator
Joined: 2008-07-24 18:46
Will check

I'll check this in the morning, possibly tonight if I get a chance.

[EDIT] I just got a chance to test this. While the provided fix would work, It's not the most appropriate fix. I'll write up proper xml-handling code and attach the fix here, or send you a Rev 2, whichever you prefer.

John T. Haller
John T. Haller's picture
Online
Last seen: 47 min 53 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fixed in 3.14.1

This is fixed in FileZilla Portable 3.14.1

Sometimes, the impossible can become possible, if you're awesome!

Rolf Ohnmacht
Offline
Last seen: 7 years 3 months ago
Joined: 2015-10-24 05:24
Error in filezilla.xml after installing 3.14.1

After installing 3.14.1 this morning I had this error, so I think the above solution does not work.

I now tried this one and it works for me. After changing FileZilla loads without errors. Can you try this (FileZillaPortable.ini) :

[FileWrite1]
Type=ConfigWrite
File=%PAL:DataDir%\settings\filezilla.xml
Entry=' <Setting name="Language Code">'
Value='%PAL:LanguageCustom%</Setting>'

John T. Haller
John T. Haller's picture
Online
Last seen: 47 min 53 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Switching Removed

As both versions cause issues, I've removed language switching in Rev 2. It may be restored in a later version.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments